aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-05-11 12:41:06 +0000
committerDima Panov <fluffy@FreeBSD.org>2021-05-11 12:41:06 +0000
commit50ea41c1535f68834fe08a1a2625eb0f930f3bca (patch)
tree8b8330d0680939bb1f7b105f25e7c730abcb1497
parent4c56dd3352784ee9105f873c5b6a32d52e43b682 (diff)
downloadports-50ea41c1535f68834fe08a1a2625eb0f930f3bca.tar.gz
ports-50ea41c1535f68834fe08a1a2625eb0f930f3bca.zip
net/ceph14: unbreak build after recent API changes in archivers/snappy
Snappy now drops own rewrite for cstdint types such as uint32_t Bump PORTREVISION to force rebuid with new snappy API changes Pointyhat to: vanilla (for skip consumers' testbuilds)
-rw-r--r--net/ceph14/Makefile2
-rw-r--r--net/ceph14/files/patch-src_compressor_snappy_SnappyCompressor.h19
2 files changed, 20 insertions, 1 deletions
diff --git a/net/ceph14/Makefile b/net/ceph14/Makefile
index 0b3fba537051..22c90093c3de 100644
--- a/net/ceph14/Makefile
+++ b/net/ceph14/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ceph
DISTVERSIONPREFIX= v
DISTVERSION= 14.2.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
PKGNAMESUFFIX= 14
diff --git a/net/ceph14/files/patch-src_compressor_snappy_SnappyCompressor.h b/net/ceph14/files/patch-src_compressor_snappy_SnappyCompressor.h
new file mode 100644
index 000000000000..313c4edb8265
--- /dev/null
+++ b/net/ceph14/files/patch-src_compressor_snappy_SnappyCompressor.h
@@ -0,0 +1,19 @@
+--- src/compressor/snappy/SnappyCompressor.h.orig 2020-08-10 20:15:22 UTC
++++ src/compressor/snappy/SnappyCompressor.h
+@@ -15,6 +15,7 @@
+ #ifndef CEPH_SNAPPYCOMPRESSOR_H
+ #define CEPH_SNAPPYCOMPRESSOR_H
+
++#include <cstdint>
+ #include <snappy.h>
+ #include <snappy-sinksource.h>
+ #include "common/config.h"
+@@ -96,7 +97,7 @@ class SnappyCompressor : public Compressor {
+ if (qat_enabled)
+ return qat_accel.decompress(p, compressed_len, dst);
+ #endif
+- snappy::uint32 res_len = 0;
++ std::uint32_t res_len = 0;
+ BufferlistSource source_1(p, compressed_len);
+ if (!snappy::GetUncompressedLength(&source_1, &res_len)) {
+ return -1;