aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2021-05-21 19:23:45 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2021-05-21 20:19:47 +0000
commit7c225866d104ab530683ecc8439806505e15f6c4 (patch)
tree249f036d48293358840f21a69b20e6444d728107
parent4f7a0060c2ab8c1eb13183c3497813e0a5f0e881 (diff)
downloadports-7c225866d104ab530683ecc8439806505e15f6c4.tar.gz
ports-7c225866d104ab530683ecc8439806505e15f6c4.zip
emulators/aqemu: clean up port
- Drop needless linguisttools_build, the port does not use translations. - Drop noninja. Works for me, have no idea why it was set in the first place. - Correctly use rcc to fix build once misc/qtchooser is removed
-rw-r--r--emulators/aqemu/Makefile4
-rw-r--r--emulators/aqemu/files/patch-CMakeLists.txt11
2 files changed, 12 insertions, 3 deletions
diff --git a/emulators/aqemu/Makefile b/emulators/aqemu/Makefile
index a0d8231fb8d2..893673cca53e 100644
--- a/emulators/aqemu/Makefile
+++ b/emulators/aqemu/Makefile
@@ -12,8 +12,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libvncclient.so:net/libvncserver
-USES= cmake:noninja compiler:c++11-lang qt:5
-USE_QT= buildtools_build linguisttools_build qmake_build \
+USES= cmake compiler:c++11-lang qt:5
+USE_QT= buildtools_build qmake_build \
core dbus gui network printsupport testlib widgets
USE_GITHUB= yes
diff --git a/emulators/aqemu/files/patch-CMakeLists.txt b/emulators/aqemu/files/patch-CMakeLists.txt
index 1b6d97bdf8a9..f09f8e6e6d48 100644
--- a/emulators/aqemu/files/patch-CMakeLists.txt
+++ b/emulators/aqemu/files/patch-CMakeLists.txt
@@ -1,5 +1,14 @@
---- CMakeLists.txt.orig 2017-12-31 01:02:19 UTC
+--- CMakeLists.txt.orig 2016-05-31 12:34:02 UTC
+++ CMakeLists.txt
+@@ -285,7 +285,7 @@ MACRO( pack_icons _sources )
+
+ SET( _out ${CMAKE_CURRENT_SOURCE_DIR}/${_basename}.rcc )
+
+- ADD_CUSTOM_COMMAND( OUTPUT ${_out} COMMAND rcc ARGS ${_in} -binary -o ${_out} DEPENDS ${_in} )
++ ADD_CUSTOM_COMMAND( OUTPUT ${_out} COMMAND ${Qt5Core_RCC_EXECUTABLE} ARGS ${_in} -binary -o ${_out} DEPENDS ${_in} )
+
+ SET( ${_sources} ${${_sources}} ${_out} )
+ ENDFOREACH( curFile )
@@ -327,11 +327,11 @@ IF( INSTALL_MAN )
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR} )