aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2021-06-18 11:27:29 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2021-06-18 11:28:38 +0000
commite1447306b7cb864cb73987da0ccd69b0de147b52 (patch)
tree7cad849550f4b026156f528ead3e93eb29f41dd7
parentfd3ddcabac2eaa421903819697de73add5f71930 (diff)
downloadports-e1447306b7cb864cb73987da0ccd69b0de147b52.tar.gz
ports-e1447306b7cb864cb73987da0ccd69b0de147b52.zip
net/haproxy: fix build with Prometheus exporter enabled.
Reported by: Johan Hendriks <joh.hendriks@gmail.com>
-rw-r--r--net/haproxy-devel/Makefile2
-rw-r--r--net/haproxy/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/haproxy-devel/Makefile b/net/haproxy-devel/Makefile
index f4e67b872b17..d2e04af71966 100644
--- a/net/haproxy-devel/Makefile
+++ b/net/haproxy-devel/Makefile
@@ -38,7 +38,7 @@ SPCRE_LIB_DEPENDS= libpcre.so:devel/pcre
SPCRE_MAKE_ARGS= USE_PCRE=1 USE_STATIC_PCRE=1 USE_PCRE_JIT=1
DEVICEATLAS_LIB_DEPENDS= libda.so:net/deviceatlas-enterprise-c
DEVICEATLAS_MAKE_ARGS= USE_DEVICEATLAS=1 DEVICEATLAS_LIB=${LOCALBASE}/lib DEVICEATLAS_INC=${LOCALBASE}/include
-PROMEX_MAKE_ARGS= EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
+PROMEX_MAKE_ARGS= USE_PROMEX=1
OPENSSL_USES= ssl
OPENSSL_MAKE_ARGS= USE_OPENSSL=1 SSL_LIB=${OPENSSLLIB} SSL_INC=${OPENSSLINC}
LUA_USES= lua:53
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 7f36e69edec2..875a163eb750 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -43,7 +43,7 @@ SPCRE_LIB_DEPENDS= libpcre.so:devel/pcre
SPCRE_MAKE_ARGS= USE_PCRE=1 USE_STATIC_PCRE=1 USE_PCRE_JIT=1
DEVICEATLAS_LIB_DEPENDS= libda.so:net/deviceatlas-enterprise-c
DEVICEATLAS_MAKE_ARGS= USE_DEVICEATLAS=1 DEVICEATLAS_LIB=${LOCALBASE}/lib DEVICEATLAS_INC=${LOCALBASE}/include
-PROMEX_MAKE_ARGS= EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
+PROMEX_MAKE_ARGS= USE_PROMEX=1
OPENSSL_USES= ssl
OPENSSL_MAKE_ARGS= USE_OPENSSL=1 SSL_LIB=${OPENSSLLIB} SSL_INC=${OPENSSLINC}
LUA_USES= lua:53