aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-11 18:45:06 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 00:33:47 +0000
commitf99057b3c2e7980852b1be4ab86a5cacaf8ad457 (patch)
tree4f0c74fa1709b0d07f7543e69be8b9ca403357ab
parent447c9c7b2dc1bcedff5c7f130b6e5eca79ac1217 (diff)
downloadports-f99057b3c2e7980852b1be4ab86a5cacaf8ad457.tar.gz
ports-f99057b3c2e7980852b1be4ab86a5cacaf8ad457.zip
graphics/hugin: make compatible with OpenEXR/Imath 3.0
-rw-r--r--graphics/hugin/Makefile14
-rw-r--r--graphics/hugin/files/patch-CMakeModules_FindOpenEXR.cmake29
2 files changed, 38 insertions, 5 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 41c4cc563f35..fa6849503982 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -2,15 +2,15 @@
PORTNAME= hugin
PORTVERSION= 2019.2.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
MAINTAINER= grog@FreeBSD.org
COMMENT= GUI for Panorama Tools, to stitch panoramic images
-LIB_DEPENDS= libIlmImf.so:graphics/openexr \
- libImath.so:graphics/ilmbase \
+LIB_DEPENDS= libOpenEXR.so:graphics/openexr \
+ libImath.so:math/Imath \
libboost_thread.so:devel/boost-libs \
liblcms2.so:graphics/lcms2 \
libexiv2.so:graphics/exiv2 \
@@ -26,13 +26,17 @@ RUN_DEPENDS= enblend>=4.1.4:graphics/enblend \
LICENSE= GPLv2
+CFLAGS+= -I${LOCALBASE}/include/Imath
+
BROKEN_i386= Fails to build: ld: error: src/hugin_base/libhuginbase.so.0.0: undefined reference to __atomic_load
USES= cmake compiler:c++11-lib desktop-file-utils gettext gl gnome \
- jpeg pkgconfig shared-mime-info shebangfix sqlite tar:bzip2
+ jpeg pkgconfig shared-mime-info shebangfix sqlite tar:bzip2 xorg
CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG}
+USE_GL= gl glew glu glut
USE_WX= 3.0+
-USE_GL= glew glut
+USE_XORG= x11
+
INSTALLS_ICONS= yes
SHEBANG_FILES= src/hugin_script_interface/hpi.py \
diff --git a/graphics/hugin/files/patch-CMakeModules_FindOpenEXR.cmake b/graphics/hugin/files/patch-CMakeModules_FindOpenEXR.cmake
new file mode 100644
index 000000000000..c11324c7eafe
--- /dev/null
+++ b/graphics/hugin/files/patch-CMakeModules_FindOpenEXR.cmake
@@ -0,0 +1,29 @@
+--- CMakeModules/FindOpenEXR.cmake.orig 2019-12-07 08:35:27 UTC
++++ CMakeModules/FindOpenEXR.cmake
+@@ -35,7 +35,7 @@ ENDIF (NOT WIN32 OR MINGW)
+ include(FindLibraryWithDebug)
+ find_library_with_debug(OPENEXR_HALF_LIBRARY
+ WIN32_DEBUG_POSTFIX d
+- NAMES Half-2_3 Half
++ NAMES Imath
+ PATHS
+ ${_OPENEXRLinkDir}
+ ${SYSTEM_LIB_DIRS}
+@@ -45,7 +45,7 @@ ENDIF (NOT WIN32 OR MINGW)
+
+ find_library_with_debug(OPENEXR_IEX_LIBRARY
+ WIN32_DEBUG_POSTFIX d
+- NAMES Iex-2_3 Iex-2_2 Iex
++ NAMES Iex
+ PATHS
+ ${_OPENEXRLinkDir}
+ ${SYSTEM_LIB_DIRS}
+@@ -76,7 +76,7 @@ ENDIF (NOT WIN32 OR MINGW)
+
+ find_library_with_debug(OPENEXR_ILMIMF_LIBRARY
+ WIN32_DEBUG_POSTFIX d
+- NAMES IlmImf-2_3 IlmImf-2_2 IlmImf
++ NAMES OpenEXR
+ PATHS
+ ${_OPENEXRLinkDir}
+ ${SYSTEM_LIB_DIRS}