aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/tcl87/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/lang/tcl87/Makefile b/lang/tcl87/Makefile
index 4d9ce8770456..e4a135095557 100644
--- a/lang/tcl87/Makefile
+++ b/lang/tcl87/Makefile
@@ -2,7 +2,7 @@
PORTNAME= tcl
DISTVERSION= ${TCL_VERSION}${TCL_RC}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= SF/tcl/Tcl/${TCL_VERSION} \
TCLTK/tcl8_7
@@ -17,7 +17,9 @@ LICENSE_NAME= Tcl/Tk License
LICENSE_FILE= ${WRKSRC}/../license.terms
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= compiler:c11 pathfix
+USES= compiler:c11 localbase pathfix
+
+LIB_DEPENDS= libtommath.so:math/libtommath
OPTIONS_DEFINE= TCLMAN TZDATA DEBUG
OPTIONS_DEFAULT=TCLMAN TZDATA
@@ -52,7 +54,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared \
--enable-man-suffix=.${MAN_SUFFIX} \
--includedir=${PREFIX}/include/tcl${TCL_VER} \
- --enable-symbols
+ --enable-symbols \
+ --with-system-libtommath
TCL_VERSION= 8.7a5
TCL_VER= 8.7