aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-07-08 12:31:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-08 15:26:07 +0000
commit2ada39de05b12da1d1083c40ad676c061b6e8a70 (patch)
tree024d31b29567c34bb0e050cf61d8a8466ac349ab
parent10f130e9152c6b2685676b02721219307de105d0 (diff)
downloadports-2ada39de05b12da1d1083c40ad676c061b6e8a70.tar.gz
ports-2ada39de05b12da1d1083c40ad676c061b6e8a70.zip
devel/py-pytest: update to 7.1.1
PR: 256624 Approved by: maintainer timeout (python@, 9 months)
-rw-r--r--devel/py-pytest/Makefile27
-rw-r--r--devel/py-pytest/distinfo6
-rw-r--r--devel/py-pytest/files/patch-testing-test_parseopt.py11
3 files changed, 14 insertions, 30 deletions
diff --git a/devel/py-pytest/Makefile b/devel/py-pytest/Makefile
index e5bd19934673..7981cbebdd85 100644
--- a/devel/py-pytest/Makefile
+++ b/devel/py-pytest/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pytest
-PORTVERSION= 4.6.11
+PORTVERSION= 7.1.1
PORTEPOCH= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
@@ -14,14 +14,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pytest4
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}atomicwrites>=1.0:devel/py-atomicwrites@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}attrs>=17.4.0:devel/py-attrs@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}more-itertools>=4.0.0:devel/py-more-itertools@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=19.2.0:devel/py-attrs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pluggy>=0.12<1.0:devel/py-pluggy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}py>=1.5.0:devel/py-py@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}wcwidth>=0:devel/py-wcwidth@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}py>=1.8.2:devel/py-py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tomli>=0:textproc/py-tomli@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}iniconfig>=0:devel/py-iniconfig@${PY_FLAVOR}
TEST_DEPENDS= bash:shells/bash \
lsof:sysutils/lsof \
${PYTHON_PKGNAMEPREFIX}argcomplete>=0:devel/py-argcomplete@${PY_FLAVOR} \
@@ -32,13 +30,14 @@ TEST_DEPENDS= bash:shells/bash \
${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pexpect>=0:misc/py-pexpect@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-xdist>=1.13:devel/py-pytest-xdist@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xmlschema>=0:textproc/py-xmlschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}unittest2>=0:devel/py-unittest2@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}asynctest>=0:devel/py-asynctest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=2.7.2:textproc/py-pygments@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
@@ -49,12 +48,8 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0.12:devel/py-importlib-metadata@${PY_FLAVOR}
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' ${WRKSRC}/testing/test_parseopt.py
-
-# test_cache_failure_warns fails
-# https://github.com/pytest-dev/pytest/issues/1845
+# XXX: test_pdb_custom_cls_with_set_trace fails
do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs -k 'not test_cache_failure_warns'
+ cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs
.include <bsd.port.post.mk>
diff --git a/devel/py-pytest/distinfo b/devel/py-pytest/distinfo
index db173fdad5c5..a9e43a42a4a4 100644
--- a/devel/py-pytest/distinfo
+++ b/devel/py-pytest/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620405525
-SHA256 (pytest-4.6.11.tar.gz) = 50fa82392f2120cc3ec2ca0a75ee615be4c479e66669789771f1758332be4353
-SIZE (pytest-4.6.11.tar.gz) = 952305
+TIMESTAMP = 1648037418
+SHA256 (pytest-7.1.1.tar.gz) = 841132caef6b1ad17a9afde46dc4f6cfa59a05f9555aae5151f73bdf2820ca63
+SIZE (pytest-7.1.1.tar.gz) = 1255528
diff --git a/devel/py-pytest/files/patch-testing-test_parseopt.py b/devel/py-pytest/files/patch-testing-test_parseopt.py
deleted file mode 100644
index 22683ffee3af..000000000000
--- a/devel/py-pytest/files/patch-testing-test_parseopt.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- testing/test_parseopt.py.orig 2020-06-05 12:09:03 UTC
-+++ testing/test_parseopt.py
-@@ -305,7 +305,7 @@ def test_argcomplete(testdir, monkeypatch):
- # redirect output from argcomplete to stdin and stderr is not trivial
- # http://stackoverflow.com/q/12589419/1307905
- # so we use bash
-- fp.write('COMP_WORDBREAKS="$COMP_WORDBREAKS" python -m pytest 8>&1 9>&2')
-+ fp.write('COMP_WORDBREAKS="$COMP_WORDBREAKS" %%PYTHON_CMD%% -m pytest 8>&1 9>&2')
- # alternative would be exteneded Testdir.{run(),_run(),popen()} to be able
- # to handle a keyword argument env that replaces os.environ in popen or
- # extends the copy, advantage: could not forget to restore