aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-06 22:04:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-06 22:38:34 +0000
commit35a9ac41d04e7bee62e88a2fc13eb3028b9476c7 (patch)
tree80bc8db2d7d0e87ec4ad6e6d1aa8843561fc495a
parent44e082fa23826301245f27b4f4305435eaa2c330 (diff)
downloadports-35a9ac41d04e7bee62e88a2fc13eb3028b9476c7.tar.gz
ports-35a9ac41d04e7bee62e88a2fc13eb3028b9476c7.zip
devel/py-pytest-{pep8,translations}: switch to pytest4
These plugins are not compatible with recent pytest. Consumers (sysutils/iocage and www/py-flask-security) were switched to pytest4 as well. Note that py-flask-security tests were and still are broken due to unrelated problem - py-sqlalchemy12 and py-sqlalchemy14 conflict. PR: 256624
-rw-r--r--devel/py-pytest-pep8/Makefile4
-rw-r--r--devel/py-pytest-translations/Makefile2
-rw-r--r--sysutils/iocage/Makefile4
-rw-r--r--www/py-flask-security/Makefile8
4 files changed, 9 insertions, 9 deletions
diff --git a/devel/py-pytest-pep8/Makefile b/devel/py-pytest-pep8/Makefile
index 9149d093bdc6..fa0036e7a504 100644
--- a/devel/py-pytest-pep8/Makefile
+++ b/devel/py-pytest-pep8/Makefile
@@ -10,8 +10,8 @@ COMMENT= Pytest plugin to check PEP8 requirements
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.4.2:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-cache>=0:devel/py-pytest-cache@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest4>=2.4.2:devel/py-pytest4@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest4-cache>=0:devel/py-pytest4-cache@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pep8>=1.3:devel/pep8@${PY_FLAVOR}
USES= python:3.6+
diff --git a/devel/py-pytest-translations/Makefile b/devel/py-pytest-translations/Makefile
index d57ff7d39296..63f043fd302d 100644
--- a/devel/py-pytest-translations/Makefile
+++ b/devel/py-pytest-translations/Makefile
@@ -12,7 +12,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0:devel/py-pbr@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest4>=0:devel/py-pytest4@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}polib>=0:devel/py-polib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}enchant>=0:textproc/py-enchant@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}testscenarios>=0:devel/py-testscenarios@${PY_FLAVOR} \
diff --git a/sysutils/iocage/Makefile b/sysutils/iocage/Makefile
index c0bb15ee98ba..46e49c0358b4 100644
--- a/sysutils/iocage/Makefile
+++ b/sysutils/iocage/Makefile
@@ -16,8 +16,8 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest4>0:devel/py-pytest4@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest4-cov>0:devel/py-pytest4-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-pep8>0:devel/py-pytest-pep8@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}netifaces>0:net/py-netifaces@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}click>=6.7:devel/py-click@${PY_FLAVOR} \
diff --git a/www/py-flask-security/Makefile b/www/py-flask-security/Makefile
index 6307b2a0a6bb..24822b816ac8 100644
--- a/www/py-flask-security/Makefile
+++ b/www/py-flask-security/Makefile
@@ -30,10 +30,10 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flask-sqlalchemy>=0:databases/py-flask-sqla
${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mongoengine>=0:databases/py-mongoengine@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydocstyle>=0:devel/py-pydocstyle@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-cache>=0:devel/py-pytest-cache@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-flakes>=0:devel/py-pytest-flakes@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest4-cache>=0:devel/py-pytest4-cache@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest4-cov>=0:devel/py-pytest4-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest4-flakes>=0:devel/py-pytest4-flakes@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest4>=0:devel/py-pytest4@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy12>=0:databases/py-sqlalchemy12@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-translations>=0:devel/py-pytest-translations@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-pep8>=0:devel/py-pytest-pep8@${PY_FLAVOR} \