aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Takacs <nimaje+fbz@bureaucracy.de>2021-12-12 17:53:29 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-12-12 17:58:57 +0000
commit4ddd25225aa38b53f02f4e5b95551cc7cd63647c (patch)
tree43bf76c48361e330f689e6518ad60bfc719146aa
parent0feb80ea3e64671b24990798b9523086a8230d62 (diff)
downloadports-4ddd25225aa38b53f02f4e5b95551cc7cd63647c.tar.gz
ports-4ddd25225aa38b53f02f4e5b95551cc7cd63647c.zip
java/openjfx14: fix build with non-default CCACHE_DIR
In the build of openjfx14 CCACHE_DIR gets lost leading to build failures e.g. when building as nobody, so add it into ccwrapper and cxxwrapper. While here remove redundant ${SETENV} in do-build (${_GRADLE_RUN} already contains ${SETENV}) PR: 260215
-rw-r--r--java/openjfx14/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/java/openjfx14/Makefile b/java/openjfx14/Makefile
index 23b37dc18147..b47c89f0a0d9 100644
--- a/java/openjfx14/Makefile
+++ b/java/openjfx14/Makefile
@@ -106,8 +106,8 @@ pre-patch:
post-patch:
@${MKDIR} ${WRKDIR}/bin
- @${PRINTF} '#!/bin/sh\nexec ${CCACHE_BIN} ${CC} ${CFLAGS} ${LDFLAGS} "$$@"\n' > ${WRKDIR}/bin/ccwrapper
- @${PRINTF} '#!/bin/sh\nexec ${CCACHE_BIN} ${CXX} ${CXXFLAGS} ${LDFLAGS} "$$@"\n' > ${WRKDIR}/bin/cxxwrapper
+ @${PRINTF} '#!/bin/sh\nexport CCACHE_DIR=${CCACHE_DIR}\nexec ${CCACHE_BIN} ${CC} ${CFLAGS} ${LDFLAGS} "$$@"\n' > ${WRKDIR}/bin/ccwrapper
+ @${PRINTF} '#!/bin/sh\nexport CCACHE_DIR=${CCACHE_DIR}\nexec ${CCACHE_BIN} ${CXX} ${CXXFLAGS} ${LDFLAGS} "$$@"\n' > ${WRKDIR}/bin/cxxwrapper
@${CHMOD} +x ${WRKDIR}/bin/ccwrapper ${WRKDIR}/bin/cxxwrapper
@${REINPLACE_CMD} -e 's|gcc|${WRKDIR}/bin/ccwrapper|g' \
-e 's|g\+\+|${WRKDIR}/bin/cxxwrapper|g' \
@@ -145,7 +145,7 @@ do-configure:
# the java doc are not installed on FreeBSD so exclude the javadoc task
# as it'll fail otherwise
do-build:
- @cd ${WRKSRC} && ${SETENV} ${_GRADLE_RUN} zips --exclude-task javadoc
+ @cd ${WRKSRC} && ${_GRADLE_RUN} zips --exclude-task javadoc
# it's not recommended to install openjfx inside openjdk directory
do-install: