aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2021-05-12 00:14:40 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2021-05-12 01:01:20 +0000
commit5693283b37e182d63579863491412355997533f9 (patch)
treedf32cebb5c2950c76760f9e6f410af619e64aa9b
parentf2b487a6e9c74a44c1a68595a442f65951d4007c (diff)
downloadports-5693283b37e182d63579863491412355997533f9.tar.gz
ports-5693283b37e182d63579863491412355997533f9.zip
lang/python-doc-html: Unbreak makesum
Change make command to fix Python 2.7 values. [1] PR: 255767 [1] Reported by: Yasuhiro Kimura <yasu@utahime.org> [1] Approved by: python (with hat) Differential Revision: https://reviews.freebsd.org/D30192
-rw-r--r--lang/python-doc-html/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/python-doc-html/Makefile b/lang/python-doc-html/Makefile
index 48c696c08995..6b0e9d5fadc5 100644
--- a/lang/python-doc-html/Makefile
+++ b/lang/python-doc-html/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python-doc-${DOCFORMAT}
PORTVERSION= ${PYTHON_PORTVERSION}
CATEGORIES= lang python
-MASTER_SITES= PYTHON/ftp/python/doc/${PORTVERSION} \
+MASTER_SITES?= PYTHON/ftp/python/doc/${PORTVERSION} \
PYTHON/ftp/python/doc/current
DISTNAME= python-${PORTVERSION}-docs-${DOCFORMAT}
DIST_SUBDIR= python
@@ -38,7 +38,7 @@ _VERS!= ${MAKE} -V _PYTHON_VERSIONS:O
all_python_versions:
.for v in ${_VERS}
- @${MAKE} -V PYTHON_PORTVERSION DEFAULT_VERSIONS=python=${v}
+ @${MAKE} -C ${PORTSDIR}/lang/python${v:S/.//} -V PYTHON_PORTVERSION
.endfor
.if make(makesum)
@@ -54,6 +54,7 @@ DISTFILES+= python-${v}-docs-${f}${EXTRACT_SUFX}:${v:S/./x/g},DEFAULT
.endfor
.endfor
MASTER_SITES+= PYTHON/ftp/python/doc/current
+.export MASTER_SITES
.endif
pre-install: