aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-07-06 18:21:29 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-07-06 18:24:28 +0000
commit62ff121df2a70f25fd1ef444ba50219585f25bd8 (patch)
treeb92b9c712530113ad3ac90e4b202d60e95630ac7
parent2e6a5c7230106fca6847d14c4c7b0663ec6d36e6 (diff)
downloadports-62ff121df2a70f25fd1ef444ba50219585f25bd8.tar.gz
ports-62ff121df2a70f25fd1ef444ba50219585f25bd8.zip
devel/libublio: remove *_p.a profiling library
Since a port cannot reliably and easily infer the profiling configuration from src.conf (the ports framework defeats reading it, and historically the port had its troubles with that), remove the profiled libublio_p.a altogether. Bumps PORTREVISION due to pkg-plist change on most practical systems. Reported by: emaste@ PR: 256873
-rw-r--r--devel/libublio/Makefile18
-rw-r--r--devel/libublio/files/Makefile2
-rw-r--r--devel/libublio/pkg-plist1
3 files changed, 3 insertions, 18 deletions
diff --git a/devel/libublio/Makefile b/devel/libublio/Makefile
index cc6bd12269d6..fc6314cd5ded 100644
--- a/devel/libublio/Makefile
+++ b/devel/libublio/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libublio
PORTVERSION= 20070103
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= LOCAL/mandree
@@ -13,17 +13,8 @@ LICENSE= BSD2CLAUSE
USE_LDCONFIG= yes
-.if defined(NO_PROFILE) || defined(NOPROFILE) || defined(WITHOUT_PROFILE) || "${MK_PROFILE}" == "no"
-PLIST_SUB+= PROFLIB="@comment "
-.else
-PLIST_SUB+= PROFLIB=""
-.endif
-
USES= uidfix
-SRCCONF= /dev/null
-MAKE_ENV+= SRCCONF=${SRCCONF}
-
SUB_FILES= libublio.pc
SUB_LIST= PREFIX=${PREFIX} PORTVERSION=${PORTVERSION}
@@ -32,13 +23,6 @@ OPTIONS_DEFINE= DOCS
post-extract:
@${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
-# this pre-install is only for debugging pointyhat failures
-pre-install:
- @${ECHO_CMD} "===> Environment:"
- @${SETENV} | ${SORT} -f
- @${ECHO_CMD} "===> Makefiles used:"
- @${ECHO_CMD} ${.MAKEFILE_LIST}
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
diff --git a/devel/libublio/files/Makefile b/devel/libublio/files/Makefile
index 51ba01b41f4d..b6409ba96834 100644
--- a/devel/libublio/files/Makefile
+++ b/devel/libublio/files/Makefile
@@ -11,4 +11,6 @@ LIB= ublio
SHLIB_MAJOR= 1
LIBDIR= ${PREFIX}/lib
+MK_PROFILE= no
+
.include <bsd.lib.mk>
diff --git a/devel/libublio/pkg-plist b/devel/libublio/pkg-plist
index 39bc6dfe803a..f46d1cdf01a2 100644
--- a/devel/libublio/pkg-plist
+++ b/devel/libublio/pkg-plist
@@ -1,6 +1,5 @@
include/ublio.h
lib/libublio.a
-%%PROFLIB%%lib/libublio_p.a
lib/libublio.so
lib/libublio.so.1
libdata/pkgconfig/libublio.pc