aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2021-11-12 14:15:26 +0000
committerKai Knoblich <kai@FreeBSD.org>2021-11-12 14:15:26 +0000
commit6fea29c9fcfe61c89fbbac3035ca1b7174609789 (patch)
treef70ffd9a6b9dd50024c991d477c420eb854b32a3
parent0ff406ab9fe97470ebdab5ea55fb5b201f7d332b (diff)
downloadports-6fea29c9fcfe61c89fbbac3035ca1b7174609789.tar.gz
ports-6fea29c9fcfe61c89fbbac3035ca1b7174609789.zip
devel/py-setuptools_scm: Fix portmaster build with option TOML unset
* The port textproc/py-tomli is required in environments, where devel/py-setuptools_scm is already installed, even if the TOML option is unset. PR: 259797 Reported by: Ivan Rozhuk <rozhuk.im@gmail.com>
-rw-r--r--devel/py-setuptools_scm/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/py-setuptools_scm/Makefile b/devel/py-setuptools_scm/Makefile
index 1468cf2268a3..58a5c111ad98 100644
--- a/devel/py-setuptools_scm/Makefile
+++ b/devel/py-setuptools_scm/Makefile
@@ -10,6 +10,7 @@ COMMENT= Setuptools plugin to manage your versions by scm tags
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tomli>=1.0.0:textproc/py-tomli@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=20.0:devel/py-packaging@${PY_FLAVOR}
TEST_DEPENDS= git:devel/git \
${PY_MERCURIAL} \
@@ -29,7 +30,6 @@ OPTIONS_DEFINE= TOML
OPTIONS_DEFAULT= TOML
TOML_DESC= Support PEP 517/518 (Keep this enabled to avoid build errors)
-TOML_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tomli>=1.0.0:textproc/py-tomli@${PY_FLAVOR}
TOML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tomli>=1.0.0:textproc/py-tomli@${PY_FLAVOR}
# Skip integration tests that require a more recent version of py-virtualenv