aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2021-10-28 10:39:35 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-11-08 11:56:14 +0000
commit7d2630fc659f13bc2b230852ee4fc95c50a2ae15 (patch)
tree107bc8f6a1d8acbaf730ab6003e927879e37f44f
parentee93a2ebb651edbbf0408ddd93b61db831a2c4b1 (diff)
downloadports-7d2630fc659f13bc2b230852ee4fc95c50a2ae15.tar.gz
ports-7d2630fc659f13bc2b230852ee4fc95c50a2ae15.zip
games/stonesoup: Fix build on armv6/armv7.
Fix build on armv6/armv7 by removing a misguided OS-detection case. Fix build with WRKDIR inside a git-maintained ports tree. Turn the custom README into a pkg-message for better visibility. Take over maintainership of this unmaintained port. PR: 259499 (cherry picked from commit 5304a1914e4dfa3da4cb6d54932ff2f0d5e32f89)
-rw-r--r--games/stonesoup/Makefile15
-rw-r--r--games/stonesoup/files/README.FreeBSD.in7
-rw-r--r--games/stonesoup/files/patch-platform.h16
-rw-r--r--games/stonesoup/files/patch-util_gen__ver.pl12
-rw-r--r--games/stonesoup/files/pkg-message.in18
-rw-r--r--games/stonesoup/pkg-plist1
6 files changed, 50 insertions, 19 deletions
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 25fed763d150..9a9dfbd74967 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -2,18 +2,15 @@
PORTNAME= stonesoup
PORTVERSION= 0.23.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fuz@fuz.su
COMMENT= Dungeon Crawl Stone Soup - a fun, free rogue-like game
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/../../LICENSE
-NOT_FOR_ARCHS= armv6
-NOT_FOR_ARCHS_REASON= missing platform \#define or unsupported compiler
-
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
USES= bison compiler:c++11-lib gmake lua:51 perl5 pkgconfig \
@@ -32,7 +29,7 @@ SHEBANG_FILES= util/gen-mi-enum \
SAVEDIR= \~/.stonesoup
WRKSRC_SUBDIR= crawl-ref/source
-SUB_FILES= README.FreeBSD
+SUB_FILES= pkg-message
PLIST_SUB= SAVEDIR="${SAVEDIR}"
MAKE_ARGS= prefix=${PREFIX} \
@@ -52,7 +49,7 @@ MAKE_ARGS= prefix=${PREFIX} \
SQLITE_LIB=-lsqlite3 \
V=yes
-OPTIONS_DEFINE= SDL SOUND NOWIZARD LUA DOCS EXAMPLES
+OPTIONS_DEFINE= SDL SOUND NOWIZARD LUA EXAMPLES
OPTIONS_DEFAULT=LUA
OPTIONS_SUB= yes
@@ -92,10 +89,6 @@ pre-build:
pre-install:
@${FIND} ${WRKSRC}/dat -type f -name '*.orig' -delete
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/README.FreeBSD ${STAGEDIR}${DOCSDIR}
-
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${STAGEDIR}${DATADIR}/settings/init.txt ${STAGEDIR}${EXAMPLESDIR}/sample.crawlrc
diff --git a/games/stonesoup/files/README.FreeBSD.in b/games/stonesoup/files/README.FreeBSD.in
deleted file mode 100644
index f6637795a0ba..000000000000
--- a/games/stonesoup/files/README.FreeBSD.in
+++ /dev/null
@@ -1,7 +0,0 @@
-The end-user documentation for ``Dungeon Crawl Stone Soup`` can be found
-in-game and in `%%DATADIR%%/docs`.
-
-If the game fails to start after an upgrade try to delete the old save games
-using `rm -rf ~/.stonesoup/saves`.
-
-Happy crawling!
diff --git a/games/stonesoup/files/patch-platform.h b/games/stonesoup/files/patch-platform.h
new file mode 100644
index 000000000000..b9c501af2fe1
--- /dev/null
+++ b/games/stonesoup/files/patch-platform.h
@@ -0,0 +1,16 @@
+--- platform.h.orig 2021-10-28 09:13:02 UTC
++++ platform.h
+@@ -212,13 +212,6 @@
+ #endif
+
+ #if !defined (OS_DETECTED)
+-#if defined (TARGET_CPU_ARM)
+-#define OS_DETECTED
+-#define TARGET_OS_NDSFIRMWARE
+-#endif
+-#endif
+-
+-#if !defined (OS_DETECTED)
+ #if defined (MSDOS) || defined (__DOS__) || defined (__DJGPP__)
+ #define OS_DETECTED
+ #define TARGET_OS_DOS
diff --git a/games/stonesoup/files/patch-util_gen__ver.pl b/games/stonesoup/files/patch-util_gen__ver.pl
new file mode 100644
index 000000000000..862c1d12e961
--- /dev/null
+++ b/games/stonesoup/files/patch-util_gen__ver.pl
@@ -0,0 +1,12 @@
+--- util/gen_ver.pl.orig 2021-10-28 09:37:07 UTC
++++ util/gen_ver.pl
+@@ -13,8 +13,7 @@ $mergebase or $mergebase = "";
+
+ mkdir dirname($outfile);
+
+-$_ = `git describe --tags $mergebase 2> /dev/null`
+- || (open(IN, "<", "$scriptpath/release_ver") ? <IN>
++$_ = (open(IN, "<", "$scriptpath/release_ver") ? <IN>
+ : die "No Git, and $scriptpath/release_ver doesn't exist.\n")
+ or die "couldn't get the version information\n";
+
diff --git a/games/stonesoup/files/pkg-message.in b/games/stonesoup/files/pkg-message.in
new file mode 100644
index 000000000000..d13b28906533
--- /dev/null
+++ b/games/stonesoup/files/pkg-message.in
@@ -0,0 +1,18 @@
+[
+{ type: install
+ message: <<EOM
+The end-user documentation for ``Dungeon Crawl Stone Soup`` can be found
+in-game and in `%%DATADIR%%/docs`.
+
+Happy crawling!
+EOM
+}
+{ type: upgrade
+ message: <<EOM
+If the game fails to start after an upgrade try to delete
+the old save games using `rm -rf ~/.stonesoup/saves`.
+
+Happy crawling!
+EOM
+}
+]
diff --git a/games/stonesoup/pkg-plist b/games/stonesoup/pkg-plist
index d4b941902274..11aa9f7af75d 100644
--- a/games/stonesoup/pkg-plist
+++ b/games/stonesoup/pkg-plist
@@ -604,7 +604,6 @@ bin/stonesoup
%%LUA%%%%DATADIR%%/dat/clua/delays.lua
%%LUA%%%%DATADIR%%/dat/clua/kills.lua
%%LUA%%%%DATADIR%%/dat/clua/stash.lua
-%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.crawlrc
%%SDL%%%%DATADIR%%/dat/tiles/feat.png
%%SDL%%%%DATADIR%%/dat/tiles/floor.png