aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-12-09 03:56:02 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-12-09 03:56:02 +0000
commit8b60d24e9b0a874e659430b636c30be008f3dfa0 (patch)
tree56394da411741db218c1b842353b2ee7fe04cd1f
parent77f4b2da757eac76d40af4426fcd97d3190b6505 (diff)
downloadports-8b60d24e9b0a874e659430b636c30be008f3dfa0.tar.gz
ports-8b60d24e9b0a874e659430b636c30be008f3dfa0.zip
graphics/embree: change default selection of the port's options (+)
OSPray, an allegedly important raytracing library, explicitly requires Embree to be built with ISPC support and back-face culling disabled. This might or might not affect other 3D applications and, particularly, Blender, but could not reach Shane for his opinion in due time. Requested by: yuri PR: 260031
-rw-r--r--graphics/embree/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/embree/Makefile b/graphics/embree/Makefile
index 644495219e30..b8ef7712f221 100644
--- a/graphics/embree/Makefile
+++ b/graphics/embree/Makefile
@@ -2,6 +2,7 @@
PORTNAME= embree
PORTVERSION= 3.13.2
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= graphics
@@ -19,15 +20,17 @@ USE_GITHUB= yes
CMAKE_ARGS= -DEMBREE_TASKING_SYSTEM:STRING=${_ETS} \
-DCMAKE_INSTALL_DOCDIR:STRING=${DOCSDIR} \
- -DEMBREE_BACKFACE_CULLING:BOOL=ON \
-DEMBREE_RAY_MASK:BOOL=ON
PLIST_SUB+= VERSION=${DISTVERSION}
-OPTIONS_DEFINE= DOCS EXAMPLES ISPC TBB
-OPTIONS_DEFAULT= TBB
+OPTIONS_DEFINE= BACKFACE_CULLING DOCS EXAMPLES ISPC TBB
+OPTIONS_DEFAULT= ISPC TBB
OPTIONS_SUB= yes
+BACKFACE_CULLING_DESC= Enable back-face culling (BFC)
+BACKFACE_CULLING_CMAKE_ON= -DEMBREE_BACKFACE_CULLING:BOOL=ON
+
ISPC_DESC= ISPC applications support
ISPC_BUILD_DEPENDS= ispc:devel/ispc
ISPC_CMAKE_OFF= -DEMBREE_ISPC_SUPPORT:BOOL=OFF