aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2021-04-11 05:49:28 +0000
committerThomas Zander <riggs@FreeBSD.org>2021-04-11 14:10:27 +0000
commitabd8356cb7e4606f0f8893176b25b3ee53d852e9 (patch)
tree45a6d22f025dc362d4834814de685d5b6abe9d22
parente6a81dd7dcbab495199af7709f6593468160068e (diff)
downloadports-abd8356cb7e4606f0f8893176b25b3ee53d852e9.tar.gz
ports-abd8356cb7e4606f0f8893176b25b3ee53d852e9.zip
audio/faad: Update to 2.10.0.
Details: - Update to upstream version 2.10.0. - Follow upstream development to the GitHub page. - Remove references to the now-defunct former project page: http://www.audiocoding.com/ PR: 254711 Reported by: pi MFH: 2021Q2
-rw-r--r--audio/faad/Makefile14
-rw-r--r--audio/faad/distinfo6
-rw-r--r--audio/faad/files/patch-common_mp4ff_Makefile.am10
-rw-r--r--audio/faad/files/patch-libfaad_cfft.c13
-rw-r--r--audio/faad/pkg-descr2
-rw-r--r--audio/faad/pkg-plist4
6 files changed, 10 insertions, 39 deletions
diff --git a/audio/faad/Makefile b/audio/faad/Makefile
index 3016799d33ab..8fa1c74a0d0b 100644
--- a/audio/faad/Makefile
+++ b/audio/faad/Makefile
@@ -1,10 +1,9 @@
# Created by: Sean McGovern <sean@sfarc.net>
PORTNAME= faad2
-PORTVERSION= 2.8.8
+PORTVERSION= 2.10.0
PORTEPOCH= 1
CATEGORIES= audio
-MASTER_SITES= SF/faac/${PORTNAME}-src/${PORTNAME}-${PORTVERSION:R}.0
MAINTAINER= multimedia@FreeBSD.org
COMMENT= MPEG-2 and MPEG-4 AAC audio decoder
@@ -19,6 +18,10 @@ GNU_CONFIGURE= yes
LDFLAGS+= -lpthread
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= knik0
+GH_TAGNAME= c626366
+
post-extract:
@${LN} -sf faad.man ${WRKSRC}/frontend/faad.1
@@ -27,14 +30,7 @@ post-patch:
${WRKSRC}/frontend/Makefile.am
@${REINPLACE_CMD} -e 's|^AM_CFLAGS|AM_CPPFLAGS|g ; \
s|-iquote |-I|g' ${WRKSRC}/libfaad/Makefile.am
- @${REINPLACE_CMD} -e 's|= -DUSE_|= -fPIC -DPIC -DUSE_|g' \
- ${WRKSRC}/common/mp4ff/Makefile.am
- @${ECHO_CMD} "SUBDIRS = libfaad common frontend" > \
- ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -E -e 's|(FAAD2_VERSION +)"unknown"|\1"${PORTVERSION:R}"|' \
${WRKSRC}/include/neaacdec.h
-post-configure:
- @${REINPLACE_CMD} "s/444/644/g" ${WRKSRC}/common/mp4ff/Makefile
-
.include <bsd.port.mk>
diff --git a/audio/faad/distinfo b/audio/faad/distinfo
index e78cdaec9c43..50e25801f89d 100644
--- a/audio/faad/distinfo
+++ b/audio/faad/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1513703210
-SHA256 (faad2-2.8.8.tar.gz) = 985c3fadb9789d2815e50f4ff714511c79c2710ac27a4aaaf5c0c2662141426d
-SIZE (faad2-2.8.8.tar.gz) = 1069044
+TIMESTAMP = 1618119869
+SHA256 (knik0-faad2-2.10.0-c626366_GH0.tar.gz) = b83a70fe976f3ddf8d9cf5742c36102b91a1bae829d85b340311e7c4a6d176f6
+SIZE (knik0-faad2-2.10.0-c626366_GH0.tar.gz) = 803223
diff --git a/audio/faad/files/patch-common_mp4ff_Makefile.am b/audio/faad/files/patch-common_mp4ff_Makefile.am
deleted file mode 100644
index dac68419d88b..000000000000
--- a/audio/faad/files/patch-common_mp4ff_Makefile.am
+++ /dev/null
@@ -1,10 +0,0 @@
---- common/mp4ff/Makefile.am.orig 2017-07-17 12:04:02 UTC
-+++ common/mp4ff/Makefile.am
-@@ -1,5 +1,5 @@
--noinst_LIBRARIES = libmp4ff.a
--noinst_HEADERS = mp4ff.h mp4ffint.h
-+lib_LIBRARIES = libmp4ff.a
-+include_HEADERS = mp4ff.h mp4ffint.h
-
- libmp4ff_a_CFLAGS = -DUSE_TAGGING=1
-
diff --git a/audio/faad/files/patch-libfaad_cfft.c b/audio/faad/files/patch-libfaad_cfft.c
deleted file mode 100644
index 59c50990578f..000000000000
--- a/audio/faad/files/patch-libfaad_cfft.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- libfaad/cfft.c.orig 2007-11-01 12:33:29 UTC
-+++ libfaad/cfft.c
-@@ -60,8 +60,8 @@ static void passf4neg(const uint16_t ido
- static void passf5(const uint16_t ido, const uint16_t l1, const complex_t *cc, complex_t *ch,
- const complex_t *wa1, const complex_t *wa2, const complex_t *wa3,
- const complex_t *wa4, const int8_t isign);
--INLINE void cfftf1(uint16_t n, complex_t *c, complex_t *ch,
-- const uint16_t *ifac, const complex_t *wa, const int8_t isign);
-+/*INLINE void cfftf1(uint16_t n, complex_t *c, complex_t *ch,
-+ const uint16_t *ifac, const complex_t *wa, const int8_t isign);*/
- static void cffti1(uint16_t n, complex_t *wa, uint16_t *ifac);
-
-
diff --git a/audio/faad/pkg-descr b/audio/faad/pkg-descr
index 91671ff169a7..69d963ff3f74 100644
--- a/audio/faad/pkg-descr
+++ b/audio/faad/pkg-descr
@@ -4,4 +4,4 @@ FAAD2 is the fastest ISO AAC audio decoder available and can be used with
DRM (Digital Radio Mondiale), and supports HE (High Efficiency), Main,
LC, LD, LTP, PS (Parametric Stereo) AAC files.
-WWW: https://www.audiocoding.com/
+WWW: https://github.com/knik0/faad2
diff --git a/audio/faad/pkg-plist b/audio/faad/pkg-plist
index 4c415e31c523..0f7d88ea84a9 100644
--- a/audio/faad/pkg-plist
+++ b/audio/faad/pkg-plist
@@ -1,7 +1,5 @@
bin/faad
include/faad.h
-include/mp4ff.h
-include/mp4ffint.h
include/neaacdec.h
lib/libfaad.a
lib/libfaad.so
@@ -11,5 +9,5 @@ lib/libfaad_drm.a
lib/libfaad_drm.so
lib/libfaad_drm.so.2
lib/libfaad_drm.so.2.0.0
-lib/libmp4ff.a
+libdata/pkgconfig/faad2.pc
man/man1/faad.1.gz