aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@utahime.org>2021-08-12 03:37:43 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-08-18 19:50:35 +0000
commitae8a8ca2e4c6603927241d2a25fb1ef42f047992 (patch)
treef4fb6d51a5e8d4b18b3918504ad4b366b417c400
parent76238c95046f9ca6e3ce47f9a8b5347822c767b7 (diff)
downloadports-ae8a8ca2e4c6603927241d2a25fb1ef42f047992.tar.gz
ports-ae8a8ca2e4c6603927241d2a25fb1ef42f047992.zip
security/py-fail2ban: Add upstream patches to fix runtime error with Python 3.10
PR: 257784 Approved by: theis AT gmx DOT at (maintainer) (cherry picked from commit e8d866428c99ca6838a6a112cb16fd5df1e2cffc)
-rw-r--r--security/py-fail2ban/Makefile2
-rw-r--r--security/py-fail2ban/files/patch-fail2ban_server_action.py30
-rw-r--r--security/py-fail2ban/files/patch-fail2ban_server_actions.py28
-rw-r--r--security/py-fail2ban/files/patch-fail2ban_server_jails.py28
4 files changed, 87 insertions, 1 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index cea038fdbc63..884231380fb3 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -1,6 +1,6 @@
PORTNAME= fail2ban
PORTVERSION= 0.11.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-fail2ban/files/patch-fail2ban_server_action.py b/security/py-fail2ban/files/patch-fail2ban_server_action.py
new file mode 100644
index 000000000000..eed4bbc6d84d
--- /dev/null
+++ b/security/py-fail2ban/files/patch-fail2ban_server_action.py
@@ -0,0 +1,30 @@
+From 2b6bb2c1bed8f7009631e8f8c306fa3160324a49 Mon Sep 17 00:00:00 2001
+From: "Sergey G. Brester" <serg.brester@sebres.de>
+Date: Mon, 8 Feb 2021 17:19:24 +0100
+Subject: [PATCH] follow bpo-37324: :ref:`collections-abstract-base-classes`
+ moved to the :mod:`collections.abc` module
+
+(since 3.10-alpha.5 `MutableMapping` is missing in collections module)
+---
+ fail2ban/server/action.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git fail2ban/server/action.py fail2ban/server/action.py
+index 3bc48fe0..f0f1e6f5 100644
+--- fail2ban/server/action.py
++++ fail2ban/server/action.py
+@@ -30,7 +30,10 @@ import tempfile
+ import threading
+ import time
+ from abc import ABCMeta
+-from collections import MutableMapping
++try:
++ from collections.abc import MutableMapping
++except ImportError:
++ from collections import MutableMapping
+
+ from .failregex import mapTag2Opt
+ from .ipdns import DNSUtils
+--
+2.32.0
+
diff --git a/security/py-fail2ban/files/patch-fail2ban_server_actions.py b/security/py-fail2ban/files/patch-fail2ban_server_actions.py
new file mode 100644
index 000000000000..bdbf5ab2f18e
--- /dev/null
+++ b/security/py-fail2ban/files/patch-fail2ban_server_actions.py
@@ -0,0 +1,28 @@
+From 42dee38ad2ac5c3f23bdf297d824022923270dd9 Mon Sep 17 00:00:00 2001
+From: "Sergey G. Brester" <serg.brester@sebres.de>
+Date: Mon, 8 Feb 2021 17:25:45 +0100
+Subject: [PATCH] amend for `Mapping`
+
+---
+ fail2ban/server/actions.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git fail2ban/server/actions.py fail2ban/server/actions.py
+index b7b95b44..897d907c 100644
+--- fail2ban/server/actions.py
++++ fail2ban/server/actions.py
+@@ -28,7 +28,10 @@ import logging
+ import os
+ import sys
+ import time
+-from collections import Mapping
++try:
++ from collections.abc import Mapping
++except ImportError:
++ from collections import Mapping
+ try:
+ from collections import OrderedDict
+ except ImportError:
+--
+2.32.0
+
diff --git a/security/py-fail2ban/files/patch-fail2ban_server_jails.py b/security/py-fail2ban/files/patch-fail2ban_server_jails.py
new file mode 100644
index 000000000000..c299687b992a
--- /dev/null
+++ b/security/py-fail2ban/files/patch-fail2ban_server_jails.py
@@ -0,0 +1,28 @@
+From 9f1d1f4fbd0804695a976beb191f2c49a2739834 Mon Sep 17 00:00:00 2001
+From: "Sergey G. Brester" <serg.brester@sebres.de>
+Date: Mon, 8 Feb 2021 17:35:59 +0100
+Subject: [PATCH] amend for `Mapping` (jails)
+
+---
+ fail2ban/server/jails.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git fail2ban/server/jails.py fail2ban/server/jails.py
+index 972a8c4b..27e12ddf 100644
+--- fail2ban/server/jails.py
++++ fail2ban/server/jails.py
+@@ -22,7 +22,10 @@ __copyright__ = "Copyright (c) 2004 Cyril Jaquier, 2013- Yaroslav Halchenko"
+ __license__ = "GPL"
+
+ from threading import Lock
+-from collections import Mapping
++try:
++ from collections.abc import Mapping
++except ImportError:
++ from collections import Mapping
+
+ from ..exceptions import DuplicateJailException, UnknownJailException
+ from .jail import Jail
+--
+2.32.0
+