aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2022-01-18 15:26:35 +0000
committerFukang Chen <loader@FreeBSD.org>2022-02-10 11:12:25 +0000
commitb19f93882a7c53f2da0f0b8c2850f61128c6d3f4 (patch)
tree534f9a8af24ce333d093e90b993f0292db0af2cc
parentb7d3f79bb0f00e2610414910e301c105fe0a5700 (diff)
downloadports-b19f93882a7c53f2da0f0b8c2850f61128c6d3f4.tar.gz
ports-b19f93882a7c53f2da0f0b8c2850f61128c6d3f4.zip
devel/py-amalgamate: Fix data_files install location
- Install data_files into ${DOCSDIR} instead of ${PREFIX} - Allow concurrent installation for bin/amalgamate.py and ${DOCSDIR} PR: 261159 Approved by: lwhsu (python) MFH: 2022Q1 (ports compliance) (cherry picked from commit 33e2061728d30f5e43912b604da958ede94ba59f)
-rw-r--r--devel/py-amalgamate/Makefile6
-rw-r--r--devel/py-amalgamate/files/patch-setup.py11
2 files changed, 16 insertions, 1 deletions
diff --git a/devel/py-amalgamate/Makefile b/devel/py-amalgamate/Makefile
index c8694a38686c..03d0facfd95b 100644
--- a/devel/py-amalgamate/Makefile
+++ b/devel/py-amalgamate/Makefile
@@ -1,5 +1,6 @@
PORTNAME= amalgamate
PORTVERSION= 0.1.3
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,8 +12,11 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= python:3.4+
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist distutils concurrent
NO_ARCH= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%DOCSDIR%%|${DOCSDIR}|' ${WRKSRC}/setup.py
+
.include <bsd.port.mk>
diff --git a/devel/py-amalgamate/files/patch-setup.py b/devel/py-amalgamate/files/patch-setup.py
new file mode 100644
index 000000000000..c716bf4acc5b
--- /dev/null
+++ b/devel/py-amalgamate/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2022-01-18 11:48:00 UTC
++++ setup.py
+@@ -26,7 +26,7 @@ setup_kwargs = {
+ ],
+ "zip_safe": False,
+ "scripts": ['amalgamate.py'],
+- "data_files": [("", ['LICENSE', 'README.rst']),],
++ "data_files": [("%%DOCSDIR%%", ['LICENSE', 'README.rst']),],
+ }
+
+