aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@utahime.org>2021-05-15 06:51:40 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-05-15 07:14:05 +0000
commitc210d2ab69b612d5b7974a34d267be027039b827 (patch)
tree031a8e2156c6ee1816ef260bd5a933561fef3691
parent9671981826f7ef8b1e7fb0a430ee24d4a1f0acf2 (diff)
downloadports-c210d2ab69b612d5b7974a34d267be027039b827.tar.gz
ports-c210d2ab69b612d5b7974a34d267be027039b827.zip
Mk/Uses/readline.mk: Remove unnecessary 'port' argument
Currently no supported FreeBSD version has libreadline.so in base. Then if 'USES=readline' is used devel/readline is always added to dependency whether or not 'port' argument is specified. So remove unnecessary 'port' argument now. PR: 248459 Exp-run by: antoine
-rw-r--r--Mk/Uses/readline.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/Mk/Uses/readline.mk b/Mk/Uses/readline.mk
index c56cca74db5d..4893ebfdee6b 100644
--- a/Mk/Uses/readline.mk
+++ b/Mk/Uses/readline.mk
@@ -2,21 +2,18 @@
#
# Feature: readline
# Usage: USES=readline
-# Valid ARGS: port
#
# MAINTAINER: portmgr@FreeBSD.org
.if !defined(_INCLUDE_USES_READLINE_MK)
_INCLUDE_USES_READLINE_MK= yes
-.if !exists(/usr/lib/libreadline.so)
-readline_ARGS= port
+.if !empty(readline_ARGS)
+IGNORE= Incorrect 'USES+= readline:${readline_ARGS}' readline takes no arguments
.endif
-.if ${readline_ARGS} == port
LIB_DEPENDS+= libreadline.so.8:devel/readline
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.endif
.endif