aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-10 14:20:37 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-10 14:42:34 +0000
commitde9dca2f74876bafe44d20b9bd39cf1327f0ace5 (patch)
tree5a9cb43ad9e973c00d5088f08e8c1db6cd5a3159
parent650ba2880a49a4be25b07dff4f744f2afb44e8ab (diff)
downloadports-de9dca2f74876bafe44d20b9bd39cf1327f0ace5.tar.gz
ports-de9dca2f74876bafe44d20b9bd39cf1327f0ace5.zip
emulators/advancemess: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. PR: 251512
-rw-r--r--emulators/advancemess/Makefile4
-rw-r--r--emulators/advancemess/files/patch-configure24
2 files changed, 27 insertions, 1 deletions
diff --git a/emulators/advancemess/Makefile b/emulators/advancemess/Makefile
index 84065957f732..fe2c9449b0bb 100644
--- a/emulators/advancemess/Makefile
+++ b/emulators/advancemess/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:textproc/expat2
RUN_DEPENDS= advancemame>=1.4:emulators/advancemame
-USES= gmake ncurses sdl
+USES= gmake ncurses pkgconfig sdl
USE_SDL= sdl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-svgalib --disable-fb --disable-alsa --enable-oss \
@@ -47,6 +47,8 @@ SLANG_LDFLAGS= -lncurses
BROKEN_powerpc= Does not compile on powerpc
+BINARY_ALIAS= freetype-config=true
+
post-patch:
@${REINPLACE_CMD} -e \
's|@@|@|' ${WRKSRC}/Makefile.in
diff --git a/emulators/advancemess/files/patch-configure b/emulators/advancemess/files/patch-configure
new file mode 100644
index 000000000000..a73f075c6c65
--- /dev/null
+++ b/emulators/advancemess/files/patch-configure
@@ -0,0 +1,24 @@
+--- configure.orig 2021-08-10 14:17:55 UTC
++++ configure
+@@ -8269,8 +8269,8 @@ done
+ else
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+- FREETYPECFLAGS=`$ac_lib_freetype_config $ac_lib_freetype_args --cflags`
+- FREETYPELIBS=`$ac_lib_freetype_config $ac_lib_freetype_args --libs`
++ FREETYPECFLAGS=`pkg-config freetype2 --cflags`
++ FREETYPELIBS=`pkg-config freetype2 --libs`
+ CFLAGS="$FREETYPECFLAGS $CFLAGS"
+ LIBS="$FREETYPELIBS $LIBS"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for FreeType2" >&5
+@@ -8359,8 +8359,8 @@ done
+ else
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+- FREETYPECFLAGS=`$ac_lib_freetype_config $ac_lib_freetype_args --cflags`
+- FREETYPELIBS=`$ac_lib_freetype_config $ac_lib_freetype_args --libs`
++ FREETYPECFLAGS=`pkg-config freetype2 --cflags`
++ FREETYPELIBS=`pkg-config freetype2 --libs`
+ CFLAGS="$FREETYPECFLAGS $CFLAGS"
+ LIBS="$FREETYPELIBS $LIBS"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for FreeType2" >&5