aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/bird2/Makefile1
-rw-r--r--net/bird2/files/patch-Makefile.in6
-rw-r--r--net/bird2/files/patch-proto_babel_babel.c24
3 files changed, 28 insertions, 3 deletions
diff --git a/net/bird2/Makefile b/net/bird2/Makefile
index 6660aa8df6b0..bc5d2af17480 100644
--- a/net/bird2/Makefile
+++ b/net/bird2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= bird
DISTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://bird.network.cz/download/
PKGNAMESUFFIX= 2
diff --git a/net/bird2/files/patch-Makefile.in b/net/bird2/files/patch-Makefile.in
index 71c91600c45e..8bddd6d09554 100644
--- a/net/bird2/files/patch-Makefile.in
+++ b/net/bird2/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2019-01-08 06:06:39.654833000 +0100
-+++ Makefile.in 2019-01-08 06:06:53.077532000 +0100
-@@ -188,11 +188,7 @@
+--- Makefile.in.orig 2021-03-21 22:29:42 UTC
++++ Makefile.in
+@@ -206,11 +206,7 @@ install: all
for BIN in bird @CLIENT@ ; do \
$(INSTALL_PROGRAM) $(exedir)/$$BIN $(DESTDIR)/$(sbindir)/$$BIN ; \
done
diff --git a/net/bird2/files/patch-proto_babel_babel.c b/net/bird2/files/patch-proto_babel_babel.c
new file mode 100644
index 000000000000..25cee54f7edc
--- /dev/null
+++ b/net/bird2/files/patch-proto_babel_babel.c
@@ -0,0 +1,24 @@
+--- proto/babel/babel.c.orig 2021-04-16 21:18:15 UTC
++++ proto/babel/babel.c
+@@ -1658,10 +1658,6 @@ babel_if_notify(struct proto *P, unsigned flags, struc
+ if (!(iface->flags & IF_UP))
+ return;
+
+- /* We only speak multicast */
+- if (!(iface->flags & IF_MULTICAST))
+- return;
+-
+ /* Ignore ifaces without link-local address */
+ if (!iface->llv6)
+ return;
+@@ -1734,10 +1730,6 @@ babel_reconfigure_ifaces(struct babel_proto *p, struct
+ WALK_LIST(iface, iface_list)
+ {
+ if (!(iface->flags & IF_UP))
+- continue;
+-
+- /* Ignore non-multicast ifaces */
+- if (!(iface->flags & IF_MULTICAST))
+ continue;
+
+ /* Ignore ifaces without link-local address */