aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/bsd-spell/Makefile39
-rw-r--r--textproc/bsd-spell/distinfo3
-rw-r--r--textproc/bsd-spell/pkg-descr9
4 files changed, 52 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b70ef9c5fcb5..d129c87fc82d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -83,6 +83,7 @@
SUBDIR += biodiff
SUBDIR += bn-aspell
SUBDIR += br-aspell
+ SUBDIR += bsd-spell
SUBDIR += bsddiff
SUBDIR += bsdgrep
SUBDIR += btparse
diff --git a/textproc/bsd-spell/Makefile b/textproc/bsd-spell/Makefile
new file mode 100644
index 000000000000..d94af4fb7edd
--- /dev/null
+++ b/textproc/bsd-spell/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= bsd-spell
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.1
+CATEGORIES= textproc
+
+MAINTAINER= gbe@FreeBSD.org
+COMMENT= This is a port of the 4.4BSD spell command
+WWW= https://github.com/gbergling/bsdspell
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= gbergling
+GH_PROJECT= bsdspell
+
+PLIST_FILES= libexec/spellprog bin/spell bin/deroff \
+ man/man1/spell.1.gz man/man1/deroff.1.gz \
+ share/dict/american \
+ share/dict/british \
+ share/dict/special.4bsd \
+ share/dict/special.math \
+ share/dict/stop
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/usr.bin/spell/spellprog ${STAGEDIR}${PREFIX}/libexec
+ ${INSTALL_PROGRAM} ${WRKSRC}/usr.bin/deroff/deroff ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/usr.bin/spell/spell.sh ${STAGEDIR}${PREFIX}/bin/spell
+
+ ${INSTALL_DATA} ${WRKSRC}/usr.bin/spell/american ${STAGEDIR}${PREFIX}/share/dict
+ ${INSTALL_DATA} ${WRKSRC}/usr.bin/spell/british ${STAGEDIR}${PREFIX}/share/dict
+ ${INSTALL_DATA} ${WRKSRC}/usr.bin/spell/special.4bsd ${STAGEDIR}${PREFIX}/share/dict
+ ${INSTALL_DATA} ${WRKSRC}/usr.bin/spell/special.math ${STAGEDIR}${PREFIX}/share/dict
+ ${INSTALL_DATA} ${WRKSRC}/usr.bin/spell/stop ${STAGEDIR}${PREFIX}/share/dict
+
+ ${INSTALL_MAN} ${WRKSRC}/usr.bin/spell/spell.1.gz ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/usr.bin/deroff/deroff.1.gz ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/textproc/bsd-spell/distinfo b/textproc/bsd-spell/distinfo
new file mode 100644
index 000000000000..208c180d5cd7
--- /dev/null
+++ b/textproc/bsd-spell/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1695708591
+SHA256 (gbergling-bsdspell-v1.0.1_GH0.tar.gz) = 05698e613d3e54caf4c206f844c7ac59eac62b6e4806255a4e3470a9c918fe58
+SIZE (gbergling-bsdspell-v1.0.1_GH0.tar.gz) = 34757
diff --git a/textproc/bsd-spell/pkg-descr b/textproc/bsd-spell/pkg-descr
new file mode 100644
index 000000000000..4b89452e908d
--- /dev/null
+++ b/textproc/bsd-spell/pkg-descr
@@ -0,0 +1,9 @@
+spell(1) collects words from the named documents and looks them up in a
+spelling list. Words that neither occur among nor are derivable
+(by applying certain inflections, prefixes or suffixes) from words in the
+spelling list are printed on the standard output.
+
+deroff(1) reads each file in sequence and removes all roff command lines,
+backslash constructions, macro definitions, eqn constructs (between ".EQ"
+and ".EN" lines or between delimiters), pic pictures, and table descriptions
+and writes the remainder to the standard output.