aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--converters/wkhtmltopdf/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index 02c79969074a..95a2d2c62c0f 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -15,7 +15,6 @@ EXPIRATION_DATE= 2024-06-30
BROKEN_armv6= fails to build: error: Not supported ARM architecture
BROKEN_armv7= fails to build: error: invalid operand for instruction
BROKEN_mips64= fails to link: undefined reference to __sync_add_and_fetch_4
-BROKEN_FreeBSD_14= fails to build: use of undeclared identifier 'needsToUnregister'
RUN_DEPENDS= webfonts>=0:x11-fonts/webfonts
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
@@ -84,7 +83,7 @@ post-patch:
${WRKSRC}/build/wkhtmltox
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
@${FIND} ${PATCH_WRKSRC}/../qt-5db36ec -name "*.cpp" -o -name "*.h" | \
- ${XARGS} ${REINPLACE_CMD} -e 's|register ||g'
+ ${XARGS} ${REINPLACE_CMD} -E 's|register ([a-zA-Z])|\1|g'
.endif