aboutsummaryrefslogtreecommitdiff
path: root/ru_RU.KOI8-R/htdocs/ports/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2012-05-17 03:23:15 +0000
committerHiroki Sato <hrs@FreeBSD.org>2012-05-17 03:23:15 +0000
commit4fe414e55f71a98004350e582bfeb852f5758769 (patch)
treecef8e8b44236eea349b9f90e1eebcc80c56017c1 /ru_RU.KOI8-R/htdocs/ports/Makefile
parent282a032540622ef194d646326406f3349c379554 (diff)
downloaddoc-4fe414e55f71a98004350e582bfeb852f5758769.tar.gz
doc-4fe414e55f71a98004350e582bfeb852f5758769.zip
- Move developers.sgml to the language-independent directory.
- Move files under <lang>/htdocs/share to <lang>/share. - s/WEB_PREFIX/DOC_PREFIX/ - Update the webupdate script to use the SVN repository. Approved by: doceng (implicit)
Notes
Notes: svn path=/head/; revision=38822
Diffstat (limited to 'ru_RU.KOI8-R/htdocs/ports/Makefile')
-rw-r--r--ru_RU.KOI8-R/htdocs/ports/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/ru_RU.KOI8-R/htdocs/ports/Makefile b/ru_RU.KOI8-R/htdocs/ports/Makefile
index 9ff76615d5..0629001872 100644
--- a/ru_RU.KOI8-R/htdocs/ports/Makefile
+++ b/ru_RU.KOI8-R/htdocs/ports/Makefile
@@ -13,8 +13,8 @@
.if exists(../Makefile.inc)
.include "../Makefile.inc"
.endif
-.if exists(Makefile.inc)
-.include "Makefile.inc"
+.if exists(${DOC_PREFIX}/en_US.ISO8859-1/htdocs/ports/Makefile.inc)
+.include "${DOC_PREFIX}/en_US.ISO8859-1/htdocs/ports/Makefile.inc"
.endif
FETCH_OPT?= -am
@@ -48,10 +48,10 @@ hostname= ${NO_PACKAGES_LINK}
packages.exists:
.if ${hostname} == "hub.freebsd.org" || ${hostname} == "freefall.freebsd.org" || ${hostname} == "www.freebsd.org"
-.if exists(${.CURDIR}/../../en/ports/packages.exists)
- ${CP} ${.CURDIR}/../../en/ports/${.TARGET} ${.CURDIR}
+.if exists(${DOC_PREFIX}/en_US.ISO8859-1/htdocs/ports/packages.exists)
+ ${CP} ${DOC_PREFIX}/en_US.ISO8859-1/htdocs/ports/${.TARGET} ${.CURDIR}
.else
- @if ${SH} ${.CURDIR}/../../en/ports/packages > ${.TARGET}.temp; then \
+ @if ${SH} ${DOC_PREFIX}/en_US.ISO8859-1/htdocs/ports/packages > ${.TARGET}.temp; then \
${MV} ${.TARGET}.temp ${.TARGET}; \
else \
${RM} ${.TARGET}.temp; ${TOUCH} ${.TARGET}; \
@@ -82,7 +82,7 @@ index.sgml: ${INDEX} categories packages.exists portindex ports.inc .NOTMAIN
# this builds: categories-alpha.sgml, categories-grouped.sgml,
# master-index.sgml, statistics.ent, <category>.sgml
-CATEGORYLIST=`grep "^[a-z]" ../../en/ports/categories | sed -e s"/,.*//"`
+CATEGORYLIST=`grep "^[a-z]" ${DOC_PREFIX}/en_US.ISO8859-1/htdocs/ports/categories | sed -e s"/,.*//"`
install: all beforeinstall
@@ -98,4 +98,4 @@ beforeinstall:
${PERL} -pi -e 's/href=\"growth/href=\"http:\/\/www.FreeBSD.org\/ports\/growth/' index.html
#.endif
-.include "${WEB_PREFIX}/share/mk/web.site.mk"
+.include "${DOC_PREFIX}/share/mk/web.site.mk"