aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-29 15:33:05 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-29 15:33:05 +0000
commitf0387837262bcb2dda20867b1dedcf7fd06a2ae7 (patch)
treef9b4ef61db65707052a7d190b421eef8f0153485
parent7099601f50e057141f3917db05103b6bd8623b75 (diff)
downloadports-f0387837262bcb2dda20867b1dedcf7fd06a2ae7.tar.gz
ports-f0387837262bcb2dda20867b1dedcf7fd06a2ae7.zip
MFH: r373383
- Remove bundled ode to not mix up header files with system ode - Fix broken text rendering Approved by: ports-secteam (rea)
Notes
Notes: svn path=/branches/2014Q4/; revision=373630
-rw-r--r--games/xmoto/Makefile11
-rw-r--r--games/xmoto/files/patch-src-VTexture.h11
-rw-r--r--games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp34
3 files changed, 55 insertions, 1 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 894e8371269f..c5d3172e87b1 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -55,6 +55,15 @@ DESKTOP_ENTRIES="XMoto" \
"Game;SportsGame;ArcadeGame;" \
false
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000
+BROKEN= does not build
+.endif
+
+post-extract:
+ @${RM} -rf ${WRKSRC}/src/ode
+
post-patch:
@${REINPLACE_CMD} -e "s/lua5.1/lua-${LUA_VER}/g" ${WRKSRC}/configure
@@ -64,4 +73,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/xmoto/files/patch-src-VTexture.h b/games/xmoto/files/patch-src-VTexture.h
new file mode 100644
index 000000000000..9932bfe4962d
--- /dev/null
+++ b/games/xmoto/files/patch-src-VTexture.h
@@ -0,0 +1,11 @@
+--- src/VTexture.h.orig 2011-10-12 00:18:35.000000000 +0400
++++ src/VTexture.h 2014-11-24 22:08:42.749026473 +0300
+@@ -135,7 +135,7 @@
+
+ void cleanUnregistredTextures();
+
+- HashNamespace::hash_map<const char*, int*, HashNamespace::hash<const char*>, hashcmp_str> m_textureSizeCache;
++ HashNamespace::hash_map<std::string, int*> m_textureSizeCache;
+ std::vector<std::string> m_textureSizeCacheKeys;
+ std::vector<int*> m_textureSizeCacheValues;
+
diff --git a/games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp b/games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp
new file mode 100644
index 000000000000..6230ef38dbdc
--- /dev/null
+++ b/games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp
@@ -0,0 +1,34 @@
+--- src/drawlib/DrawLibOpenGL.cpp.orig 2011-10-12 00:18:26.000000000 +0400
++++ src/drawlib/DrawLibOpenGL.cpp 2014-11-24 22:08:12.925973647 +0300
+@@ -80,7 +80,7 @@
+ /* a glyph from other glyphs */
+ /*kejo:why not just grrr create a copy contructor*/
+ GLFontGlyph(const std::string& i_value,
+- HashNamespace::hash_map<const char*, GLFontGlyphLetter*, HashNamespace::hash<const char*>, hashcmp_str>& i_glyphsLetters);
++ HashNamespace::hash_map<std::string, GLFontGlyphLetter*>& i_glyphsLetters);
+ virtual ~GLFontGlyph();
+
+ std::string Value() const;
+@@ -132,11 +132,11 @@
+ private:
+ std::vector<std::string> m_glyphsKeys;
+ std::vector<GLFontGlyph*> m_glyphsValues;
+- HashNamespace::hash_map<const char*, GLFontGlyph*, HashNamespace::hash<const char*>, hashcmp_str> m_glyphs;
++ HashNamespace::hash_map<std::string, GLFontGlyph*> m_glyphs;
+
+ std::vector<std::string> m_glyphsLettersKeys;
+ std::vector<GLFontGlyphLetter*> m_glyphsLettersValues;
+- HashNamespace::hash_map<const char*, GLFontGlyphLetter*, HashNamespace::hash<const char*>, hashcmp_str> m_glyphsLetters;
++ HashNamespace::hash_map<std::string, GLFontGlyphLetter*> m_glyphsLetters;
+
+ unsigned int getLonguestLineSize(const std::string& i_value, unsigned int i_start = 0, unsigned int i_nbLinesToRead = -1);
+ };
+@@ -825,7 +825,7 @@
+ }
+
+ GLFontGlyph::GLFontGlyph(const std::string& i_value,
+- HashNamespace::hash_map<const char*, GLFontGlyphLetter*, HashNamespace::hash<const char*>, hashcmp_str>& i_glyphsLetters) {
++ HashNamespace::hash_map<std::string, GLFontGlyphLetter*>& i_glyphsLetters) {
+ GLFontGlyph* v_glyph;
+ std::string v_char;
+