aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-12-26 10:04:31 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-12-26 10:04:31 +0000
commit43dff643d06668d0f72bd41031d1f58f73ee4a1c (patch)
tree38b608b736fbf9052098e8f82d72ac03f040769a
parenta6cfd4ba34451c5518f453cb5d8beb6593f278ea (diff)
downloadports-43dff643d06668d0f72bd41031d1f58f73ee4a1c.tar.gz
ports-43dff643d06668d0f72bd41031d1f58f73ee4a1c.zip
MFH: r429442
Improve the way CFLAGS and CPPFLAGS are set. ":?" is not supported by fmake from FreeBSD 9, so replace it with an explicit version check. The end result was still the desired one (-DHAVE_STRCHRNUL=1 was not passed on FreeBSD 9). While here, also improve the version check by including DragonFly (which supports strchrnul(3) according to its online man page) and restricting the FreeBSD version check to the revision range after strchrnul(3) was added to base. Also stop passing -Os when building in debug mode, and set UNICODE61_CPPFLAGS to pet portlint. PR: 214608 Submitted by: Pavel Volkov <pavelivolkov@gmail.com> (maintainer) Approved by: ports-secteam (junovitch)
Notes
Notes: svn path=/branches/2016Q4/; revision=429489
-rw-r--r--databases/sqlite3/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 6dd981e3690e..a679e8be7002 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -18,11 +18,6 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-# Platform Configuration
-CFLAGS+= -Os
-CPPFLAGS+= -DHAVE_ISNAN=1 -DHAVE_MALLOC_USABLE_SIZE=1 -DHAVE_GMTIME_R=1 -DHAVE_LOCALTIME_R=1 -DHAVE_USLEEP=1
-CPPFLAGS+= ${OSVERSION<1000000:?:-DHAVE_STRCHRNUL=1}
-
MAKE_JOBS_UNSAFE= yes
# Compilation Options For SQLite https://www.sqlite.org/compile.html
@@ -174,6 +169,7 @@ ICU_LIB_DEPENDS= libicudata.so:devel/icu
ICU_CPPFLAGS= `${LOCALBASE}/bin/icu-config --cppflags` -DSQLITE_ENABLE_ICU=1
ICU_LDFLAGS= `${LOCALBASE}/bin/icu-config --ldflags`
+UNICODE61_CPPFLAGS= ""
UNICODE61_CPPFLAGS_OFF= -DSQLITE_DISABLE_FTS3_UNICODE=1
READLINES_CONFIGURE_ON= --enable-readline
@@ -197,6 +193,15 @@ UNKNOWN_SQL_CPPFLAGS= -DSQLITE_ENABLE_UNKNOWN_SQL_FUNCTION=1
.include <bsd.port.options.mk>
+# Platform Configuration
+.if !defined(WITH_DEBUG)
+CFLAGS+= -Os
+.endif
+CPPFLAGS+= -DHAVE_ISNAN=1 -DHAVE_MALLOC_USABLE_SIZE=1 -DHAVE_GMTIME_R=1 -DHAVE_LOCALTIME_R=1 -DHAVE_USLEEP=1
+.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000029)
+CPPFLAGS+= -DHAVE_STRCHRNUL=1
+.endif
+
post-configure:
@${ECHO_MSG} "===> CONFIGURE_ARGS=${CONFIGURE_ARGS}"
@${ECHO_MSG} "===> CPPFLAGS=${CPPFLAGS}"