aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2017-12-18 10:47:45 +0000
committerBen Woods <woodsb02@FreeBSD.org>2017-12-18 10:47:45 +0000
commitef7785986b248af43b185df400f50b042855eeb3 (patch)
treeaa72b6426258fa34af45fe3eb7023b8fb1a3fb45
parent59840eb8405883120046907cc5d9b586708869ae (diff)
downloadports-ef7785986b248af43b185df400f50b042855eeb3.tar.gz
ports-ef7785986b248af43b185df400f50b042855eeb3.zip
MFH: r456522
misc/mc: Fix SUBSHELL blank terminal upon opening in xterm with Slang Note: Unfortunately this does not fix this issue on the FreeBSD console. PR: 217758 Submitted by: Alexander Moisseev <moiseev@mezonplus.ru> Reported by: Dron <dron_2@ua.fm> Reported by: danfe Approved by: ports-secteam (delphij)
Notes
Notes: svn path=/branches/2017Q4/; revision=456605
-rw-r--r--misc/mc/Makefile1
-rw-r--r--misc/mc/files/patch-lib_tty_tty-slang.c28
2 files changed, 29 insertions, 0 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 6e93893b18a6..35883ae30016 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -4,6 +4,7 @@
PORTNAME= mc
PORTVERSION= 4.8.19
PORTREVISION= 3
+PORTREVISION= 1
CATEGORIES= misc shells
MASTER_SITES= http://ftp.midnight-commander.org/ \
http://ftp.osuosl.org/pub/midnightcommander/
diff --git a/misc/mc/files/patch-lib_tty_tty-slang.c b/misc/mc/files/patch-lib_tty_tty-slang.c
new file mode 100644
index 000000000000..fb0f07ff29ba
--- /dev/null
+++ b/misc/mc/files/patch-lib_tty_tty-slang.c
@@ -0,0 +1,28 @@
+--- lib/tty/tty-slang.c.orig 2017-03-04 17:51:38 UTC
++++ lib/tty/tty-slang.c
+@@ -373,7 +373,11 @@ tty_shutdown (void)
+ void
+ tty_enter_ca_mode (void)
+ {
+- /* S-Lang handles alternate screen switching and cursor position saving */
++ if (mc_global.tty.xterm_flag)
++ {
++ fprintf (stdout, /* ESC_STR ")0" */ ESC_STR "7" ESC_STR "[?47h");
++ fflush (stdout);
++ }
+ }
+
+ /* --------------------------------------------------------------------------------------------- */
+@@ -381,7 +385,11 @@ tty_enter_ca_mode (void)
+ void
+ tty_exit_ca_mode (void)
+ {
+- /* S-Lang handles alternate screen switching and cursor position restoring */
++ if (mc_global.tty.xterm_flag)
++ {
++ fprintf (stdout, ESC_STR "[?47l" ESC_STR "8" ESC_STR "[m");
++ fflush (stdout);
++ }
+ }
+
+ /* --------------------------------------------------------------------------------------------- */