aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2020-03-18 00:51:59 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2020-03-18 00:51:59 +0000
commitbab5719cdd352d46866ae482aef91eef51e6ebfa (patch)
treec49d31f7cfabcd1cc81c4800d82230963eaf8de3
parentf57f99ffdc579306f58108211fed24e26f5284a7 (diff)
downloadports-bab5719cdd352d46866ae482aef91eef51e6ebfa.tar.gz
ports-bab5719cdd352d46866ae482aef91eef51e6ebfa.zip
MFH: r528619 devel/py-virtualenvwrapper: Fix virtualenvwrapper_lazy.sh wrapper
Fix the virtualenvwrapper_lazy.sh wrapper to invoke the Python versions-specific virtualenvwrapper.sh script that the port/package was built with, preventing the following error: ERROR: virtualenvwrapper_lazy.sh: Could not find virtualenvwrapper.sh While I'm here: - Update pkg-descr WWW: URL to match setup.py:homepage - Update COMMENT to match setup.py:summary Approved by: portmgr (blanket: ports (python) compliance, run-time bugfix) Approved by: ports-secteam (blanket: ports (python) compliance, run-time bugfix)
Notes
Notes: svn path=/branches/2020Q1/; revision=528620
-rw-r--r--devel/py-virtualenvwrapper/Makefile9
-rw-r--r--devel/py-virtualenvwrapper/pkg-descr2
2 files changed, 7 insertions, 4 deletions
diff --git a/devel/py-virtualenvwrapper/Makefile b/devel/py-virtualenvwrapper/Makefile
index 6a403bdaf8d5..5f6f417822e7 100644
--- a/devel/py-virtualenvwrapper/Makefile
+++ b/devel/py-virtualenvwrapper/Makefile
@@ -3,13 +3,13 @@
PORTNAME= virtualenvwrapper
PORTVERSION= 4.8.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
-COMMENT= Set of extensions to virtualenv
+COMMENT= Enhancements to virtualenv
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -33,11 +33,14 @@ DOCS_VARS= PYDISTUTILS_BUILD_TARGET+=build_sphinx \
NO_ARCH= yes
post-patch:
- @${REINPLACE_CMD} \
+ ${REINPLACE_CMD} \
-e 's|$$(command \\which python)|${PYTHON_CMD}|1' \
-e 's|="virtualenv"|="virtualenv${UNIQUE_SUFFIX}"|1' \
-e 's|="virtualenv-clone"|="virtualenv-clone${UNIQUE_SUFFIX}"|1' \
${WRKSRC}/${PORTNAME}.sh
+ ${REINPLACE_CMD} \
+ -e 's|which virtualenvwrapper.sh|which ${PORTNAME}.sh${UNIQUE_SUFFIX}|' \
+ ${WRKSRC}/${PORTNAME}_lazy.sh
post-patch-DOCS-on:
@${REINPLACE_CMD} -e 's|python setup.py|${PYTHON_CMD} setup.py|' \
diff --git a/devel/py-virtualenvwrapper/pkg-descr b/devel/py-virtualenvwrapper/pkg-descr
index 396ecf54d669..887b86dd4fdf 100644
--- a/devel/py-virtualenvwrapper/pkg-descr
+++ b/devel/py-virtualenvwrapper/pkg-descr
@@ -5,4 +5,4 @@ managing your development workflow, making it easier to work on more
than one project at a time without introducing conflicts in their
dependencies.
-WWW: http://virtualenvwrapper.readthedocs.org/en/latest/index.html
+WWW: https://virtualenvwrapper.readthedocs.io/