aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Wolf <matthias@rheinwolf.de>2021-05-11 18:13:16 +0000
committerRene Ladan <rene@FreeBSD.org>2021-05-13 09:14:29 +0000
commitc4e5afaa3eff2329260f712ea36c7969e5dd78da (patch)
tree26081908b12576112620bdc5a9913a8e6d7bd2c5
parentaf0c6cb39f80528e5a975152844307706fc97270 (diff)
downloadports-c4e5afaa3eff2329260f712ea36c7969e5dd78da.tar.gz
ports-c4e5afaa3eff2329260f712ea36c7969e5dd78da.zip
www/chromium: update to 90.0.4430.212
MFH: 2021Q2 Security: https://vuxml.freebsd.org/freebsd/3cac007f-b27e-11eb-97a0-e09467587c17.html (cherry picked from commit ee49491174986c7e5e54f7ccbd2e6d038f6791fb)
-rw-r--r--www/chromium/Makefile2
-rw-r--r--www/chromium/distinfo10
-rw-r--r--www/chromium/files/patch-third__party_webrtc_modules_video__coding_codecs_h264_h264__decoder__impl.cc12
3 files changed, 16 insertions, 8 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 85750ca378aa..5a5b33075650 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -1,7 +1,7 @@
# Created by: Florent Thoumie <flz@FreeBSD.org>
PORTNAME= chromium
-PORTVERSION= 90.0.4430.93
+PORTVERSION= 90.0.4430.212
CATEGORIES= www java
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
LOCAL/rene/chromium/:fonts
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index 89045163f38d..8be9f1212a33 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,7 +1,3 @@
-TIMESTAMP = 1619508995
-SHA256 (chromium-90.0.4430.93.tar.xz) = 532ec75f4e08384fe2fb17b69af9210103379ee212dbf0bf081bdc5d4eca357e
-SIZE (chromium-90.0.4430.93.tar.xz) = 917357836
-SHA256 (chromium-90.0.4430.93-testdata.tar.xz) = fff80fe158223770d12a93ef67ca8690473c62e9b1997e59e991f32161659579
-SIZE (chromium-90.0.4430.93-testdata.tar.xz) = 256588960
-SHA256 (test_fonts-85.tar.xz) = f22b61b3639acb147c98ec2e2305d8b96f0b55c8c74c40e2ea696402fae8cef9
-SIZE (test_fonts-85.tar.xz) = 9511984
+TIMESTAMP = 1620717235
+SHA256 (chromium-90.0.4430.212.tar.xz) = abe11d0cb1ff21278aad2eec1a1e279d59176b15331804d7df1807446786d59e
+SIZE (chromium-90.0.4430.212.tar.xz) = 917430448
diff --git a/www/chromium/files/patch-third__party_webrtc_modules_video__coding_codecs_h264_h264__decoder__impl.cc b/www/chromium/files/patch-third__party_webrtc_modules_video__coding_codecs_h264_h264__decoder__impl.cc
new file mode 100644
index 000000000000..83f4afc9a103
--- /dev/null
+++ b/www/chromium/files/patch-third__party_webrtc_modules_video__coding_codecs_h264_h264__decoder__impl.cc
@@ -0,0 +1,12 @@
+--- third_party/webrtc/modules/video_coding/codecs/h264/h264_decoder_impl.cc.orig 2021-04-30 09:00:21.722978000 +0000
++++ third_party/webrtc/modules/video_coding/codecs/h264/h264_decoder_impl.cc 2021-04-30 09:00:54.473978000 +0000
+@@ -202,6 +202,9 @@
+ // a pointer |this|.
+ av_context_->opaque = this;
+
++ // Initializing |lowres|
++ av_context_->lowres = 0;
++
+ AVCodec* codec = avcodec_find_decoder(av_context_->codec_id);
+ if (!codec) {
+ // This is an indication that FFmpeg has not been initialized or it has not