aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2022-11-24 20:36:25 +0000
committerCy Schubert <cy@FreeBSD.org>2022-12-05 20:06:15 +0000
commit3c82f0cb8a253f74f2befa66c4ea1d654ce5ec9c (patch)
treeb2ef8767e82ce4f03334fb969f424c3c1053fe37
parentc4a04da5be275e110b187e63e34038bc9bb77ec8 (diff)
downloadports-3c82f0cb8a253f74f2befa66c4ea1d654ce5ec9c.tar.gz
ports-3c82f0cb8a253f74f2befa66c4ea1d654ce5ec9c.zip
Partially revert "security/heimdal*: Remove LLVM_DEFAULT build prerequisite"
The suggested workaround will only work when autoreconf is not run. The devel port still needs LLVM_DEFAULT while the non-devel port does not PR: 267814 Fixes: 22a683a337ef This partially reverts commit 22a683a337efe7169b61de8c9ec63e2c0d561891. (cherry picked from commit 286254e283f60ef160b572c8d76db06ac2b87c1a)
-rw-r--r--security/heimdal-devel/Makefile5
-rw-r--r--security/heimdal-devel/files/patch-configure.ac15
2 files changed, 7 insertions, 13 deletions
diff --git a/security/heimdal-devel/Makefile b/security/heimdal-devel/Makefile
index 9910558554e5..96ddcd0afc64 100644
--- a/security/heimdal-devel/Makefile
+++ b/security/heimdal-devel/Makefile
@@ -23,7 +23,10 @@ USES= autoreconf:build cpe gettext-runtime gssapi:bootstrap,heimdal \
CPE_VENDOR= ${PORTNAME}_project
USE_LDCONFIG= ${GSSAPILIBDIR}
-BUILD_DEPENDS= p5-JSON>0:converters/p5-JSON
+# Needs clang-format which is only provided by the port.
+# Else asm1_fails resulting in a command not found error.
+BUILD_DEPENDS= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT} \
+ p5-JSON>0:converters/p5-JSON
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_fnmatch_h=yes \
diff --git a/security/heimdal-devel/files/patch-configure.ac b/security/heimdal-devel/files/patch-configure.ac
index b616d032b93a..048b6c83b622 100644
--- a/security/heimdal-devel/files/patch-configure.ac
+++ b/security/heimdal-devel/files/patch-configure.ac
@@ -1,15 +1,6 @@
---- configure.ac.orig 2022-11-17 16:55:32.000000000 -0800
-+++ configure.ac 2022-11-24 07:19:25.053801000 -0800
-@@ -19,7 +19,7 @@
- AM_PROG_CC_C_O
- AC_PROG_CPP
- AM_PATH_PYTHON
--AC_CHECK_PROG(CLANG_FORMAT, clang-format, [clang-format], [no])
-+AC_CHECK_PROG(CLANG_FORMAT, clang-format, [clang-format], [])
- test "$CLANG_FORMAT" = no && CLANG_FORMAT=true
-
- m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-@@ -177,6 +177,7 @@
+--- configure.ac.orig 2019-06-07 06:21:39 UTC
++++ configure.ac
+@@ -153,6 +153,7 @@ AC_ARG_ENABLE(kx509,
if test "$enable_kx509" != no ;then
AC_DEFINE([KX509], 1, [Define to enable kx509.])
fi