aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-03-16 12:58:16 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-03-16 12:58:16 +0000
commitf7731c8be869e5b2f2797f9f8e2df315aa243a04 (patch)
treecd771deb19a99a0daf138afa2b966f56b7d36b63
parent9d50ebf5193ad227f1cd4d5fc99b42fdbb0ab0c1 (diff)
downloadports-f7731c8be869e5b2f2797f9f8e2df315aa243a04.tar.gz
ports-f7731c8be869e5b2f2797f9f8e2df315aa243a04.zip
Drop default directory from _DEPENDS in my ports
Notes
Notes: svn path=/head/; revision=411229
-rw-r--r--audio/alsa-plugins/Makefile12
-rw-r--r--audio/alsa-utils/Makefile8
-rw-r--r--audio/wavbreaker/Makefile2
-rw-r--r--devel/android-tools-adb-devel/Makefile2
-rw-r--r--devel/android-tools-adb/Makefile2
-rw-r--r--devel/android-tools-fastboot/Makefile2
-rw-r--r--devel/android-tools-simpleperf/Makefile4
-rw-r--r--devel/fb-adb/Makefile14
-rw-r--r--devel/googlemock/Makefile6
-rw-r--r--devel/lua-luarocks/Makefile20
-rw-r--r--devel/onscripter/Makefile6
-rw-r--r--devel/ponscripter-sekai/Makefile10
-rw-r--r--devel/py-game_sdl2/Makefile4
-rw-r--r--devel/renpy/Makefile16
-rw-r--r--devel/rlvm/Makefile22
-rw-r--r--emulators/ppsspp/Makefile12
-rw-r--r--emulators/xsystem35/Makefile8
-rw-r--r--games/aquaria/Makefile10
-rw-r--r--games/katawa-shoujo/Makefile2
-rw-r--r--games/narcissu2/Makefile2
-rw-r--r--games/openbor/Makefile12
-rw-r--r--games/openra/Makefile10
-rw-r--r--graphics/waifu2x-converter-cpp/Makefile6
-rw-r--r--mail/mpop/Makefile8
-rw-r--r--multimedia/baka-mplayer/Makefile4
-rw-r--r--multimedia/libmtp/Makefile2
-rw-r--r--sysutils/fusefs-simple-mtpfs/Makefile2
-rw-r--r--sysutils/rinse/Makefile4
-rw-r--r--sysutils/uhidd/Makefile4
-rw-r--r--x11-drivers/xf86-input-wacom/Makefile4
30 files changed, 110 insertions, 110 deletions
diff --git a/audio/alsa-plugins/Makefile b/audio/alsa-plugins/Makefile
index b3ecc90e57ae..f14db5caf324 100644
--- a/audio/alsa-plugins/Makefile
+++ b/audio/alsa-plugins/Makefile
@@ -13,7 +13,7 @@ COMMENT= ALSA compatibility library plugins
LICENSE= LGPL21+
-LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS= libasound.so:audio/alsa-lib
GNU_CONFIGURE= yes
USES= alias libtool:keepla localbase pkgconfig tar:bzip2
@@ -38,20 +38,20 @@ BLKCNT_P2_CFLAGS=-DFREEBSD_OSS_BLKCNT_P2
BUFSZ_P2_CFLAGS=-DFREEBSD_OSS_BUFSZ_P2
VERBOSE_CFLAGS= -DFREEBSD_OSS_DEBUG_VERBOSE
-JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
+JACK_LIB_DEPENDS= libjack.so:audio/jack
JACK_CONFIGURE_ENABLE= jack
JACK_IMPLIES= SAMPLERATE
-FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
+FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
FFMPEG_CONFIGURE_ENABLE=avcodec
-PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_ENABLE=pulseaudio
-SAMPLERATE_LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
+SAMPLERATE_LIB_DEPENDS= libsamplerate.so:audio/libsamplerate
SAMPLERATE_CONFIGURE_ENABLE=samplerate
-SPEEX_LIB_DEPENDS= libspeex.so:${PORTSDIR}/audio/speex
+SPEEX_LIB_DEPENDS= libspeex.so:audio/speex
SPEEX_CONFIGURE_ON= --with-speex=lib
SPEEX_CONFIGURE_OFF= --without-speex
diff --git a/audio/alsa-utils/Makefile b/audio/alsa-utils/Makefile
index 71ecbd927fc1..dbb2848631b9 100644
--- a/audio/alsa-utils/Makefile
+++ b/audio/alsa-utils/Makefile
@@ -12,8 +12,8 @@ COMMENT= ALSA compatibility utils
LICENSE= GPLv2+
-LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
-RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins
+LIB_DEPENDS= libasound.so:audio/alsa-lib
+RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:audio/alsa-plugins
USES= gmake localbase shebangfix tar:bzip2
GNU_CONFIGURE= yes
@@ -27,10 +27,10 @@ OPTIONS_DEFINE= BAT MANPAGES NLS
OPTIONS_DEFAULT=BAT MANPAGES
BAT_DESC= Basic Audio Tester support
-BAT_LIB_DEPENDS=libfftw3.so:${PORTSDIR}/math/fftw3
+BAT_LIB_DEPENDS=libfftw3.so:math/fftw3
BAT_CONFIGURE_ENABLE=bat
-MANPAGES_BUILD_DEPENDS= xmlto:${PORTSDIR}/textproc/xmlto
+MANPAGES_BUILD_DEPENDS= xmlto:textproc/xmlto
MANPAGES_CONFIGURE_ENABLE=xmlto
NLS_USES= gettext
diff --git a/audio/wavbreaker/Makefile b/audio/wavbreaker/Makefile
index 4cf4b14779a6..1e415068debc 100644
--- a/audio/wavbreaker/Makefile
+++ b/audio/wavbreaker/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2+
OPTIONS_DEFINE= PULSEAUDIO NLS
OPTIONS_SUB= yes
-PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_ENABLE=pulse
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
diff --git a/devel/android-tools-adb-devel/Makefile b/devel/android-tools-adb-devel/Makefile
index 9bce76418687..859c3451896c 100644
--- a/devel/android-tools-adb-devel/Makefile
+++ b/devel/android-tools-adb-devel/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE= TEST_PYTHON
TEST_PYTHON_DESC= ${TEST_DESC:S/tests/python &/}
TEST_PYTHON_GH_PROJECT= platform_development:development
TEST_PYTHON_GH_TAGNAME= ${DISTVERSIONFULL:C/-[0-9].*//}-2510-g72f24a0:development
-TEST_PYTHON_BUILD_DEPENDS=${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
+TEST_PYTHON_BUILD_DEPENDS=${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock
TEST_PYTHON_USES= python:2.7,build
pre-install-TEST_PYTHON-on:
diff --git a/devel/android-tools-adb/Makefile b/devel/android-tools-adb/Makefile
index bf612084a1a6..f1293cc7806d 100644
--- a/devel/android-tools-adb/Makefile
+++ b/devel/android-tools-adb/Makefile
@@ -58,7 +58,7 @@ BASH_VARS= LICENSE+=MIT LICENSE_COMB=multi
DOCS_MAKE_ARGS_OFF= FILES="" FILESDIR=""
-TEST_BUILD_DEPENDS= googletest>=1.6.0:${PORTSDIR}/devel/googletest
+TEST_BUILD_DEPENDS= googletest>=1.6.0:devel/googletest
TEST_ALL_TARGET= adb_test
pre-install-TEST-on: do-test
diff --git a/devel/android-tools-fastboot/Makefile b/devel/android-tools-fastboot/Makefile
index ce189aae61b7..02622b9c9c00 100644
--- a/devel/android-tools-fastboot/Makefile
+++ b/devel/android-tools-fastboot/Makefile
@@ -16,7 +16,7 @@ LICENSE= APACHE20 BSD2CLAUSE PD
LICENSE_COMB= multi
LICENSE_FILE_PD= ${WRKSRC}/libselinux/NOTICE
-LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:devel/pcre
USE_GITHUB= yes
GH_ACCOUNT= android jbeich:extras,libselinux
diff --git a/devel/android-tools-simpleperf/Makefile b/devel/android-tools-simpleperf/Makefile
index b3d5b9a84fa3..b4141b8d7dfb 100644
--- a/devel/android-tools-simpleperf/Makefile
+++ b/devel/android-tools-simpleperf/Makefile
@@ -11,7 +11,7 @@ COMMENT= Android simpleperf tool
LICENSE= APACHE20
-BUILD_DEPENDS= llvm-config${LLVM_VER}:${PORTSDIR}/devel/llvm${LLVM_VER}
+BUILD_DEPENDS= llvm-config${LLVM_VER}:devel/llvm${LLVM_VER}
USE_GITHUB= yes
GH_ACCOUNT= android:bionic,core jbeich
@@ -35,7 +35,7 @@ LLVM_VER?= 36 # XXX Move to DEFAULT_VERSIONS
OPTIONS_DEFINE= TEST
-TEST_BUILD_DEPENDS= googletest>=1.6.0:${PORTSDIR}/devel/googletest
+TEST_BUILD_DEPENDS= googletest>=1.6.0:devel/googletest
TEST_ALL_TARGET= simpleperf_test
post-extract:
diff --git a/devel/fb-adb/Makefile b/devel/fb-adb/Makefile
index 96e2abe45af3..c499e3304f0c 100644
--- a/devel/fb-adb/Makefile
+++ b/devel/fb-adb/Makefile
@@ -11,9 +11,9 @@ COMMENT= Better shell for Android devices
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= xxd:${PORTSDIR}/editors/vim-lite \
- ${BASH_CMD}:${PORTSDIR}/shells/${BASH_CMD:T}
-RUN_DEPENDS= adb:${PORTSDIR}/devel/android-tools-adb
+BUILD_DEPENDS= xxd:editors/vim-lite \
+ ${BASH_CMD}:shells/${BASH_CMD:T}
+RUN_DEPENDS= adb:devel/android-tools-adb
USE_GITHUB= yes
GH_ACCOUNT= facebook
@@ -47,7 +47,7 @@ OPTIONS_EXCLUDE_DragonFly=NDK
ASSERT_CONFIGURE_ENABLE=checking
BASH_DESC= Install JSON parser used by bash-completion
-BASH_RUN_DEPENDS= jq:${PORTSDIR}/textproc/jq
+BASH_RUN_DEPENDS= jq:textproc/jq
DEBUG_CONFIGURE_ENABLE= debuggable-stubs
# XXX Convert into USES=android once more things depend on it
@@ -67,8 +67,8 @@ NDK_SHELL= ${SETENV} UNAME_s=Linux UNAME_m=${LINUX_RPM_ARCH} ${SH}
NDK_CONFIGURE_ENV= ANDROID_NDK="${WRKSRC_ndk}" \
ANDROID_NDK_SHELL="${NDK_SHELL}" \
NDK_TMPDIR="${WRKDIR}"
-NDK_BUILD_DEPENDS_OFF= ${LOCALBASE}/android/ARMv7/bin/arm-aux-linux-androideabi-gcc:${PORTSDIR}/lang/gnatdroid-armv7 \
- ${LOCALBASE}/android-x86/x86_32/bin/i686-aux-linux-android-gcc:${PORTSDIR}/lang/gnatdroid-x86
+NDK_BUILD_DEPENDS_OFF= ${LOCALBASE}/android/ARMv7/bin/arm-aux-linux-androideabi-gcc:lang/gnatdroid-armv7 \
+ ${LOCALBASE}/android-x86/x86_32/bin/i686-aux-linux-android-gcc:lang/gnatdroid-x86
.if defined(.PARSEDIR)
NDK_CONFIGURE_ENV_OFF= PATH="${NDK_BUILD_DEPENDS_OFF:C/:.*//:H:ts:}:$$PATH"
.else
@@ -116,7 +116,7 @@ do-autoreconf:
.if defined(OVERRIDE_LINUX_BASE_PORT) || \
(${OPSYS} == FreeBSD && ${OSVERSION} < 1000009)
EXTRACT_ONLY+= ${DISTFILES:N*\:*p7zip*:C/:.*//}
-EXTRACT_DEPENDS+=${P7ZIP_CMD}:${PORTSDIR}/archivers/p7zip
+EXTRACT_DEPENDS+=${P7ZIP_CMD}:archivers/p7zip
P7ZIP_CMD?= 7z
P7ZIP_ARGS?= x -bd -y -o${WRKDIR} >/dev/null
diff --git a/devel/googlemock/Makefile b/devel/googlemock/Makefile
index 198e02a6e35e..eda5e6b8a396 100644
--- a/devel/googlemock/Makefile
+++ b/devel/googlemock/Makefile
@@ -13,9 +13,9 @@ COMMENT= Library for writing and using C++ mock classes
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ax_pthread.m4:${PORTSDIR}/devel/autoconf-archive \
- googletest>=1.7.0:${PORTSDIR}/devel/googletest
-LIB_DEPENDS= libgtest.so:${PORTSDIR}/devel/googletest
+BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ax_pthread.m4:devel/autoconf-archive \
+ googletest>=1.7.0:devel/googletest
+LIB_DEPENDS= libgtest.so:devel/googletest
USE_GITHUB= yes
GH_ACCOUNT= google
diff --git a/devel/lua-luarocks/Makefile b/devel/lua-luarocks/Makefile
index 2470b8ac65a7..42dc6f701f49 100644
--- a/devel/lua-luarocks/Makefile
+++ b/devel/lua-luarocks/Makefile
@@ -12,8 +12,8 @@ COMMENT= Package manager for Lua modules
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- curl:${PORTSDIR}/ftp/curl
+RUN_DEPENDS= zip:archivers/zip \
+ curl:ftp/curl
USE_GITHUB= yes
GH_ACCOUNT= keplerproject
@@ -36,22 +36,22 @@ FETCH_DESC= Fetch from repositories
OPTIONS_GROUP_FETCH= CVS GIT HG SVN
CMAKE_DESC= CMake support
-CMAKE_RUN_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+CMAKE_RUN_DEPENDS= cmake:devel/cmake
GMAKE_DESC= GNU Make support
-GMAKE_RUN_DEPENDS= gmake:${PORTSDIR}/devel/gmake
+GMAKE_RUN_DEPENDS= gmake:devel/gmake
CVS_DESC= CVS support
-CVS_RUN_DEPENDS= cvs:${PORTSDIR}/devel/cvs-devel
+CVS_RUN_DEPENDS= cvs:devel/cvs-devel
GIT_DESC= Git support
-GIT_RUN_DEPENDS= git:${PORTSDIR}/devel/git
+GIT_RUN_DEPENDS= git:devel/git
HG_DESC= Mercurial support
-HG_RUN_DEPENDS= hg:${PORTSDIR}/devel/mercurial
+HG_RUN_DEPENDS= hg:devel/mercurial
SVN_DESC= Subversion support
-SVN_RUN_DEPENDS= svn:${PORTSDIR}/devel/subversion
+SVN_RUN_DEPENDS= svn:devel/subversion
LUAJIT_DESC= Use LuaJIT instead of Lua
-LUAJIT_BUILD_DEPENDS= luajit:${PORTSDIR}/lang/luajit
-LUAJIT_RUN_DEPENDS= luajit:${PORTSDIR}/lang/luajit
+LUAJIT_BUILD_DEPENDS= luajit:lang/luajit
+LUAJIT_RUN_DEPENDS= luajit:lang/luajit
LUAJIT_CONFIGURE_ON= --lua-suffix=jit
LUAJIT_PLIST_SUB= LUA_VER=${LUA_VER} \
LUA_MODSHAREDIR=share/lua/${LUA_VER}
diff --git a/devel/onscripter/Makefile b/devel/onscripter/Makefile
index 83cba6505725..80d0feb83dc1 100644
--- a/devel/onscripter/Makefile
+++ b/devel/onscripter/Makefile
@@ -10,9 +10,9 @@ COMMENT?= Visual novel engine compatible with NScripter
LICENSE= GPLv2+
-LIB_DEPENDS= libsmpeg.so:${PORTSDIR}/multimedia/smpeg \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
-RUN_DEPENDS= sdl_ttf>=2.0.11_6:${PORTSDIR}/graphics/sdl_ttf
+LIB_DEPENDS= libsmpeg.so:multimedia/smpeg \
+ libfontconfig.so:x11-fonts/fontconfig
+RUN_DEPENDS= sdl_ttf>=2.0.11_6:graphics/sdl_ttf
USES= gmake
USE_SDL= image mixer ttf
diff --git a/devel/ponscripter-sekai/Makefile b/devel/ponscripter-sekai/Makefile
index 09ff2b23d40a..1a443d656060 100644
--- a/devel/ponscripter-sekai/Makefile
+++ b/devel/ponscripter-sekai/Makefile
@@ -11,8 +11,8 @@ COMMENT= NScripter-like novel-game interpreter with Unicode support
LICENSE= GPLv2+
-LIB_DEPENDS= libsmpeg2.so:${PORTSDIR}/multimedia/smpeg2 \
- libfreetype.so:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libsmpeg2.so:multimedia/smpeg2 \
+ libfreetype.so:print/freetype2
CONFLICTS= ponscripter-[0-9]* # doesn't exist yet
@@ -37,16 +37,16 @@ PLIST_FILES= bin/ponscr \
OPTIONS_DEFINE= DOCS MANPAGES TREMOR
OPTIONS_DEFAULT=MANPAGES ${MACHINE_CPU:tu:MSOFTFP:S/SOFTFP/TREMOR/}
-MANPAGES_BUILD_DEPENDS= xmlto:${PORTSDIR}/textproc/xmlto
+MANPAGES_BUILD_DEPENDS= xmlto:textproc/xmlto
MANPAGES_PLIST_FILES=\
man/man6/ponscr.6.gz \
man/man7/ponscr-ext.7.gz \
man/man7/ponscr-syntax.7.gz \
man/man7/ponscripter.7.gz
-TREMOR_LIB_DEPENDS= libvorbisidec.so:${PORTSDIR}/audio/libtremor
+TREMOR_LIB_DEPENDS= libvorbisidec.so:audio/libtremor
TREMOR_CFLAGS= -DINTEGER_OGG_VORBIS
-TREMOR_LIB_DEPENDS_OFF= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
+TREMOR_LIB_DEPENDS_OFF= libvorbisfile.so:audio/libvorbis
post-patch:
@${REINPLACE_CMD} -e '/^ifdef DEBUG/,/^$$/d' \
diff --git a/devel/py-game_sdl2/Makefile b/devel/py-game_sdl2/Makefile
index 79c9a218fbf8..d3223653089d 100644
--- a/devel/py-game_sdl2/Makefile
+++ b/devel/py-game_sdl2/Makefile
@@ -14,8 +14,8 @@ COMMENT= Reimplementation of portions of the pygame API using SDL2
LICENSE= LGPL21+ ZLIB
LICENSE_COMB= multi
-BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython
-LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
+BUILD_DEPENDS= cython:lang/cython
+LIB_DEPENDS= libpng.so:graphics/png
# Upstream tends to reroll distfiles before moving under /release/
PORTSCOUT= site:http://www.renpy.org/dl/release/
diff --git a/devel/renpy/Makefile b/devel/renpy/Makefile
index ab8cf77692de..80596f0fa91a 100644
--- a/devel/renpy/Makefile
+++ b/devel/renpy/Makefile
@@ -16,13 +16,13 @@ LICENSE_NAME_DejaVu= Bitstream Vera and Arev fonts license
LICENSE_FILE_DejaVu= ${WRKSRC}/renpy/common/DejaVuSans.txt
LICENSE_PERMS_DejaVu= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>0:${PORTSDIR}/devel/py-game_sdl2 \
- cython:${PORTSDIR}/lang/cython
-LIB_DEPENDS= libfribidi.so:${PORTSDIR}/converters/fribidi \
- libpng.so:${PORTSDIR}/graphics/png \
- libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
- libfreetype.so:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>=${PORTVERSION}:${PORTSDIR}/devel/py-game_sdl2
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>0:devel/py-game_sdl2 \
+ cython:lang/cython
+LIB_DEPENDS= libfribidi.so:converters/fribidi \
+ libpng.so:graphics/png \
+ libavcodec.so:multimedia/ffmpeg \
+ libfreetype.so:print/freetype2
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>=${PORTVERSION}:devel/py-game_sdl2
# Upstream tends to reroll distfiles before moving under /release/
PORTSCOUT= site:http://www.renpy.org/dl/release/
@@ -56,7 +56,7 @@ DIST_VARS= LICENSE+="ART20 PSFL" \
PORTDATA+="lib renpy.app renpy.exe renpy.sh"
EXAMPLES_VARS= PORTDATA+="the_question tutorial"
TKINTER_DESC= Install Tkinter to allow choosing Projects Directory
-TKINTER_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
+TKINTER_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
. for lic in FREETYPE LIBJPEG LIBPNG MSVCR90
DIST_VARS+= LICENSE+=${lic}
diff --git a/devel/rlvm/Makefile b/devel/rlvm/Makefile
index 63baf1689506..37426be5b09a 100644
--- a/devel/rlvm/Makefile
+++ b/devel/rlvm/Makefile
@@ -10,11 +10,11 @@ COMMENT= RealLive virtual machine clone
LICENSE= GPLv2 GPLv3 MIT
LICENSE_COMB= multi
-BUILD_DEPENDS= ${LOCALBASE}/include/utf8.h:${PORTSDIR}/devel/utf8cpp
-LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
- libboost_serialization.so:${PORTSDIR}/devel/boost-libs \
- libguichan.so:${PORTSDIR}/devel/guichan
-RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
+BUILD_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp
+LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
+ libboost_serialization.so:devel/boost-libs \
+ libguichan.so:devel/guichan
+RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
USE_GITHUB= yes
GH_ACCOUNT= eglaysher
@@ -41,19 +41,19 @@ OPTIONS_SUB= yes
JAPANESE_FONT_DESC=msgothic.ttc alternatives with verified metrics (unless --font)
KOCHI_DESC= kochi-gothic-subst.ttf from japanese/font-kochi
-KOCHI_RUN_DEPENDS=${LOCALBASE}/share/fonts/TTF/kochi-gothic-subst.ttf:${PORTSDIR}/japanese/font-kochi
+KOCHI_RUN_DEPENDS=${LOCALBASE}/share/fonts/TTF/kochi-gothic-subst.ttf:japanese/font-kochi
MONA_DESC= mona.ttf from japanese/monafonts-ttf
-MONA_RUN_DEPENDS=${LOCALBASE}/share/fonts/TrueType/mona.ttf:${PORTSDIR}/japanese/monafonts-ttf
+MONA_RUN_DEPENDS=${LOCALBASE}/share/fonts/TrueType/mona.ttf:japanese/monafonts-ttf
SAZANAMI_DESC= sazanami-gothic.ttf from japanese/font-sazanami
-SAZANAMI_RUN_DEPENDS=${LOCALBASE}/share/fonts/TTF/sazanami-gothic.ttf:${PORTSDIR}/japanese/font-sazanami
+SAZANAMI_RUN_DEPENDS=${LOCALBASE}/share/fonts/TTF/sazanami-gothic.ttf:japanese/font-sazanami
DEBUG_MAKE_ARGS_OFF=--release
NLS_USES= gettext
NLS_EXTRA_PATCHES_OFF=${FILESDIR}/extra-patch-disable-nls
TEST_USES= lua:51
-TEST_BUILD_DEPENDS=googletest>=1.7.0:${PORTSDIR}/devel/googletest \
- googlemock>=1.7.0:${PORTSDIR}/devel/googlemock \
- luabind>0:${PORTSDIR}/devel/luabind
+TEST_BUILD_DEPENDS=googletest>=1.7.0:devel/googletest \
+ googlemock>=1.7.0:devel/googlemock \
+ luabind>0:devel/luabind
TEST_EXTRA_PATCHES_OFF=${FILESDIR}/extra-patch-disable-test
post-patch:
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index 42b4bdf2bba0..10b1586b3d00 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -15,10 +15,10 @@ COMMENT= PSP emulator in C++ with dynarec JIT for x86, ARM, MIPS
LICENSE= GPLv2+
-LIB_DEPENDS= libzip.so:${PORTSDIR}/archivers/libzip \
- libsnappy.so:${PORTSDIR}/archivers/snappy \
- libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
-RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
+LIB_DEPENDS= libzip.so:archivers/libzip \
+ libsnappy.so:archivers/snappy \
+ libavcodec.so:multimedia/ffmpeg
+RUN_DEPENDS= xdg-open:devel/xdg-utils
USE_GITHUB= yes
GH_ACCOUNT= hrydgard:DEFAULT,lang Kingcom:ext_armips
@@ -54,8 +54,8 @@ QT4_USE= QT4=qmake_build,moc_build,rcc_build,uic_build,linguisttools_build,gui,o
QT5_USES= qmake:outsource
QT5_USE= QT5=qmake_build,buildtools_build,linguisttools_build,gui,opengl,widgets
SDL_USES= cmake:outsource ninja
-SDL_BUILD_DEPENDS= png>=1.6:${PORTSDIR}/graphics/png
-SDL_LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
+SDL_BUILD_DEPENDS= png>=1.6:graphics/png
+SDL_LIB_DEPENDS= libpng.so:graphics/png
SDL_VARS= PORTDATA+="assets ${PORTNAME}"
post-extract:
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index 6b4884ae6cdc..54f5fe8302d1 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -13,9 +13,9 @@ COMMENT= AliceSoft System 3.5/3.6/3.8/3.9 on X Window System
LICENSE= GPLv2+
-LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
- libltdl.so:${PORTSDIR}/devel/libltdl \
- libfreetype.so:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
+ libltdl.so:devel/libltdl \
+ libfreetype.so:print/freetype2
OPTIONS_DEFINE= ESOUND DOCS EXAMPLES
OPTIONS_DEFINE_i386= MMX
@@ -31,7 +31,7 @@ GTK1_CONFIGURE_OFF=--with-glib-prefix=${NONEXISTENT} \
--with-gtk-prefix=${NONEXISTENT}
GTK2_USE= GNOME=gtk20
GTK2_USES= pkgconfig
-MMX_BUILD_DEPENDS=nasm:${PORTSDIR}/devel/nasm
+MMX_BUILD_DEPENDS=nasm:devel/nasm
MMX_CONFIGURE_ENABLE=mmx
EXTRACT_AFTER_ARGS=--exclude libltdl
diff --git a/games/aquaria/Makefile b/games/aquaria/Makefile
index d55679b1c064..5daaed23972a 100644
--- a/games/aquaria/Makefile
+++ b/games/aquaria/Makefile
@@ -11,11 +11,11 @@ COMMENT= Underwater 2D fantasy action-adventure (game engine)
LICENSE= GPLv2+
-BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
-LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
- libftgl.so:${PORTSDIR}/graphics/ftgl \
- libpng.so:${PORTSDIR}/graphics/png \
- libtinyxml2.so:${PORTSDIR}/textproc/tinyxml2
+BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:math/glm
+LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
+ libftgl.so:graphics/ftgl \
+ libpng.so:graphics/png \
+ libtinyxml2.so:textproc/tinyxml2
USE_GITHUB= yes
GH_ACCOUNT= AquariaOSE
diff --git a/games/katawa-shoujo/Makefile b/games/katawa-shoujo/Makefile
index 265b9cbb28fc..7f0d24664bda 100644
--- a/games/katawa-shoujo/Makefile
+++ b/games/katawa-shoujo/Makefile
@@ -22,7 +22,7 @@ LICENSE_NAME= Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported
LICENSE_TEXT= See https://creativecommons.org/licenses/by-nc-nd/3.0/
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-RUN_DEPENDS= renpy:${PORTSDIR}/devel/renpy
+RUN_DEPENDS= renpy:devel/renpy
USES= tar:bz2
NO_ARCH= yes
diff --git a/games/narcissu2/Makefile b/games/narcissu2/Makefile
index e79e96a21f90..8e018ebf2d0a 100644
--- a/games/narcissu2/Makefile
+++ b/games/narcissu2/Makefile
@@ -22,7 +22,7 @@ LICENSE_TEXT= Permission has been granted to anyone to redistribute \
game data are not modified.
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-RUN_DEPENDS= ponscr:${PORTSDIR}/devel/ponscripter-sekai
+RUN_DEPENDS= ponscr:devel/ponscripter-sekai
NO_ARCH= yes
NO_BUILD= yes
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 39eb29300b23..ad25f2e31226 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -11,8 +11,8 @@ COMMENT= Moddable fighting game engine (aka Beats of Rage)
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
- libvpx.so:${PORTSDIR}/multimedia/libvpx
+LIB_DEPENDS= libpng.so:graphics/png \
+ libvpx.so:multimedia/libvpx
USES= dos2unix gmake pkgconfig tar:xz
USE_SDL= gfx2
@@ -39,12 +39,12 @@ OPTIONS_DEFAULT= ${MACHINE_CPU:tu:MSOFTFP:S/SOFTFP/TREMOR/}
OPTIONS_DEFINE_i386= MMX
OPTIONS_DEFAULT_i386= MMX # runtime detection
-MMX_BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
+MMX_BUILD_DEPENDS= yasm:devel/yasm
MMX_MAKE_ARGS= BUILD_MMX=1
-TREMOR_LIB_DEPENDS= libvorbisidec.so:${PORTSDIR}/audio/libtremor
+TREMOR_LIB_DEPENDS= libvorbisidec.so:audio/libtremor
TREMOR_MAKE_ARGS= BUILD_TREMOR=1 BUILD_VORBIS=""
-TREMOR_LIB_DEPENDS_OFF= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
+TREMOR_LIB_DEPENDS_OFF= libvorbisfile.so:audio/libvorbis
#
# To update snapshot: make makesum BOOTSTRAP=
@@ -62,7 +62,7 @@ SVN_REV?= ${PORTVERSION:E:S/r//}
.endif
.if defined(BOOTSTRAP) || defined(SVN_FETCH)
-FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+FETCH_DEPENDS+= svn:devel/subversion
do-fetch:
${MKDIR} ${WRKDIR}
diff --git a/games/openra/Makefile b/games/openra/Makefile
index c75d63d75048..8f1755fbedbe 100644
--- a/games/openra/Makefile
+++ b/games/openra/Makefile
@@ -44,8 +44,8 @@ COMMENT= Multiplayer re-envisioning of early RTS games by Westwood Studios
LICENSE= GPLv3
-LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libgdiplus.so:${PORTSDIR}/x11-toolkits/libgdiplus
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libgdiplus.so:x11-toolkits/libgdiplus
USE_GITHUB= yes
GH_PROJECT= OpenRA
@@ -66,14 +66,14 @@ PORTDOCS= *.html
OPTIONS_DEFINE= DOCS TEST ZENITY
OPTIONS_DEFAULT=ZENITY
-DOCS_BUILD_DEPENDS=markdown:${PORTSDIR}/textproc/markdown
+DOCS_BUILD_DEPENDS=markdown:textproc/markdown
DOCS_ALL_TARGET=docs
TEST_MAKE_ENV= HOME="${WRKDIR}"
TEST_ALL_TARGET=test
-ZENITY_RUN_DEPENDS=xdg-open:${PORTSDIR}/devel/xdg-utils \
- zenity:${PORTSDIR}/x11/zenity
+ZENITY_RUN_DEPENDS=xdg-open:devel/xdg-utils \
+ zenity:x11/zenity
ZENITY_DESC= Use native crash dialog
post-extract:
diff --git a/graphics/waifu2x-converter-cpp/Makefile b/graphics/waifu2x-converter-cpp/Makefile
index 1be543429647..450d44fe21f9 100644
--- a/graphics/waifu2x-converter-cpp/Makefile
+++ b/graphics/waifu2x-converter-cpp/Makefile
@@ -16,9 +16,9 @@ LICENSE_COMB= multi
LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/LICENSE
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${LOCALBASE}/include/CL/opencl.h:${PORTSDIR}/devel/opencl
-LIB_DEPENDS= libopencv_highgui.so:${PORTSDIR}/graphics/opencv \
- libopencv_imgproc.so:${PORTSDIR}/graphics/opencv-core
+BUILD_DEPENDS= ${LOCALBASE}/include/CL/opencl.h:devel/opencl
+LIB_DEPENDS= libopencv_highgui.so:graphics/opencv \
+ libopencv_imgproc.so:graphics/opencv-core
USE_GITHUB= yes
GH_ACCOUNT= tanakamura
diff --git a/mail/mpop/Makefile b/mail/mpop/Makefile
index e3e55244418c..7f190eb95022 100644
--- a/mail/mpop/Makefile
+++ b/mail/mpop/Makefile
@@ -24,15 +24,15 @@ OPTIONS_RADIO_TLS= GNUTLS OPENSSL
OPTIONS_DEFAULT= IDN OPENSSL
OPTIONS_SUB= yes
-GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_CONFIGURE_ON= --with-tls=gnutls
GSASL_DESC= ${SASL_DESC} via GNU SASL
-GSASL_LIB_DEPENDS= libgsasl.so:${PORTSDIR}/security/gsasl
+GSASL_LIB_DEPENDS= libgsasl.so:security/gsasl
GSASL_CONFIGURE_WITH= libgsasl
-IDN_LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
+IDN_LIB_DEPENDS= libidn.so:dns/libidn
IDN_CONFIGURE_WITH= libidn
LIBSECRET_DESC= GNOME password management
-LIBSECRET_LIB_DEPENDS= libsecret-1.so:${PORTSDIR}/security/libsecret
+LIBSECRET_LIB_DEPENDS= libsecret-1.so:security/libsecret
LIBSECRET_CONFIGURE_WITH= libsecret
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
diff --git a/multimedia/baka-mplayer/Makefile b/multimedia/baka-mplayer/Makefile
index fd0dfcc820b6..725f97f4e351 100644
--- a/multimedia/baka-mplayer/Makefile
+++ b/multimedia/baka-mplayer/Makefile
@@ -10,7 +10,7 @@ COMMENT= Qt 5 multimedia player based on libmpv
LICENSE= GPLv2
-LIB_DEPENDS= libmpv.so:${PORTSDIR}/multimedia/mpv
+LIB_DEPENDS= libmpv.so:multimedia/mpv
USE_GITHUB= yes
GH_ACCOUNT= u8sand
@@ -27,7 +27,7 @@ OPTIONS_SUB= yes
NLS_USE= QT5=linguisttools_build
NLS_QMAKE_ON= CONFIG+="install_translations"
NOTO_DESC= Original look with Noto Sans font
-NOTO_RUN_DEPENDS= noto>0:${PORTSDIR}/x11-fonts/noto
+NOTO_RUN_DEPENDS= noto>0:x11-fonts/noto
post-patch:
${REINPLACE_CMD} '/^Comment/s,=.*,=${COMMENT},' \
diff --git a/multimedia/libmtp/Makefile b/multimedia/libmtp/Makefile
index 1af1815a783b..a274c107cd27 100644
--- a/multimedia/libmtp/Makefile
+++ b/multimedia/libmtp/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ENV+= LIBUSB_CFLAGS=" " LIBUSB_LIBS="-lusb"
.endif
MTPZ_CONFIGURE_ENABLE= mtpz
-MTPZ_LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
+MTPZ_LIB_DEPENDS= libgcrypt.so:security/libgcrypt
post-patch:
.if !exists(/usr/libdata/pkgconfig/libusb-1.0.pc)
diff --git a/sysutils/fusefs-simple-mtpfs/Makefile b/sysutils/fusefs-simple-mtpfs/Makefile
index e70a72fd39b9..d8f9dc926d6b 100644
--- a/sysutils/fusefs-simple-mtpfs/Makefile
+++ b/sysutils/fusefs-simple-mtpfs/Makefile
@@ -11,7 +11,7 @@ COMMENT= Simple MTP fuse filesystem driver
LICENSE= GPLv2+
-LIB_DEPENDS= libmtp.so:${PORTSDIR}/multimedia/libmtp
+LIB_DEPENDS= libmtp.so:multimedia/libmtp
USE_GITHUB= yes
GH_ACCOUNT= phatina
diff --git a/sysutils/rinse/Makefile b/sysutils/rinse/Makefile
index fce681f48b1a..75002601c05e 100644
--- a/sysutils/rinse/Makefile
+++ b/sysutils/rinse/Makefile
@@ -11,8 +11,8 @@ COMMENT= Install RPM-based system into a directory
LICENSE= ART10
-RUN_DEPENDS= p5-Term-Size>0:${PORTSDIR}/devel/p5-Term-Size \
- p5-libwww>0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-Term-Size>0:devel/p5-Term-Size \
+ p5-libwww>0:www/p5-libwww
NO_ARCH= yes
NO_BUILD= yes
diff --git a/sysutils/uhidd/Makefile b/sysutils/uhidd/Makefile
index 73ed18e07d8b..c4f18d830d73 100644
--- a/sysutils/uhidd/Makefile
+++ b/sysutils/uhidd/Makefile
@@ -31,8 +31,8 @@ OPTIONS_EXCLUDE+= CUSE
.endif
CUSE_DESC= Use cuse(3) over multimedia/cuse4bsd-kmod
-CUSE_BUILD_DEPENDS_OFF= cuse4bsd-kmod>=0.1.24:${PORTSDIR}/multimedia/cuse4bsd-kmod
-CUSE_LIB_DEPENDS_OFF= libcuse4bsd.so:${PORTSDIR}/multimedia/cuse4bsd-kmod
+CUSE_BUILD_DEPENDS_OFF= cuse4bsd-kmod>=0.1.24:multimedia/cuse4bsd-kmod
+CUSE_LIB_DEPENDS_OFF= libcuse4bsd.so:multimedia/cuse4bsd-kmod
CUSE_SUB_LIST_OFF= LIBCUSE="${LOCALBASE}/lib/libcuse4bsd.so"
CUSE_SUB_LIST= LIBCUSE=""
diff --git a/x11-drivers/xf86-input-wacom/Makefile b/x11-drivers/xf86-input-wacom/Makefile
index e9aad7859ed3..10666fff2370 100644
--- a/x11-drivers/xf86-input-wacom/Makefile
+++ b/x11-drivers/xf86-input-wacom/Makefile
@@ -11,8 +11,8 @@ COMMENT= X.Org Wacom tablet driver
LICENSE= GPLv2+
-BUILD_DEPENDS= v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat
-RUN_DEPENDS= webcamd>=3.1.0.1:${PORTSDIR}/multimedia/webcamd
+BUILD_DEPENDS= v4l_compat>=1.0.20110603:multimedia/v4l_compat
+RUN_DEPENDS= webcamd>=3.1.0.1:multimedia/webcamd
USES= tar:bzip2 pathfix pkgconfig libtool
USE_XORG= xrandr xinerama