aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-27 03:14:31 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-27 03:14:31 +0000
commit4969f420de804e85de23c0508026fab6eb9e79e7 (patch)
tree7f3cafc389cd2af1e565fa802a97dc61d881fef3
parent7d9bbb3bfbf384cb3da98614b20646d22ab2b9e0 (diff)
downloadports-4969f420de804e85de23c0508026fab6eb9e79e7.tar.gz
ports-4969f420de804e85de23c0508026fab6eb9e79e7.zip
Update to version 21.1.8.
PR: 14591 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=23434
-rw-r--r--editors/xemacs21-mule-common/Makefile101
-rw-r--r--editors/xemacs21-mule-common/files/DESCR.tmpl (renamed from editors/xemacs21-mule-common/pkg-descr)8
-rw-r--r--editors/xemacs21-mule-common/files/INSTALL.tmpl7
-rw-r--r--editors/xemacs21-mule-common/pkg-plist51
-rw-r--r--editors/xemacs21-mule/Makefile89
-rw-r--r--editors/xemacs21-mule/pkg-comment2
-rw-r--r--editors/xemacs21-mule/pkg-descr17
-rw-r--r--editors/xemacs21-mule/pkg-plist19
-rw-r--r--japanese/xemacs21-canna+freewnn/Makefile7
-rw-r--r--japanese/xemacs21-canna+wnn6/Makefile7
-rw-r--r--japanese/xemacs21-canna/Makefile71
-rw-r--r--japanese/xemacs21-canna/files/DESCR.tmpl31
-rw-r--r--japanese/xemacs21-canna/pkg-comment1
-rw-r--r--japanese/xemacs21-canna/pkg-descr23
-rw-r--r--japanese/xemacs21-freewnn/Makefile7
-rw-r--r--japanese/xemacs21-wnn6/Makefile7
16 files changed, 242 insertions, 206 deletions
diff --git a/editors/xemacs21-mule-common/Makefile b/editors/xemacs21-mule-common/Makefile
index f5219e2a62fc..b87a2dc9ad01 100644
--- a/editors/xemacs21-mule-common/Makefile
+++ b/editors/xemacs21-mule-common/Makefile
@@ -1,107 +1,96 @@
# New ports collection makefile for: files except executables for xemacs with mule
-# Version required: 21.1.6
+# Version required: 21.1.8
# Date created: 5 Dec 1997
# Whom: Kazuyuki IENAGA <ienaga@jsys.co.jp>
#
# $FreeBSD$
#
-DISTNAME= xemacs-${VERSION}
-PKGNAME= xemacs-mule-common-${VERSION}
-CATEGORIES= editors japanese
-MASTER_SITES= ftp://ftp.lab.kdd.co.jp/xemacs/${FTP_DIR}/ \
- ftp://ftp.xemacs.org/pub/xemacs/${FTP_DIR}/ \
- ftp://ftp.mpi-sb.mpg.de/pub/gnu/mirror/ftp.xemacs.org/xemacs/${FTP_DIR}/ \
- ftp://ftp.th-darmstadt.de/pub/editors/xemacs/${FTP_DIR}/ \
- ftp://ftp.jpl.org/pub/elisp/
-DISTFILES= xemacs-${VERSION}.tar.gz xemacs-${VERSION}-elc.tar.gz \
- xemacs-${VERSION}-info.tar.gz \
- ps-print-jp.el.gz
-DIST_SUBDIR= xemacs
-
-MAINTAINER= kiri@kiri.toba-cmt.ac.jp
-
-# from xemacs-mule
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.3:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- compface.1:${PORTSDIR}/mail/faces
-USE_AUTOCONF= yes
-
-EXTRACT_ONLY= xemacs-${VERSION}.tar.gz xemacs-${VERSION}-elc.tar.gz \
- xemacs-${VERSION}-info.tar.gz
+# This is the COMMON port of XEmacs Mule slave ports(editors/xemacs-mule,
+# japanese/xemacs-*) and provides `Architecture Independent' parts of xemacs binary.
+#
+# Caracteristic variables of XEmacs Mule ports family:
+# MULE_COMMON : COMMON port if defined
+# PKGLDIR : Local PKGDIR of MASTER port(editors/xemacs-mule/pkg)
+# SITE_INCLUDES : site include path(configure arguments)
+# SITE_LIBRARIES : site libraries path(configure arguments)
+# WITH_INPUT_METHOD : input methods(configure arguments)
+# LIB_INPUT_METHOD : LIB_DEPENDS list of Input Methods
+# BUILD_INPUT_METHOD: BUILD_DEPENDS list of Input Methods
.include <bsd.port.pre.mk>
.for dir in \
editors/xemacs-mule \
- japanese/xemacs \
japanese/xemacs-canna \
japanese/xemacs-canna+wnn4 \
japanese/xemacs-canna+wnn6 \
japanese/xemacs-wnn4 \
japanese/xemacs-wnn6
.if exists(${WRKDIRPREFIX}${.CURDIR}/../../${dir}/work/.install_done)
-WRKDIR= ${WRKDIRPREFIX}${.CURDIR}/../../${dir}/work
+WRKDIR= ${WRKDIRPREFIX}${.CURDIR}/../../${dir}/work
.elif exists(${WRKDIRPREFIX}${.CURDIR}/../../${dir}/work/.build_done)
-WRKDIR?= ${WRKDIRPREFIX}${.CURDIR}/../../${dir}/work
+WRKDIR= ${WRKDIRPREFIX}${.CURDIR}/../../${dir}/work
.endif
.endfor
-WRKSRC= ${WRKDIR}/xemacs-${VERSION}
-
.if !defined(WRKDIR)
.if defined(PACKAGE_BUILDING)
-# XXX
pre-build:
- @cd ${.CURDIR}/../xemacs-mule; make
+ @cd ${.CURDIR}/../xemacs-mule; ${MAKE}
.else
BROKEN= You should build install one of the other xemacs ports first
.endif
.endif
-INSTALL_COOKIE= ${WRKDIR}/.install_done-${PKGNAME}
-PACKAGE_COOKIE= ${WRKDIR}/.package_done-${PKGNAME}
-TMPPLIST= ${WRKDIR}/.PLIST.mktmp-${PKGNAME}
-
-USE_XLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= i386-unknown-freebsd \
- --with-x11 \
+CONFIGURE_ARGS= --with-x11 \
--with-mule \
--x-includes=${X11BASE}/include \
--x-libraries=${X11BASE}/lib
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
gnuserv.1 xemacs.1
-
-STRIP=
INSTALL_TARGET= install-arch-indep
+PKGINSTALL= ${WRKDIR}/INSTALL.${PKGNAME}
+PLIST= ${PKGDIR}/PLIST
+DESCR= ${WRKDIR}/DESCR.${PKGNAME}
PLIST_SUB= XEMACS_DIR=${XEMACS_DIR}
+PKGINSTALL= ${WRKDIR}/INSTALL
+TMPPLIST= ${WRKDIR}/.PLIST.mktmp-${PKGNAME}
-MAJOR_VERSION= 21.1
-VERSION= 21.1.6
-XEMACS_DIR= xemacs-${VERSION}
-FTP_DIR= xemacs-${MAJOR_VERSION}
+MULE_COMMON= yes
+PKGNAMEEXT= -mule-common
+DESCR_TMPL= ${.CURDIR}/../xemacs-mule-common/files/DESCR.tmpl
+INSTALL_TMPL= ${.CURDIR}/../xemacs-mule-common/files/INSTALL.tmpl
pre-build:
- ${RM} -f ${WRKSRC}/lib-src/DOC* ${WRKSRC}/src/xemacs
+ @${RM} -f ${WRKSRC}/lib-src/DOC* ${WRKSRC}/src/xemacs
pre-install:
- @${MKDIR} ${PREFIX}/lib/xemacs
+.for dirp in site mule xemacs
+.for dir in etc info man pkginfo
+ @${MKDIR} ${PREFIX}/lib/xemacs/${dirp}-packages/${dir}
+.endfor
+.endfor
@(cd ${PREFIX}/lib/xemacs; ${MKDIR} info etc site-lisp)
@if [ ! -f ${PREFIX}/lib/xemacs/info/dir ]; then \
${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/lib/xemacs/info/dir; \
fi
+ @${SED} -e "s/%%XEMACS_VER%%/${XEMACS_VER}/g" \
+ ${DESCR_TMPL} > ${DESCR}
+ @${SED} -e "s/%%XEMACS_VER%%/${XEMACS_VER}/g" \
+ ${INSTALL_TMPL} > ${PKGINSTALL}
-post-install:
+post-install::
# install xemacs-mule.sh into ${PREFIX}/etc/rc.d
- @${MKDIR} /var/run/emacs/lock
- ${CHMOD} 1777 /var/run/emacs/lock
+ @if [ ! -d /var/run/emacs/lock ]; then \
+ ${MKDIR} /var/run/emacs/lock; \
+ ${CHMOD} 1777 /var/run/emacs/lock; \
+ fi
@${MKDIR} ${PREFIX}/etc/rc.d
@${INSTALL_SCRIPT} ${FILESDIR}/xemacs-mule.sh ${PREFIX}/etc/rc.d
+ @if [ -f ${PKGDIR}/INSTALL ]; then \
+ ${SETENV} PKG_PREFIX=${PREFIX} \
+ ${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL; \
+ fi
@${TOUCH} ${TOUCH_FLAGS} ${INSTALL_COOKIE}
-post-package:
- @${TOUCH} ${TOUCH_FLAGS} ${PACKAGE_COOKIE}
-
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../xemacs-mule/Makefile"
diff --git a/editors/xemacs21-mule-common/pkg-descr b/editors/xemacs21-mule-common/files/DESCR.tmpl
index 58aa2e6d5bae..10f90be633ce 100644
--- a/editors/xemacs21-mule-common/pkg-descr
+++ b/editors/xemacs21-mule-common/files/DESCR.tmpl
@@ -1,9 +1,9 @@
This is XEmacs lisp files, info pages, and so on (except executables)
-for XEmacs 21.1.6, the next generation of Emacs.
+for XEmacs with Mule(version %%XEMACS_VER%%), the next generation of Emacs.
-You must install one of packages, xemacs, jp-xemacs-*-21.1.6 (
-jp-xemacs-canna-21.1.6, jp-xemacs-canna+sj3-21.1.6, etc.), each of which
-contains only the executables for xemacs-21.1.6.
+You must install one of packages, xemacs-mule-%%XEMACS_VER%%,
+ja-xemacs-*-%%XEMACS_VER%% (ja-xemacs-canna-%%XEMACS_VER%%, ja-xemacs-canna+wnn4-%%XEMACS_VER%%, etc.),
+each of which contains only the executables for XEmacs with Mule(vresion %%XEMACS_VER%%).
This package and the above package of the executables *will* clobber any
existing XEmacs installation. In particular, the executables and man
diff --git a/editors/xemacs21-mule-common/files/INSTALL.tmpl b/editors/xemacs21-mule-common/files/INSTALL.tmpl
new file mode 100644
index 000000000000..dfc729fef788
--- /dev/null
+++ b/editors/xemacs21-mule-common/files/INSTALL.tmpl
@@ -0,0 +1,7 @@
+#!/bin/sh
+if [ "$2" != "POST-INSTALL" ]; then exit 0; fi
+echo "################################################################"
+echo "You must install one of packages, xemacs-mule and "
+echo " ja-xemacs-*-%%XEMACS_VER%% (ja-xemacs-%%XEMACS_VER%%, ja-xemacs-canna-%%XEMACS_VER%%, etc.)"
+echo ", each of which contains only the executables for xemacs-%%XEMACS_VER%%"
+echo "################################################################"
diff --git a/editors/xemacs21-mule-common/pkg-plist b/editors/xemacs21-mule-common/pkg-plist
index 976eb2f459a8..5ba34b159a5b 100644
--- a/editors/xemacs21-mule-common/pkg-plist
+++ b/editors/xemacs21-mule-common/pkg-plist
@@ -1,14 +1,20 @@
+@exec mkdir -p %D/lib/xemacs/site-packages/etc
@exec mkdir -p %D/lib/xemacs/site-packages/info
+@exec mkdir -p %D/lib/xemacs/site-packages/lisp
+@exec mkdir -p %D/lib/xemacs/site-packages/man
+@exec mkdir -p %D/lib/xemacs/site-packages/pkginfo
+@exec mkdir -p %D/lib/xemacs/mule-packages/etc
@exec mkdir -p %D/lib/xemacs/mule-packages/info
+@exec mkdir -p %D/lib/xemacs/mule-packages/lisp
+@exec mkdir -p %D/lib/xemacs/mule-packages/man
+@exec mkdir -p %D/lib/xemacs/mule-packages/pkginfo
+@exec mkdir -p %D/lib/xemacs/xemacs-packages/etc
@exec mkdir -p %D/lib/xemacs/xemacs-packages/info
-@exec [ -f %D/lib/xemacs/site-packages/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir-tmpl > %D/lib/xemacs/site-packages/info/dir
-@exec [ -f %D/lib/xemacs/mule-packages/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir-tmpl > %D/lib/xemacs/mule-packages/info/dir
-@exec [ -f %D/lib/xemacs/xemacs-packages/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir-tmpl > %D/lib/xemacs/xemacs-packages/info/dir
+@exec mkdir -p %D/lib/xemacs/xemacs-packages/lisp
+@exec mkdir -p %D/lib/xemacs/xemacs-packages/man
+@exec mkdir -p %D/lib/xemacs/xemacs-packages/pkginfo
@exec mkdir -p %D/lib/xemacs/site-lisp
@exec mkdir -p /var/run/emacs/lock ; chmod 1777 /var/run/emacs/lock
-@comment
-@comment XEmacs etc
-@comment
etc/rc.d/xemacs-mule.sh
lib/%%XEMACS_DIR%%/etc/BETA
lib/%%XEMACS_DIR%%/etc/CHARSETS
@@ -370,9 +376,6 @@ lib/%%XEMACS_DIR%%/etc/xemacs-ja.1
lib/%%XEMACS_DIR%%/etc/xemacs.1
lib/%%XEMACS_DIR%%/etc/xemacs.xbm
lib/%%XEMACS_DIR%%/etc/xemacs.xpm
-@comment
-@comment XEmacs infos
-@comment
lib/%%XEMACS_DIR%%/info/cl.info
lib/%%XEMACS_DIR%%/info/cl.info-1
lib/%%XEMACS_DIR%%/info/cl.info-2
@@ -392,6 +395,7 @@ lib/%%XEMACS_DIR%%/info/internals.info-4
lib/%%XEMACS_DIR%%/info/internals.info-5
lib/%%XEMACS_DIR%%/info/internals.info-6
lib/%%XEMACS_DIR%%/info/internals.info-7
+lib/%%XEMACS_DIR%%/info/internals.info-8
lib/%%XEMACS_DIR%%/info/lispref.info
lib/%%XEMACS_DIR%%/info/lispref.info-1
lib/%%XEMACS_DIR%%/info/lispref.info-10
@@ -492,9 +496,6 @@ lib/%%XEMACS_DIR%%/info/xemacs.info-6
lib/%%XEMACS_DIR%%/info/xemacs.info-7
lib/%%XEMACS_DIR%%/info/xemacs.info-8
lib/%%XEMACS_DIR%%/info/xemacs.info-9
-@comment
-@comment XEmacs lisp
-@comment
lib/%%XEMACS_DIR%%/lisp/.cvsignore
lib/%%XEMACS_DIR%%/lisp/ChangeLog
lib/%%XEMACS_DIR%%/lisp/ChangeLog.1
@@ -923,20 +924,18 @@ lib/%%XEMACS_DIR%%/lisp/x-win-sun.el
lib/%%XEMACS_DIR%%/lisp/x-win-sun.elc
lib/%%XEMACS_DIR%%/lisp/x-win-xfree86.el
lib/%%XEMACS_DIR%%/lisp/x-win-xfree86.elc
-@comment
-@comment dirrm
-@comment
-@dirrm lib/%%XEMACS_DIR%%/etc/custom
-@dirrm lib/%%XEMACS_DIR%%/etc/eos
-@dirrm lib/%%XEMACS_DIR%%/etc/idd
-@dirrm lib/%%XEMACS_DIR%%/etc/photos
-@dirrm lib/%%XEMACS_DIR%%/etc/sparcworks
+lib/%%XEMACS_DIR%%/lisp/xpm-button.el
+lib/%%XEMACS_DIR%%/lisp/xpm-button.elc
+@dirrm lib/%%XEMACS_DIR%%/lisp/term
+@dirrm lib/%%XEMACS_DIR%%/lisp/mule
+@dirrm lib/%%XEMACS_DIR%%/lisp
+@dirrm lib/%%XEMACS_DIR%%/info
+@dirrm lib/%%XEMACS_DIR%%/etc/toolbar
@dirrm lib/%%XEMACS_DIR%%/etc/tests/external-widget
@dirrm lib/%%XEMACS_DIR%%/etc/tests
-@dirrm lib/%%XEMACS_DIR%%/etc/toolbar
+@dirrm lib/%%XEMACS_DIR%%/etc/sparcworks
+@dirrm lib/%%XEMACS_DIR%%/etc/photos
+@dirrm lib/%%XEMACS_DIR%%/etc/idd
+@dirrm lib/%%XEMACS_DIR%%/etc/eos
+@dirrm lib/%%XEMACS_DIR%%/etc/custom
@dirrm lib/%%XEMACS_DIR%%/etc
-@dirrm lib/%%XEMACS_DIR%%/info
-@dirrm lib/%%XEMACS_DIR%%/lisp/mule
-@dirrm lib/%%XEMACS_DIR%%/lisp/term
-@dirrm lib/%%XEMACS_DIR%%/lisp
-@dirrm lib/%%XEMACS_DIR%%
diff --git a/editors/xemacs21-mule/Makefile b/editors/xemacs21-mule/Makefile
index 7d7c028fdd88..b226981feebd 100644
--- a/editors/xemacs21-mule/Makefile
+++ b/editors/xemacs21-mule/Makefile
@@ -1,47 +1,57 @@
# New ports collection makefile for: XEmacs
-# Version required: 21.1.6
+# Version required: 21.1.8
# Date created: 5 Dec 1997
# Whom: Kazuyuki IENAGA <ienaga@jsys.co.jp>
#
# $FreeBSD$
#
-DISTNAME= xemacs-${VERSION}
-PKGNAME= ${LANGPREFIX}xemacs${PKGNAMEEXT}-${VERSION}
+# This is the MASTER port of XEmacs Mule slave ports(japanese/xemacs-*)
+# and provides `Architecture Dependent' parts of xemacs binary.
+#
+# Caracteristic variables of XEmacs Mule ports family:
+# MULE_COMMON : COMMON port if defined
+# PKGLDIR : Local PKGDIR of MASTER port(editors/xemacs-mule/pkg)
+# SITE_INCLUDES : site include path(configure arguments)
+# SITE_LIBRARIES : site libraries path(configure arguments)
+# WITH_INPUT_METHOD : input methods(configure arguments)
+# LIB_INPUT_METHOD : LIB_DEPENDS list of Input Methods
+# BUILD_INPUT_METHOD: BUILD_DEPENDS list of Input Methods
+
+DISTNAME= xemacs-${XEMACS_VER}
+PKGNAME= ${LANGPREFIX}xemacs${PKGNAMEEXT}-${XEMACS_VER}
CATEGORIES?= editors
MASTER_SITES= ftp://ftp.lab.kdd.co.jp/xemacs/${FTP_DIR}/ \
ftp://ftp.xemacs.org/pub/xemacs/${FTP_DIR}/ \
ftp://ftp.mpi-sb.mpg.de/pub/gnu/mirror/ftp.xemacs.org/xemacs/${FTP_DIR}/ \
- ftp://ftp.th-darmstadt.de/pub/editors/xemacs/${FTP_DIR}/ \
- ftp://ftp.jpl.org/pub/elisp/
-DISTFILES= xemacs-${VERSION}.tar.gz xemacs-${VERSION}-elc.tar.gz \
- xemacs-${VERSION}-info.tar.gz \
- ps-print-jp.el.gz
+ ftp://ftp.th-darmstadt.de/pub/editors/xemacs/${FTP_DIR}/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-elc${EXTRACT_SUFX} \
+ ${DISTNAME}-info${EXTRACT_SUFX}
DIST_SUBDIR= xemacs
-MAINTAINER?= kiri@kiri.toba-cmt.ac.jp
+MAINTAINER= kiri@kiri.toba-cmt.ac.jp
-BUILD_DEPENDS= ${BUILD_DEP_LIST}
+.if !defined(MULE_COMMON)
+BUILD_DEPENDS= ${PREFIX}/lib/xemacs/xemacs-packages/pkginfo/MANIFEST.xemacs-devel:${PORTSDIR}/editors/xemacs-packages \
+ ${PREFIX}/lib/xemacs/mule-packages/pkginfo/MANIFEST.skk:${PORTSDIR}/editors/xemacs-mule-packages \
+ ${BUILD_INPUT_METHOD}
+RUN_DEPENDS= ${PREFIX}/lib/${XEMACS_DIR}/lisp/x-win-xfree86.elc:${PORTSDIR}/editors/xemacs-mule-common \
+ ${PREFIX}/lib/xemacs/xemacs-packages/pkginfo/MANIFEST.xemacs-devel:${PORTSDIR}/editors/xemacs-packages \
+ ${PREFIX}/lib/xemacs/mule-packages/pkginfo/MANIFEST.skk:${PORTSDIR}/editors/xemacs-mule-packages
+.endif
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.3:${PORTSDIR}/graphics/png \
compface.1:${PORTSDIR}/mail/faces \
tiff.4:${PORTSDIR}/graphics/tiff \
${LIB_INPUT_METHOD}
-RUN_DEPENDS= ${RUN_DEP_LIST}
-EXTRACT_ONLY= xemacs-${VERSION}.tar.gz xemacs-${VERSION}-elc.tar.gz \
- xemacs-${VERSION}-info.tar.gz
-WRKSRC= ${WRKDIR}/xemacs-${VERSION}
-PATCHDIR= ${.CURDIR}/../../editors/xemacs-mule-common/patches
-FILESDIR= ${.CURDIR}/../../editors/xemacs-mule-common/files
-SCRIPTDIR= ${.CURDIR}/../../editors/xemacs-mule-common/scripts
-INSTALL_COOKIE= ${WRKDIR}/.install_done-${PKGNAME}
-PACKAGE_COOKIE= ${WRKDIR}/.package_done-${PKGNAME}
-GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/xemacs-${XEMACS_VER}
USE_AUTOCONF= yes
+USE_XLIB= yes
+GNU_CONFIGURE= yes
CONFIGURE_TARGET=${MACHINE_ARCH}--freebsd
-CONFIGURE_ARGS= --with-x11 \
+CONFIGURE_ARGS?=--with-x11 \
--with-xim=no \
--with-mule \
--x-includes=${X11BASE}/include \
@@ -64,23 +74,37 @@ CONFIGURE_ARGS= --with-x11 \
--with-clash-detection \
--lockdir=/var/run/emacs/lock \
${WITH_INPUT_METHOD}
+MAKE_ENV= LANG=C
+MAKE_ARGS= prefix=${PREFIX}
+PATCHDIR= ${.CURDIR}/../../editors/xemacs-mule/patches
+FILESDIR= ${.CURDIR}/../../editors/xemacs-mule/files
+INSTALL_COOKIE= ${WRKDIR}/.install_done-${PKGNAME}
+PACKAGE_COOKIE= ${WRKDIR}/.package_done-${PKGNAME}
STRIP=
-INSTALL_TARGET= install-arch-dep
+INSTALL_TARGET?=install-arch-dep
+DESCR?= ${WRKDIR}/DESCR
PLIST?= ${PKGLDIR}/PLIST
-PLIST_SUB= XEMACS_DIR=${XEMACS_DIR} ARCH_SUBDIR=${ARCH_SUBDIR}
+PLIST_SUB?= XEMACS_DIR=${XEMACS_DIR} ARCH_SUBDIR=${ARCH_SUBDIR} EMACS_CMD=${EMACS_CMD}
-MAJOR_VERSION= 21.1
-VERSION= 21.1.6
-EMACS_CMD= xemacs-${VERSION}
-XEMACS_DIR= xemacs-${VERSION}
-FTP_DIR= xemacs-${MAJOR_VERSION}
+XEMACS_MAJVER= 21.1
+XEMACS_VER= 21.1.8
+EMACS_CMD= xemacs-${XEMACS_VER}
+XEMACS_DIR= xemacs-${XEMACS_VER}
+FTP_DIR= xemacs-${XEMACS_MAJVER}
ARCH_SUBDIR= ${MACHINE_ARCH}--freebsd
PKGNAMEEXT?= -mule
+DESCR_TMPL?= ${.CURDIR}/../xemacs-mule/files/DESCR.tmpl
+.if !defined(MULE_COMMON)
PKGLDIR= ${.CURDIR}/../../editors/xemacs-mule/pkg
SITE_INCLUDES+= ${PREFIX}/include
SITE_LIBRARIES+= ${PREFIX}/lib
WITH_INPUT_METHOD?= --with-canna=no --with-wnn=no --with-wnn6=no
-RUN_DEP_LIST+= ${PREFIX}/lib/${XEMACS_DIR}/lisp/x-win-xfree86.elc:${PORTSDIR}/editors/xemacs-mule-common
+.endif
+
+.if !defined(MULE_COMMON)
+post-configure::
+ @${SED} -e "s/%%XEMACS_VER%%/${XEMACS_VER}/g" \
+ ${DESCR_TMPL} > ${DESCR}
pre-build:
@find ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
@@ -93,14 +117,11 @@ post-build:
.endif
post-install::
-.for file in b2m ctags etags gnuclient xemacs-${VERSION}
+.for file in b2m ctags etags gnuclient xemacs-${XEMACS_VER}
@strip ${PREFIX}/bin/${file}
.endfor
- @if [ -f ${PKGDIR}/INSTALL ]; then \
- ${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL; \
- fi
@${TOUCH} ${TOUCH_FLAGS} ${INSTALL_COOKIE}
+.endif
post-package:
@${TOUCH} ${TOUCH_FLAGS} ${PACKAGE_COOKIE}
diff --git a/editors/xemacs21-mule/pkg-comment b/editors/xemacs21-mule/pkg-comment
index 59b1a3dc5c60..2fb19845b5fc 100644
--- a/editors/xemacs21-mule/pkg-comment
+++ b/editors/xemacs21-mule/pkg-comment
@@ -1 +1 @@
-XEmacs text editor (Only the executables)
+XEmacs text editor with mule(Only the executables)
diff --git a/editors/xemacs21-mule/pkg-descr b/editors/xemacs21-mule/pkg-descr
deleted file mode 100644
index 8bccd2d70870..000000000000
--- a/editors/xemacs21-mule/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-This is a package containing only the executables for xemacs-21.1.6, the
-next generation of Emacs.
-
-You need to install a package, xemacs-common-21.1.6, containing emacs
-lisp files, info pages, and so on (except executables) for
-xemacs-21.1.6.
-
-This package is not built with any particular language support. If
-you want a built-in input method, look into the xemacs ports in
-language- specific directories. Currently only Japanese (SKK,Canna, SJ3,
-Wnn4 and Wnn6) is available.
-
-This package and the package, xemacs-common-21.1.6 are designed *not* to
-clobber any existing emacs installation. In particular, the
-executables and man pages of etags/ctags are not installed, and the
-info pages that come with the original emacs don't get installed too.
-The Japanese version is build to install everything, by the way.
diff --git a/editors/xemacs21-mule/pkg-plist b/editors/xemacs21-mule/pkg-plist
index 0ffe73da20b3..5ef8365ac8d2 100644
--- a/editors/xemacs21-mule/pkg-plist
+++ b/editors/xemacs21-mule/pkg-plist
@@ -7,26 +7,9 @@ bin/gnudoit
bin/ootags
bin/pstogif
bin/rcs-checkin
-bin/xemacs-21.1.6
+bin/%%XEMACS_DIR%%
@exec ln -sf %D/%F %B/xemacs
@unexec rm %B/xemacs
lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/DOC
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/add-big-package.sh
lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/config.values
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/cvtmail
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/digest-doc
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/fakemail
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/gnuserv
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/gzip-el.sh
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/hexl
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/make-docfile
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/make-path
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/mmencode
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/movemail
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/profile
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/rcs2log
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/sorted-doc
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/vcdiff
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/wakeup
-lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%/yow
@dirrm lib/%%XEMACS_DIR%%/%%ARCH_SUBDIR%%
diff --git a/japanese/xemacs21-canna+freewnn/Makefile b/japanese/xemacs21-canna+freewnn/Makefile
index fa9b7f8df6f0..5227c587ac51 100644
--- a/japanese/xemacs21-canna+freewnn/Makefile
+++ b/japanese/xemacs21-canna+freewnn/Makefile
@@ -1,5 +1,5 @@
# New ports collection makefile for: XEmacs with Canna and Wnn4
-# Version required: 21.1.6
+# Version required: 21.1.8
# Date created: 5 Dec 1997
# Whom: KIRIYAMA Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
@@ -9,7 +9,4 @@
CANNA= yes
WNN4= yes
-MASTERDIR= ${.CURDIR}/../../japanese/xemacs
-PKGDIR= ${.CURDIR}/pkg
-
-.include "${MASTERDIR}/Makefile"
+.include "${.CURDIR}/../xemacs-canna/Makefile"
diff --git a/japanese/xemacs21-canna+wnn6/Makefile b/japanese/xemacs21-canna+wnn6/Makefile
index 9c1fccebaf1f..007328b60dbe 100644
--- a/japanese/xemacs21-canna+wnn6/Makefile
+++ b/japanese/xemacs21-canna+wnn6/Makefile
@@ -1,5 +1,5 @@
# New ports collection makefile for: XEmacs with Canna and Wnn6
-# Version required: 21.1.6
+# Version required: 21.1.8
# Date created: 5 Dec 1997
# Whom: KIRIYAMA Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
@@ -9,7 +9,4 @@
CANNA= yes
WNN6= yes
-MASTERDIR= ${.CURDIR}/../../japanese/xemacs
-PKGDIR= ${.CURDIR}/pkg
-
-.include "${MASTERDIR}/Makefile"
+.include "${.CURDIR}/../xemacs-canna/Makefile"
diff --git a/japanese/xemacs21-canna/Makefile b/japanese/xemacs21-canna/Makefile
index 20eb1192bf4e..d74fcfd20995 100644
--- a/japanese/xemacs21-canna/Makefile
+++ b/japanese/xemacs21-canna/Makefile
@@ -1,14 +1,73 @@
-# New ports collection makefile for: XEmacs for Japanese with Canna
-# Version required: 21.1.6
+# New ports collection makefile for: XEmacs for Japanese
+# Version required: 21.1.8
# Date created: 5 Dec 1997
# Whom: KIRIYAMA Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
# $FreeBSD$
#
-CANNA= yes
+# This is the MASTER port of Japanese XEmacs slave ports(japanese/xemacs-*)
+# and provides `Architecture Dependent' parts of xemacs binary.
+#
+# Caracteristic variables of XEmacs Mule ports family:
+# MULE_COMMON : COMMON port if defined
+# PKGLDIR : Local PKGDIR of MASTER port(editors/xemacs-mule/pkg)
+# SITE_INCLUDES : site include path(configure arguments)
+# SITE_LIBRARIES : site libraries path(configure arguments)
+# WITH_INPUT_METHOD : input methods(configure arguments)
+# LIB_INPUT_METHOD : LIB_DEPENDS list of Input Methods
+# BUILD_INPUT_METHOD: BUILD_DEPENDS list of Input Methods
+
+CATEGORIES= japanese editors
+
+JAPANESE= yes
+MANLANG= ja
+MAN1= xemacs-ja.1
+DESCR_TMPL= ${.CURDIR}/../xemacs-canna/files/DESCR.tmpl
+PLIST= ${PKGLDIR}/PLIST-ja
+
+LANGPREFIX= ja-
+COMMENT= ${WRKDIR}/COMMENT
+DESCR= ${WRKDIR}/DESCR
+.if defined(CANNA) && defined(WNN4)
+PKGNAMEEXT= -canna+wnn4
+SITE_INCLUDES= ${X11BASE}/include
+SITE_LIBRARIES= ${X11BASE}/lib
+WITH_INPUT_METHOD= --with-canna --with-wnn --with-wnn6=no
+LIB_INPUT_METHOD= canna.1:${PORTSDIR}/japanese/Canna
+BUILD_INPUT_METHOD= ${PREFIX}/bin/Wnn4/jserver:${PORTSDIR}/japanese/Wnn
+COMMENT_TEXT= XEmacs(version ${XEMACS_VER}) text editor, with SJ3, SKK, Canna and Wnn4 support.
+.elif defined(CANNA) && defined(WNN6)
+PKGNAMEEXT= -canna+wnn6
+WITH_INPUT_METHOD= --with-canna --with-wnn6
+LIB_INPUT_METHOD= canna.1:${PORTSDIR}/japanese/Canna
+BUILD_INPUT_METHOD= ${PREFIX}/include/wnn/jlib.h:${PORTSDIR}/japanese/Wnn6-lib
+COMMENT_TEXT= XEmacs(version ${XEMACS_VER}) text editor, with SJ3, SKK, Canna and Wnn6 support.
+.elif defined(WNN4)
+PKGNAMEEXT= -wnn4
+SITE_INCLUDES= ${X11BASE}/include
+SITE_LIBRARIES= ${X11BASE}/lib
+WITH_INPUT_METHOD= --with-wnn --with-canna=no --with-wnn6=no
+BUILD_INPUT_METHOD= ${PREFIX}/bin/Wnn4/jserver:${PORTSDIR}/japanese/Wnn
+COMMENT_TEXT= XEmacs(version ${XEMACS_VER}) text editor, with SJ3, SKK and Wnn4 support.
+.elif defined(WNN6)
+PKGNAMEEXT= -wnn6
+WITH_INPUT_METHOD= --with-wnn6 --with-canna=no
+BUILD_INPUT_METHOD= ${PREFIX}/include/wnn/jlib.h:${PORTSDIR}/japanese/Wnn6-lib
+COMMENT_TEXT= XEmacs(version ${XEMACS_VER}) text editor, with SJ3, SKK, Canna and Wnn6 support.
+.else
+PKGNAMEEXT= -canna
+WITH_INPUT_METHOD= --with-canna --with-wnn=no --with-wnn6=no
+LIB_INPUT_METHOD= canna.1:${PORTSDIR}/japanese/Canna
+COMMENT_TEXT= XEmacs(version ${XEMACS_VER}) text editor, with SJ3, SKK and Canna support.
+.endif
+
+post-configure::
+ @${ECHO} "${COMMENT_TEXT}" > ${COMMENT}
-MASTERDIR= ${.CURDIR}/../../japanese/xemacs
-PKGDIR= ${.CURDIR}/pkg
+post-install::
+ @${MKDIR} ${PREFIX}/man/ja/man1
+ @${INSTALL_MAN} ${WRKSRC}/etc/xemacs-ja.1 ${PREFIX}/man/ja/man1
+ @${LN} -sf ja ${PREFIX}/lib/xemacs/mule-packages/etc/app-defaults/ja_JP.EUC
-.include "${MASTERDIR}/Makefile"
+.include "${.CURDIR}/../../editors/xemacs-mule/Makefile"
diff --git a/japanese/xemacs21-canna/files/DESCR.tmpl b/japanese/xemacs21-canna/files/DESCR.tmpl
new file mode 100644
index 000000000000..acba674b39a9
--- /dev/null
+++ b/japanese/xemacs21-canna/files/DESCR.tmpl
@@ -0,0 +1,31 @@
+This is a package containing only the executables for XEmacs with
+Mule(version %%XEMACS_VER%%), the next generation of Emacs.
+
+You need to install a package, xemacs-common-%%XEMACS_VER%%, containing emacs
+lisp files, info pages, and so on (except executables) for
+XEmacs with Mule(version %%XEMACS_VER%%).
+
+This package is built with Japanese support by using SKK, SJ3, Canna,
+Wnn4 or Wnn6 as an external input engine. Each input method would be
+supported in following ports respectively:
+
+ japanese/xemacs-canna ........ SKK, SJ3, Canna
+ japanese/xemacs-canna+wnn4 ... SKK, SJ3, Canna, Wnn4
+ japanese/xemacs-canna+wnn6 ... SKK, SJ3, Canna, Wnn6
+ japanese/xemacs-wnn4 ......... SKK, SJ3, Wnn4
+ japanese/xemacs-wnn6 ......... SKK, SJ3, Wnn6
+
+If you use with SJ3 or SKK, you should be installed sj3serv or skkserv
+in advance. SKK is supported as already builtin. Also it will
+support several input methods under leim.
+
+This package and the package xemacs-common-%%XEMACS_VER%%, might clobber any
+existing emacs installation. In particular, the executables and man
+pages of etags/ctags are installed, and the info pages that come with
+the original emacs will be overwritten too.
+
+Although this shouldn't cause any problems to run both mule and emacs,
+it may cause some confusion when one of them is pkg_delete'd. If
+someone has a solution to this, please tell me.
+Or to avoid this problem, you could select prefix for top install
+directory. By default it is pointed to the usual place, /usr/local.
diff --git a/japanese/xemacs21-canna/pkg-comment b/japanese/xemacs21-canna/pkg-comment
deleted file mode 100644
index 2320690d5427..000000000000
--- a/japanese/xemacs21-canna/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-XEmacs text editor, with Canna, SJ3 and SKK support
diff --git a/japanese/xemacs21-canna/pkg-descr b/japanese/xemacs21-canna/pkg-descr
deleted file mode 100644
index 3d9393e51f94..000000000000
--- a/japanese/xemacs21-canna/pkg-descr
+++ /dev/null
@@ -1,23 +0,0 @@
-This is a package containing only the executables for xemacs-21.1.6, the
-next generation of Emacs.
-
-You need to install a package, xemacs-common-21.1.6, containing emacs
-lisp files, info pages, and so on (except executables) for
-xemacs-21.1.6.
-
-This package is built with Japanese support by using Canna or SJ3 as
-an external input engine. If you use with SJ3, you should be installed
-sj3serv in advance. SKK is supported as already builtin. Also it will
-support several input methods under leim.
-
-This package and the package xemacs-common-21.1.6, might clobber any
-existing emacs installation. In particular, the executables and man
-pages of etags/ctags are installed, and the info pages that come with
-the original emacs will be overwritten too.
-
-Although this shouldn't cause any problems to run both mule and emacs,
-it may cause some confusion when one of them is pkg_delete'd. If
-someone has a solution to this, please tell me.
-Or to avoid this problem, you could select prefix for top install
-directory. By default it is pointed to the usual place, /usr/local.
-
diff --git a/japanese/xemacs21-freewnn/Makefile b/japanese/xemacs21-freewnn/Makefile
index 03d0cc8bf41d..29191d2045cc 100644
--- a/japanese/xemacs21-freewnn/Makefile
+++ b/japanese/xemacs21-freewnn/Makefile
@@ -1,5 +1,5 @@
# New ports collection makefile for: XEmacs with Wnn4
-# Version required: 21.1.6
+# Version required: 21.1.8
# Date created: 25 January 1998
# Whom: KIRIYAMA Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
@@ -8,7 +8,4 @@
WNN4= yes
-MASTERDIR= ${.CURDIR}/../../japanese/xemacs
-PKGDIR= ${.CURDIR}/pkg
-
-.include "${MASTERDIR}/Makefile"
+.include "${.CURDIR}/../xemacs-canna/Makefile"
diff --git a/japanese/xemacs21-wnn6/Makefile b/japanese/xemacs21-wnn6/Makefile
index 71a1ae3ac0bc..2d59d4aad1c5 100644
--- a/japanese/xemacs21-wnn6/Makefile
+++ b/japanese/xemacs21-wnn6/Makefile
@@ -1,5 +1,5 @@
# New ports collection makefile for: XEmacs with Wnn6
-# Version required: 21.1.6
+# Version required: 21.1.8
# Date created: 25 January 1998
# Whom: KIRIYAMA Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
@@ -8,7 +8,4 @@
WNN6= yes
-MASTERDIR= ${.CURDIR}/../../japanese/xemacs
-PKGDIR= ${.CURDIR}/pkg
-
-.include "${MASTERDIR}/Makefile"
+.include "${.CURDIR}/../xemacs-canna/Makefile"