aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1996-06-20 23:53:28 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1996-06-20 23:53:28 +0000
commitc326036982e2e98618d1859929a2c1177e182601 (patch)
tree07a681f1b7e88350edd762e25ef2c5b18b080113
parente308a056f5e24ee9db1709b4c497849656a9e4d1 (diff)
downloadports-c326036982e2e98618d1859929a2c1177e182601.tar.gz
ports-c326036982e2e98618d1859929a2c1177e182601.zip
Merge from HEAD
Notes
Notes: svn path=/branches/RELENG_2_1_0/; revision=3268
-rw-r--r--Mk/bsd.port.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0add00a4eb21..506c469c252f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.210 1996/06/19 09:33:31 asami Exp $
+# $Id: bsd.port.mk,v 1.212 1996/06/20 23:52:45 jkh Exp $
#
# Please view me with 4 column tabs!
@@ -249,7 +249,13 @@ cleandir: clean
.endif
.endif
+.if !target(distribute)
+distribute:
+ @cd ${.CURDIR} && ${MAKE} install DESTDIR=${DISTDIR}/${DISTRIBUTION}
.endif
+.endif
+# end of SRC_ENCAPSULATION defines
+
# These need to be absolute since we don't know how deep in the ports
# tree we are and thus can't go relative. They can, of course, be overridden
@@ -997,7 +1003,7 @@ pre-clean:
clean: pre-clean
@${ECHO_MSG} "===> Cleaning for ${PKGNAME}"
.if !defined(NO_WRKDIR) && !exists(${.CURDIR}/obj)
- ${RM} -rf ${WRKDIR}
+ @${RM} -rf ${WRKDIR}
.else
@${RM} -f ${WRKDIR}/.*_done
.endif