aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-06-16 09:27:41 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-06-16 09:27:41 +0000
commitc2342ae6c19c59ddef257ba9d2df6c08a50c0d6e (patch)
tree7ae4d773c2013dada5ec45915b6c2a6961bf7dce
parent16ee608093151e587e9340ff428f987ee02048f4 (diff)
downloadports-c2342ae6c19c59ddef257ba9d2df6c08a50c0d6e.tar.gz
ports-c2342ae6c19c59ddef257ba9d2df6c08a50c0d6e.zip
Make this actually work.
Notes
Notes: svn path=/head/; revision=29633
-rw-r--r--devel/py-mxDateTime/Makefile6
-rw-r--r--devel/py-mxDateTime/pkg-plist6
2 files changed, 10 insertions, 2 deletions
diff --git a/devel/py-mxDateTime/Makefile b/devel/py-mxDateTime/Makefile
index e163445c7561..ea777d5c5ea6 100644
--- a/devel/py-mxDateTime/Makefile
+++ b/devel/py-mxDateTime/Makefile
@@ -32,9 +32,13 @@ post-extract:
do-configure:
@(cd ${WRKSRC} && ${CONFIGURE_ENV} ${MAKE} -f Makefile.pre.in boot)
-post-install:
+do-install:
@${MKDIR} ${DATETIMEDIR}
${INSTALL_DATA} ${WRKDIR}/DateTime/*.py ${DATETIMEDIR}
+ @${MKDIR} ${DATETIMEDIR}/mxDateTime
+.for file in __init__.py mxDateTime.so
+ ${INSTALL_DATA} ${WRKDIR}/DateTime/mxDateTime/${file} ${DATETIMEDIR}/mxDateTime
+.endfor
@${PREFIX}/bin/python ${PYTHONSCRIPTDIR}/compileall.py ${DATETIMEDIR}
@${PREFIX}/bin/python -O ${PYTHONSCRIPTDIR}/compileall.py ${DATETIMEDIR}
@${MKDIR} ${EXAMPLEDIR}
diff --git a/devel/py-mxDateTime/pkg-plist b/devel/py-mxDateTime/pkg-plist
index bb0f5ba792c1..8d059e4306b1 100644
--- a/devel/py-mxDateTime/pkg-plist
+++ b/devel/py-mxDateTime/pkg-plist
@@ -31,10 +31,14 @@ lib/python1.5/site-packages/DateTime/Timezone.pyo
lib/python1.5/site-packages/DateTime/__init__.py
lib/python1.5/site-packages/DateTime/__init__.pyc
lib/python1.5/site-packages/DateTime/__init__.pyo
+lib/python1.5/site-packages/DateTime/mxDateTime/__init__.py
+lib/python1.5/site-packages/DateTime/mxDateTime/__init__.pyc
+lib/python1.5/site-packages/DateTime/mxDateTime/__init__.pyo
+lib/python1.5/site-packages/DateTime/mxDateTime/mxDateTime.so
+@dirrm lib/python1.5/site-packages/DateTime/mxDateTime
lib/python1.5/site-packages/DateTime/timegm.py
lib/python1.5/site-packages/DateTime/timegm.pyc
lib/python1.5/site-packages/DateTime/timegm.pyo
-lib/python1.5/site-packages/mxDateTime.so
@dirrm lib/python1.5/site-packages/DateTime
share/doc/py-mxDateTime/mxDateTime-History.html
share/doc/py-mxDateTime/mxDateTime.html