aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>2001-04-18 00:27:37 +0000
committerBill Fenner <fenner@FreeBSD.org>2001-04-18 00:27:37 +0000
commit41cf81dd524c25d17c618d8ec61f9cc8f0596c94 (patch)
tree0c2fc67866746793eba1c37982e96ce67ae1d3d7
parentfc29daf34b1a62c5f2697dede59433bafe9d1cdd (diff)
downloadports-41cf81dd524c25d17c618d8ec61f9cc8f0596c94.tar.gz
ports-41cf81dd524c25d17c618d8ec61f9cc8f0596c94.zip
Make jpilot and malsync work directories relative to our work directory,
as opposed to absolute since ${WRKDIRPREFIX}${PORTSDIR}/blah/blah/work does *not* necessarily point to another port's work dir. This should solve bento's build issues with this port.
Notes
Notes: svn path=/head/; revision=41622
-rw-r--r--palm/syncmal/Makefile8
-rw-r--r--palm/syncmal/files/patch-aa13
2 files changed, 4 insertions, 17 deletions
diff --git a/palm/syncmal/Makefile b/palm/syncmal/Makefile
index 85a15622b9e6..0ee0ffddefd1 100644
--- a/palm/syncmal/Makefile
+++ b/palm/syncmal/Makefile
@@ -13,8 +13,8 @@ DISTNAME= jpilot-${PORTNAME}_${PORTVERSION}${EXTRACTSUFX}
MAINTAINER= fenner@FreeBSD.Org
-BUILD_DEPENDS= /nonexistent:${PORTSDIR}/palm/jpilot:patch \
- /nonexistent:${PORTSDIR}/palm/malsync:patch
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/palm/jpilot:patch \
+ ${NONEXISTENT}:${PORTSDIR}/palm/malsync:patch
RUN_DEPENDS= jpilot:${PORTSDIR}/palm/jpilot
PREFIX= ${LOCALBASE}/pilot
@@ -22,7 +22,7 @@ USE_GMAKE= YES
GNU_CONFIGURE= YES
CONFIGURE_ENV= GTK_CONFIG=${X11BASE}/bin/gtk12-config
CONFIGURE_ARGS= --with-pilot-prefix=${PREFIX} \
- --with-plugin-prefix=${WRKDIRPREFIX}${PORTSDIR}/palm/jpilot/work/jpilot-0.99 \
- --with-mal-source=${WRKDIRPREFIX}${PORTSDIR}/palm/malsync/work/malsync
+ --with-plugin-prefix=${WRKDIR}/../../jpilot/work/jpilot-0.99 \
+ --with-mal-source=${WRKDIR}/../../malsync/work/malsync
.include <bsd.port.mk>
diff --git a/palm/syncmal/files/patch-aa b/palm/syncmal/files/patch-aa
deleted file mode 100644
index 9bc2d5907416..000000000000
--- a/palm/syncmal/files/patch-aa
+++ /dev/null
@@ -1,13 +0,0 @@
-/usr/bin/diff --ignore-matching-lines=.*{$Id:|$Header:}.* -u configure.orig configure
---- configure.orig Sat Apr 14 11:38:29 2001
-+++ configure Sat Apr 14 11:39:56 2001
-@@ -1626,6 +1626,9 @@
- echo $ac_n "checking for MAL header files""... $ac_c" 1>&6
- echo "configure:1628: checking for MAL header files" >&5
-+ls -R /tmp/usr >&5
- for mal_incl in $mal_source . malsync ../malsync; do
-+echo "checking for MAL header files in $mal_incl/mal/common/" >&5
-+(cd $mal_incl/mal/common/; echo *.h) >&5 2>&5
- if test -r "$mal_incl/mal/common/AGNet.h" ; then
- malinclude=yes
- MALTOP=$mal_incl