aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-01-22 18:43:33 +0000
committerYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-01-22 18:43:33 +0000
commit43008f4520a2224f36fdf718ad6bbfe4ab562804 (patch)
treede66fd70e3e324c9d5ed6e9abf7640e8b164e9f6
parent8813376ab3af4ee3f3384c9ce22429fa5b9ce327 (diff)
downloadports-43008f4520a2224f36fdf718ad6bbfe4ab562804.tar.gz
ports-43008f4520a2224f36fdf718ad6bbfe4ab562804.zip
Add elisp-info.el, provide functions for Emacs to find
description of function or variable from Emacs-Lisp Reference Manual.
Notes
Notes: svn path=/head/; revision=53592
-rw-r--r--editors/mode-info/Makefile40
-rw-r--r--editors/mode-info/distinfo1
-rw-r--r--editors/mode-info/files/ELISP_CFG3
-rw-r--r--editors/mode-info/files/elisp-info-setup.el11
-rw-r--r--editors/mode-info/pkg-comment1
-rw-r--r--editors/mode-info/pkg-descr9
-rw-r--r--editors/mode-info/pkg-plist4
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/elisp-info/Makefile40
-rw-r--r--japanese/elisp-info/distinfo1
-rw-r--r--japanese/elisp-info/files/ELISP_CFG3
-rw-r--r--japanese/elisp-info/files/elisp-info-setup.el11
-rw-r--r--japanese/elisp-info/pkg-comment1
-rw-r--r--japanese/elisp-info/pkg-descr9
-rw-r--r--japanese/elisp-info/pkg-plist4
15 files changed, 139 insertions, 0 deletions
diff --git a/editors/mode-info/Makefile b/editors/mode-info/Makefile
new file mode 100644
index 000000000000..3c621c521c78
--- /dev/null
+++ b/editors/mode-info/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: elisp-info.el
+# Date Created: 21 Jan 2002
+# Whom: Yoichi NAKAYAMA <yoichi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= elisp-info
+PORTVERSION= 2.11
+CATEGORIES= japanese elisp
+MASTER_SITES= http://namazu.org/~tsuchiya/elisp/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .el
+
+MAINTAINER= yoichi@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/info/elisp-ja:${PORTSDIR}/japanese/elisp-manual
+RUN_DEPENDS= ${LOCALBASE}/info/elisp-ja:${PORTSDIR}/japanese/elisp-manual
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= -p
+EXTRACT_AFTER_ARGS= ./
+
+EMACS_PORT_NAME?= emacs21
+EMACS_NO_RUN_DEPENDS= yes
+LISPDIR?= ${PREFIX}/${EMACS_SITE_LISPDIR}/${PORTNAME}
+
+post-extract:
+ ${CP} ${FILESDIR}/ELISP_CFG ${WRKDIR}
+do-build:
+ (cd ${WRKDIR}; \
+ ${EMACS_CMD} -batch -l ./ELISP_CFG -l ./${PORTNAME}.el -f ${PORTNAME}-make-index)
+do-install:
+ ${MKDIR} ${LISPDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.el ${LISPDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-index.el ${LISPDIR}
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}-setup.el ${LISPDIR}
+
+.include <bsd.port.mk>
diff --git a/editors/mode-info/distinfo b/editors/mode-info/distinfo
new file mode 100644
index 000000000000..08cb74c396ca
--- /dev/null
+++ b/editors/mode-info/distinfo
@@ -0,0 +1 @@
+MD5 (elisp-info.el) = 8f1d82402b087992586186597a88fe4c
diff --git a/editors/mode-info/files/ELISP_CFG b/editors/mode-info/files/ELISP_CFG
new file mode 100644
index 000000000000..a426e885e557
--- /dev/null
+++ b/editors/mode-info/files/ELISP_CFG
@@ -0,0 +1,3 @@
+(require 'info)
+(info-initialize)
+(setq elisp-info-list '("elisp-ja"))
diff --git a/editors/mode-info/files/elisp-info-setup.el b/editors/mode-info/files/elisp-info-setup.el
new file mode 100644
index 000000000000..f1c56717c4b1
--- /dev/null
+++ b/editors/mode-info/files/elisp-info-setup.el
@@ -0,0 +1,11 @@
+;; Setup for elisp-info.el
+(require 'elisp-info)
+(eval-after-load "help.el"
+ (progn
+ (define-key help-map "f" 'elisp-info-describe-function)
+ (define-key help-map "d" 'elisp-info-describe-function)
+ (define-key help-map "D" 'describe-function)
+ (define-key help-map "v" 'elisp-info-describe-variable)
+ (define-key help-map "V" 'describe-variable)
+ (define-key help-mode-map "i" 'elisp-info-help-to-info)))
+(provide 'elisp-info-setup) \ No newline at end of file
diff --git a/editors/mode-info/pkg-comment b/editors/mode-info/pkg-comment
new file mode 100644
index 000000000000..eddebd1dbefd
--- /dev/null
+++ b/editors/mode-info/pkg-comment
@@ -0,0 +1 @@
+Functions to refer Emacs-Lisp Reference Manual
diff --git a/editors/mode-info/pkg-descr b/editors/mode-info/pkg-descr
new file mode 100644
index 000000000000..ee499a09b98b
--- /dev/null
+++ b/editors/mode-info/pkg-descr
@@ -0,0 +1,9 @@
+This package provide functions for Emacs with which you can
+find description of function or variable from Emacs-Lisp
+Reference Manual. If you put (require 'elisp-info-setup)
+in ~/.emacs then following key binds are provided.
+
+C-h f (C-h d) : elisp-info-describe-function
+C-h D : describe-function
+C-h v : elisp-info-describe-variable
+C-h V : describe-variable
diff --git a/editors/mode-info/pkg-plist b/editors/mode-info/pkg-plist
new file mode 100644
index 000000000000..80f6c0e28173
--- /dev/null
+++ b/editors/mode-info/pkg-plist
@@ -0,0 +1,4 @@
+%%EMACS_SITE_LISPDIR%%/elisp-info/elisp-info.el
+%%EMACS_SITE_LISPDIR%%/elisp-info/elisp-info-index.el
+%%EMACS_SITE_LISPDIR%%/elisp-info/elisp-info-setup.el
+@dirrm %%EMACS_SITE_LISPDIR%%/elisp-info
diff --git a/japanese/Makefile b/japanese/Makefile
index dde0ff11bb84..d7788f74fa2f 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -61,6 +61,7 @@
SUBDIR += eijiro-fpw
SUBDIR += elisa10x8
SUBDIR += elisa8x8
+ SUBDIR += elisp-info
SUBDIR += elisp-manual
SUBDIR += elvis
SUBDIR += emacs-manual
diff --git a/japanese/elisp-info/Makefile b/japanese/elisp-info/Makefile
new file mode 100644
index 000000000000..3c621c521c78
--- /dev/null
+++ b/japanese/elisp-info/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: elisp-info.el
+# Date Created: 21 Jan 2002
+# Whom: Yoichi NAKAYAMA <yoichi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= elisp-info
+PORTVERSION= 2.11
+CATEGORIES= japanese elisp
+MASTER_SITES= http://namazu.org/~tsuchiya/elisp/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .el
+
+MAINTAINER= yoichi@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/info/elisp-ja:${PORTSDIR}/japanese/elisp-manual
+RUN_DEPENDS= ${LOCALBASE}/info/elisp-ja:${PORTSDIR}/japanese/elisp-manual
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= -p
+EXTRACT_AFTER_ARGS= ./
+
+EMACS_PORT_NAME?= emacs21
+EMACS_NO_RUN_DEPENDS= yes
+LISPDIR?= ${PREFIX}/${EMACS_SITE_LISPDIR}/${PORTNAME}
+
+post-extract:
+ ${CP} ${FILESDIR}/ELISP_CFG ${WRKDIR}
+do-build:
+ (cd ${WRKDIR}; \
+ ${EMACS_CMD} -batch -l ./ELISP_CFG -l ./${PORTNAME}.el -f ${PORTNAME}-make-index)
+do-install:
+ ${MKDIR} ${LISPDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.el ${LISPDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-index.el ${LISPDIR}
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}-setup.el ${LISPDIR}
+
+.include <bsd.port.mk>
diff --git a/japanese/elisp-info/distinfo b/japanese/elisp-info/distinfo
new file mode 100644
index 000000000000..08cb74c396ca
--- /dev/null
+++ b/japanese/elisp-info/distinfo
@@ -0,0 +1 @@
+MD5 (elisp-info.el) = 8f1d82402b087992586186597a88fe4c
diff --git a/japanese/elisp-info/files/ELISP_CFG b/japanese/elisp-info/files/ELISP_CFG
new file mode 100644
index 000000000000..a426e885e557
--- /dev/null
+++ b/japanese/elisp-info/files/ELISP_CFG
@@ -0,0 +1,3 @@
+(require 'info)
+(info-initialize)
+(setq elisp-info-list '("elisp-ja"))
diff --git a/japanese/elisp-info/files/elisp-info-setup.el b/japanese/elisp-info/files/elisp-info-setup.el
new file mode 100644
index 000000000000..f1c56717c4b1
--- /dev/null
+++ b/japanese/elisp-info/files/elisp-info-setup.el
@@ -0,0 +1,11 @@
+;; Setup for elisp-info.el
+(require 'elisp-info)
+(eval-after-load "help.el"
+ (progn
+ (define-key help-map "f" 'elisp-info-describe-function)
+ (define-key help-map "d" 'elisp-info-describe-function)
+ (define-key help-map "D" 'describe-function)
+ (define-key help-map "v" 'elisp-info-describe-variable)
+ (define-key help-map "V" 'describe-variable)
+ (define-key help-mode-map "i" 'elisp-info-help-to-info)))
+(provide 'elisp-info-setup) \ No newline at end of file
diff --git a/japanese/elisp-info/pkg-comment b/japanese/elisp-info/pkg-comment
new file mode 100644
index 000000000000..eddebd1dbefd
--- /dev/null
+++ b/japanese/elisp-info/pkg-comment
@@ -0,0 +1 @@
+Functions to refer Emacs-Lisp Reference Manual
diff --git a/japanese/elisp-info/pkg-descr b/japanese/elisp-info/pkg-descr
new file mode 100644
index 000000000000..ee499a09b98b
--- /dev/null
+++ b/japanese/elisp-info/pkg-descr
@@ -0,0 +1,9 @@
+This package provide functions for Emacs with which you can
+find description of function or variable from Emacs-Lisp
+Reference Manual. If you put (require 'elisp-info-setup)
+in ~/.emacs then following key binds are provided.
+
+C-h f (C-h d) : elisp-info-describe-function
+C-h D : describe-function
+C-h v : elisp-info-describe-variable
+C-h V : describe-variable
diff --git a/japanese/elisp-info/pkg-plist b/japanese/elisp-info/pkg-plist
new file mode 100644
index 000000000000..80f6c0e28173
--- /dev/null
+++ b/japanese/elisp-info/pkg-plist
@@ -0,0 +1,4 @@
+%%EMACS_SITE_LISPDIR%%/elisp-info/elisp-info.el
+%%EMACS_SITE_LISPDIR%%/elisp-info/elisp-info-index.el
+%%EMACS_SITE_LISPDIR%%/elisp-info/elisp-info-setup.el
+@dirrm %%EMACS_SITE_LISPDIR%%/elisp-info