aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-05-25 00:30:24 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-05-25 00:30:24 +0000
commit30eea66494bfffd5b3eaf451f7f0edb51737b3b1 (patch)
treeb0f8fc67040947859b1788560ba98304dbb3ea65
parentc67968755f6a89fa6f4514c8225f5e23e6fae123 (diff)
downloadports-30eea66494bfffd5b3eaf451f7f0edb51737b3b1.tar.gz
ports-30eea66494bfffd5b3eaf451f7f0edb51737b3b1.zip
Make sure STRIP is defined before referencing the value. STRIP can be
undefined when DEBUG_FLAGS is defined. Submitted by: Dave Cornejo <dave@dogwood.com>, Joshua Goodall <joshua@roughtrade.net>
Notes
Notes: svn path=/head/; revision=59938
-rw-r--r--lang/ruby-devel/Makefile2
-rw-r--r--lang/ruby/Makefile2
-rw-r--r--lang/ruby16/Makefile2
-rw-r--r--lang/ruby18/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/lang/ruby-devel/Makefile b/lang/ruby-devel/Makefile
index 68710294f98d..29c4f080acaf 100644
--- a/lang/ruby-devel/Makefile
+++ b/lang/ruby-devel/Makefile
@@ -118,7 +118,7 @@ pre-install:
done
post-install:
-.if ${STRIP} == -s
+.if defined(STRIP) && ${STRIP} == -s
strip ${RUBY}
.endif
${INSTALL_SCRIPT} ${WRKSRC}/ext/dl/h2rb ${PREFIX}/bin/
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index d7fbb038430a..d2da2e936ad9 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -103,7 +103,7 @@ pre-install:
done
post-install:
-.if ${STRIP} == -s
+.if defined(STRIP) && ${STRIP} == -s
strip ${RUBY}
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index d7fbb038430a..d2da2e936ad9 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -103,7 +103,7 @@ pre-install:
done
post-install:
-.if ${STRIP} == -s
+.if defined(STRIP) && ${STRIP} == -s
strip ${RUBY}
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 68710294f98d..29c4f080acaf 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -118,7 +118,7 @@ pre-install:
done
post-install:
-.if ${STRIP} == -s
+.if defined(STRIP) && ${STRIP} == -s
strip ${RUBY}
.endif
${INSTALL_SCRIPT} ${WRKSRC}/ext/dl/h2rb ${PREFIX}/bin/