aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-24 13:50:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-24 13:50:46 +0000
commit47dab81eb744ecd7ca0d2ec5518c1e1a60bee96b (patch)
treee3bf978d5cbdedc72919638754fcfe096ceb0cc8
parent1b93f8f793d272742a32ad305b4a6b555f84206f (diff)
downloadports-47dab81eb744ecd7ca0d2ec5518c1e1a60bee96b.tar.gz
ports-47dab81eb744ecd7ca0d2ec5518c1e1a60bee96b.zip
add py-spreadmodule 1.2
A python extension module for the Spread group communcations package PR: 36868 Submitted by: Joshua Goodall <joshua@roughtrade.net>
Notes
Notes: svn path=/head/; revision=59897
-rw-r--r--net/Makefile1
-rw-r--r--net/py-spreadmodule/Makefile26
-rw-r--r--net/py-spreadmodule/distinfo1
-rw-r--r--net/py-spreadmodule/pkg-comment1
-rw-r--r--net/py-spreadmodule/pkg-descr6
-rw-r--r--net/py-spreadmodule/pkg-plist1
6 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d020f279e8db..01775a3c9cd2 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -403,6 +403,7 @@
SUBDIR += py-smb
SUBDIR += py-snmp
SUBDIR += py-soap
+ SUBDIR += py-spreadmodule
SUBDIR += py-xmlrpc
SUBDIR += py-xmlrpclib
SUBDIR += py-zsi
diff --git a/net/py-spreadmodule/Makefile b/net/py-spreadmodule/Makefile
new file mode 100644
index 000000000000..1a01ce722ef2
--- /dev/null
+++ b/net/py-spreadmodule/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-spreadmodule
+# Date created: 24 May 2002
+# Whom: Joshua Goodall <joshua@roughtrade.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spreadmodule
+PORTVERSION= 1.2
+CATEGORIES= net python
+MASTER_SITES= http://www.python.org/other/spread/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= SpreadModule-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= joshua@roughtrade.net
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libsp.a:${PORTSDIR}/net/spread
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+post-patch:
+ @${PERL} -pi -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/net/py-spreadmodule/distinfo b/net/py-spreadmodule/distinfo
new file mode 100644
index 000000000000..5c7b52303db3
--- /dev/null
+++ b/net/py-spreadmodule/distinfo
@@ -0,0 +1 @@
+MD5 (SpreadModule-1.2.tgz) = dec9b45f8e3891f9afc5939932be59ac
diff --git a/net/py-spreadmodule/pkg-comment b/net/py-spreadmodule/pkg-comment
new file mode 100644
index 000000000000..2add18ed64ac
--- /dev/null
+++ b/net/py-spreadmodule/pkg-comment
@@ -0,0 +1 @@
+A python extension module for the Spread group communcations package
diff --git a/net/py-spreadmodule/pkg-descr b/net/py-spreadmodule/pkg-descr
new file mode 100644
index 000000000000..0534e6dd0ea7
--- /dev/null
+++ b/net/py-spreadmodule/pkg-descr
@@ -0,0 +1,6 @@
+This is a Python extension module for Spread, an open source group
+communications package.
+
+WWW: http://www.python.org/other/spread/
+
+- Joshua Goodall <joshua@roughtrade.net>
diff --git a/net/py-spreadmodule/pkg-plist b/net/py-spreadmodule/pkg-plist
new file mode 100644
index 000000000000..4402d8f9eba7
--- /dev/null
+++ b/net/py-spreadmodule/pkg-plist
@@ -0,0 +1 @@
+lib/%%PYTHON_VERSION%%/site-packages/spread.so