aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOllivier Robert <roberto@FreeBSD.org>2003-03-09 17:41:51 +0000
committerOllivier Robert <roberto@FreeBSD.org>2003-03-09 17:41:51 +0000
commitbf4093374e9616e670ce35d9a4ca357a6e861587 (patch)
tree3e9bf617bae57c77bf5689ba07494cb62cdc896f
parent6b466daea7ef6eb23b45adcaef69ec8abd476426 (diff)
downloadports-bf4093374e9616e670ce35d9a4ca357a6e861587.tar.gz
ports-bf4093374e9616e670ce35d9a4ca357a6e861587.zip
Fix picturebook the same way I fixed sjog. Make myself maintainer as well.
Approved by: portmgr(will)
Notes
Notes: svn path=/head/; revision=77077
-rw-r--r--graphics/picturebook/Makefile2
-rw-r--r--graphics/picturebook/files/patch-ac15
-rw-r--r--graphics/picturebook/files/patch-ba12
-rw-r--r--graphics/picturebook/files/patch-bb12
4 files changed, 28 insertions, 13 deletions
diff --git a/graphics/picturebook/Makefile b/graphics/picturebook/Makefile
index 1f8fb26b7b38..72299ccf586e 100644
--- a/graphics/picturebook/Makefile
+++ b/graphics/picturebook/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://samba.org/picturebook/
DISTNAME= capture
EXTRACT_SUFX= .tgz
-MAINTAINER= alan@clegg.com
+MAINTAINER= roberto@FreeBSD.org
COMMENT= SONY VAIO camera capture utility
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/graphics/picturebook/files/patch-ac b/graphics/picturebook/files/patch-ac
index b7b64fa6f4c9..ee1557244ef3 100644
--- a/graphics/picturebook/files/patch-ac
+++ b/graphics/picturebook/files/patch-ac
@@ -1,6 +1,12 @@
---- ../picturebook.old/capture.h Mon Dec 25 19:01:43 2000
-+++ capture.h Mon Dec 25 19:03:17 2000
-@@ -21,15 +21,28 @@
+--- capture.h.orig Thu Jul 27 02:15:05 2000
++++ capture.h Sun Mar 9 18:18:21 2003
+@@ -16,20 +16,34 @@
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+ #define _XOPEN_SOURCE 500
++#define __BSD_VISIBLE 1
+ #include <stdio.h>
+ #include <stdlib.h>
#include <unistd.h>
#include <fcntl.h>
#include <errno.h>
@@ -20,7 +26,7 @@
+#endif
+#ifdef LINUX
#include <linux/pci.h>
-+#else ifdef __FreeBSD__
++#else
+#include <sys/pciio.h>
+#include "pci.h" /*This is taken from Linux kernel*/
+#define O_SYNC O_FSYNC
@@ -28,3 +34,4 @@
+#endif
#include <sys/time.h>
#include "mchip.h"
+
diff --git a/graphics/picturebook/files/patch-ba b/graphics/picturebook/files/patch-ba
index 0bae7539b563..a782221d66f8 100644
--- a/graphics/picturebook/files/patch-ba
+++ b/graphics/picturebook/files/patch-ba
@@ -1,6 +1,10 @@
---- setbrightness.c.orig Tue Dec 12 09:42:20 2000
-+++ setbrightness.c Mon Jul 30 14:29:54 2001
-@@ -4,17 +4,47 @@
+--- setbrightness.c.orig Tue Dec 12 01:42:20 2000
++++ setbrightness.c Sun Mar 9 18:20:58 2003
+@@ -1,20 +1,51 @@
+ #define _XOPEN_SOURCE 500
++#define __BSD_VISIBLE 1
+ #include <stdio.h>
+ #include <stdlib.h>
#include <unistd.h>
#include <fcntl.h>
#include <errno.h>
@@ -48,7 +52,7 @@
#define DATA_REG 0x62
#define CST_REG 0x66
-@@ -24,28 +54,35 @@
+@@ -24,28 +55,35 @@
static void ecr_set(u16 addr, u16 value)
{
while (inw(CST_REG) & 3) usleep(1);
diff --git a/graphics/picturebook/files/patch-bb b/graphics/picturebook/files/patch-bb
index d682f9b0e0f5..9186eb5d3141 100644
--- a/graphics/picturebook/files/patch-bb
+++ b/graphics/picturebook/files/patch-bb
@@ -1,6 +1,10 @@
---- vaiobat.c Tue Dec 12 09:42:20 2000
-+++ vaiobat.c Wed Mar 21 20:16:59 2001
-@@ -4,18 +4,50 @@
+--- vaiobat.c.orig Thu Feb 8 09:15:07 2001
++++ vaiobat.c Sun Mar 9 18:22:57 2003
+@@ -1,21 +1,54 @@
+ #define _XOPEN_SOURCE 500
++#define __BSD_VISIBLE 1
+ #include <stdio.h>
+ #include <stdlib.h>
#include <unistd.h>
#include <fcntl.h>
#include <errno.h>
@@ -51,7 +55,7 @@
#define DATA_REG 0x62
#define CST_REG 0x66
-@@ -25,20 +57,20 @@
+@@ -25,20 +58,20 @@
static void ecr_set(u8 addr, u8 value)
{
while (inb(CST_REG) & 3) usleep(1);