aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Hay <jhay@FreeBSD.org>2003-11-24 18:16:30 +0000
committerJohn Hay <jhay@FreeBSD.org>2003-11-24 18:16:30 +0000
commit6f45f9a15eca37d8034b386ae29bc059991581bd (patch)
tree18a79b84a0129a61d498f7bce528411d68f5e6c4
parente331747748419d640812b2b7932f9f1e04459afa (diff)
downloadports-6f45f9a15eca37d8034b386ae29bc059991581bd.tar.gz
ports-6f45f9a15eca37d8034b386ae29bc059991581bd.zip
Update to nqc 2.5 r3.
Notes
Notes: svn path=/head/; revision=94766
-rw-r--r--lang/nqc/Makefile2
-rw-r--r--lang/nqc/distinfo2
-rw-r--r--lang/nqc/files/patch-aa28
3 files changed, 19 insertions, 13 deletions
diff --git a/lang/nqc/Makefile b/lang/nqc/Makefile
index bccbc4e68f48..9bc40d40427c 100644
--- a/lang/nqc/Makefile
+++ b/lang/nqc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nqc
-PORTVERSION= 2.5.r1
+PORTVERSION= 2.5.r3
CATEGORIES= lang
MASTER_SITES= http://www.baumfamily.org/nqc/release/
EXTRACT_SUFX= .tgz
diff --git a/lang/nqc/distinfo b/lang/nqc/distinfo
index d9100e037e8e..fbb81acf4899 100644
--- a/lang/nqc/distinfo
+++ b/lang/nqc/distinfo
@@ -1 +1 @@
-MD5 (nqc-2.5.r1.tgz) = b765ac5077aba731861157c265748075
+MD5 (nqc-2.5.r3.tgz) = 65917b5057533f9c12b9504f0c966f8d
diff --git a/lang/nqc/files/patch-aa b/lang/nqc/files/patch-aa
index 338eb7133622..b0f77ab7c472 100644
--- a/lang/nqc/files/patch-aa
+++ b/lang/nqc/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Jan 28 06:24:21 2003
-+++ Makefile Thu Jan 30 20:19:25 2003
+--- Makefile.orig Sun Nov 9 06:14:20 2003
++++ Makefile Mon Nov 24 19:57:31 2003
@@ -28,20 +28,20 @@
#
# Pick your C++ compiler.
@@ -54,19 +54,25 @@
-USBOBJ = rcxlib/RCX_USBTowerPipe_none.o
+USBOBJ = rcxlib/RCX_USBTowerPipe_fbsd.o
+
#
- # Platform specific tweaks
-@@ -78,9 +79,6 @@
- ifeq ($TARGET),solaris)
+@@ -87,18 +88,23 @@
# Solaris
CFLAGS += -DSOLARIS
--else
-- # default - works for Linux
-- CFLAGS += -O6
+ else
++ifneq (,$(strip $(findstring $(OSTYPE), FreeBSD)))
++ # FreeBSD
++ # Don't need to set anything
++else
+ # default Unix build without USB support
+ CFLAGS += -O6
endif
endif
+ endif
++endif
+
-@@ -88,7 +86,7 @@
+ # this must happen after the platform tweaks just in case the platform
# wants to redefine the default serial name
#
ifndef DEFAULT_SERIAL_NAME
@@ -75,7 +81,7 @@
endif
CFLAGS += -DDEFAULT_SERIAL_NAME='$(DEFAULT_SERIAL_NAME)'
-@@ -140,10 +138,10 @@
+@@ -150,10 +156,10 @@
$(MKDIR) bin
bin/nqc : compiler/parse.cpp $(OBJ)
@@ -88,7 +94,7 @@
#
# clean up stuff
-@@ -203,7 +201,7 @@
+@@ -213,7 +219,7 @@
# general rule for compiling
#
.cpp.o: