aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-09-26 12:56:14 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-09-26 12:56:14 +0000
commitc32ac92f841e87eadfb5f7377d8f8840a75de48d (patch)
treee56ee67398ce13ed6c740d002f47e93d18e86e3f
parentdd522e1e314cd67cdf18fe6e8c1dd1aaacbf0709 (diff)
downloadports-c32ac92f841e87eadfb5f7377d8f8840a75de48d.tar.gz
ports-c32ac92f841e87eadfb5f7377d8f8840a75de48d.zip
Update to 2.7.5.
Feature safe: yes
Notes
Notes: svn path=/head/; revision=242133
-rw-r--r--textproc/libxml2/Makefile4
-rw-r--r--textproc/libxml2/distinfo6
-rw-r--r--textproc/libxml2/files/patch-parser.c16
3 files changed, 5 insertions, 21 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 3ba16db9e1f9..0dd79ff054bc 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -12,8 +12,8 @@
#
PORTNAME= libxml2
-PORTVERSION= 2.7.4
-PORTREVISION?= 1
+PORTVERSION= 2.7.5
+PORTREVISION?= 0
CATEGORIES?= textproc gnome
MASTER_SITES= ftp://fr.rpmfind.net/pub/libxml/ \
ftp://gd.tuwien.ac.at/pub/libxml/ \
diff --git a/textproc/libxml2/distinfo b/textproc/libxml2/distinfo
index d9047d867ddb..e332906c7b26 100644
--- a/textproc/libxml2/distinfo
+++ b/textproc/libxml2/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/libxml2-2.7.4.tar.gz) = 961cce07211049e3bb20c5b98a1281b4
-SHA256 (gnome2/libxml2-2.7.4.tar.gz) = f10ff01a25750913828b69625ac9d1f1f82039aa8401ca843c1d335763cbf5b1
-SIZE (gnome2/libxml2-2.7.4.tar.gz) = 4835073
+MD5 (gnome2/libxml2-2.7.5.tar.gz) = 2e29ca610579438714ebb1e4010a0ece
+SHA256 (gnome2/libxml2-2.7.5.tar.gz) = af5a9a6d9ffb09756f0792fb402720ca2505762b7f6dd99ba277d5fbfffcec6d
+SIZE (gnome2/libxml2-2.7.5.tar.gz) = 4854121
diff --git a/textproc/libxml2/files/patch-parser.c b/textproc/libxml2/files/patch-parser.c
deleted file mode 100644
index 5813507f7fe7..000000000000
--- a/textproc/libxml2/files/patch-parser.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- parser.c.orig 2009-09-16 17:00:06.000000000 +0200
-+++ parser.c 2009-09-16 17:01:07.000000000 +0200
-@@ -10130,8 +10130,12 @@ xmlParseDocument(xmlParserCtxtPtr ctxt)
- /*
- * Check for the XMLDecl in the Prolog.
- * do not GROW here to avoid the detected encoder to decode more
-- * than just the first line
-+ * than just the first line, unless the amount of data is really
-+ * too small to hold "<?xml version="1.0" encoding="foo"
- */
-+ if ((ctxt->input->end - ctxt->input->cur) < 35) {
-+ GROW;
-+ }
- if ((CMP5(CUR_PTR, '<', '?', 'x', 'm', 'l')) && (IS_BLANK_CH(NXT(5)))) {
-
- /*