aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2009-09-27 16:54:58 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2009-09-27 16:54:58 +0000
commitce5abe443c15a1aa2d26c1cbb54dbf4cf48e6195 (patch)
tree7b73aa0b29daecc61f6e1025d0dfd9d5366bccf6
parentefbf96e92218b6164ff5822aa9a3fcc0faeffbde (diff)
downloadports-ce5abe443c15a1aa2d26c1cbb54dbf4cf48e6195.tar.gz
ports-ce5abe443c15a1aa2d26c1cbb54dbf4cf48e6195.zip
- Fixed build to FreeBSD 9.
- Mark as jobs safe. PR: 138916 Submitted by: Sylvio Cesar <scjamorim___bsd.com.br> Feature safe: yes
Notes
Notes: svn path=/head/; revision=242172
-rw-r--r--mail/postfix-current/Makefile1
-rw-r--r--mail/postfix-current/files/patch-makedefs10
-rw-r--r--mail/postfix-current/files/patch-src__util__sys_defs.h17
3 files changed, 20 insertions, 8 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index 254aac040427..64307c3929cb 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -24,6 +24,7 @@ COMMENT= A secure alternative to widely-used Sendmail
CONFLICTS= courier-0.* postfix-1.* postfix-2.* postfix-current-2.[0-68-9]* \
sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
+MAKE_JOBS_SAFE= yes
USE_SUBMAKE= yes
USE_PERL5_BUILD=yes
USE_RC_SUBR= postfix.sh
diff --git a/mail/postfix-current/files/patch-makedefs b/mail/postfix-current/files/patch-makedefs
index e2c3ef21120f..2c6f01dc0379 100644
--- a/mail/postfix-current/files/patch-makedefs
+++ b/mail/postfix-current/files/patch-makedefs
@@ -1,10 +1,12 @@
---- makedefs.orig 2007-08-19 11:28:11.000000000 -0300
-+++ makedefs 2007-10-22 16:37:52.000000000 -0200
-@@ -132,6 +132,8 @@
+--- makedefs.orig 2009-05-11 18:26:46.000000000 -0300
++++ makedefs 2009-09-15 10:27:12.000000000 -0300
+@@ -144,6 +144,10 @@
;;
FreeBSD.7*) SYSTYPE=FREEBSD7
;;
-+ FreeBSD.8*) SYSTYPE=FREEBSD7
++ FreeBSD.8*) SYSTYPE=FREEBSD8
++ ;;
++ FreeBSD.9*) SYSTYPE=FREEBSD9
+ ;;
OpenBSD.2*) SYSTYPE=OPENBSD2
;;
diff --git a/mail/postfix-current/files/patch-src__util__sys_defs.h b/mail/postfix-current/files/patch-src__util__sys_defs.h
index 22119b906d2f..68b537c624e1 100644
--- a/mail/postfix-current/files/patch-src__util__sys_defs.h
+++ b/mail/postfix-current/files/patch-src__util__sys_defs.h
@@ -1,10 +1,19 @@
---- src/util/sys_defs.h.orig 2009-07-29 16:58:28.000000000 -0300
-+++ src/util/sys_defs.h 2009-07-29 16:59:15.000000000 -0300
-@@ -110,6 +110,10 @@
+--- src/util/sys_defs.h.orig 2009-06-07 15:47:59.000000000 -0300
++++ src/util/sys_defs.h 2009-09-27 16:30:18.000000000 -0300
+@@ -25,6 +25,7 @@
+ */
+ #if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
+ || defined(FREEBSD5) || defined(FREEBSD6) || defined(FREEBSD7) \
++ || defined(FREEBSD8) || defined(FREEBSD9) \
+ || defined(BSDI2) || defined(BSDI3) || defined(BSDI4) \
+ || defined(OPENBSD2) || defined(OPENBSD3) || defined(OPENBSD4) \
+ || defined(NETBSD1) || defined(NETBSD2) || defined(NETBSD3) \
+@@ -110,6 +111,11 @@
#define HAS_DUPLEX_PIPE /* 4.1 breaks with kqueue(2) */
#endif
-+#if (__FreeBSD_version >= 702104 && __FreeBSD_version < 800000) || (__FreeBSD_version >= 800099)
++#if (__FreeBSD_version >= 702104 && __FreeBSD_version <= 800000) \
++ || __FreeBSD_version >= 800100
+#define HAS_CLOSEFROM
+#endif
+