aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2010-07-07 23:22:25 +0000
committerBrooks Davis <brooks@FreeBSD.org>2010-07-07 23:22:25 +0000
commit9e5eeb4e5be36ac84b79dbf3e7b480d2a9dbaa55 (patch)
tree2d27eaf747f8e67e124058643c970cc8b4fb4e65
parentdd7fe419cf014c4efa178a9b03d847dc4f5befc4 (diff)
downloadports-9e5eeb4e5be36ac84b79dbf3e7b480d2a9dbaa55.tar.gz
ports-9e5eeb4e5be36ac84b79dbf3e7b480d2a9dbaa55.zip
Another attempt to fixing interactions with p5-DBIx-Class. A few people
report that this works. PR: 148318 Feature safe: yes Submitted by: Mark Knight
Notes
Notes: svn path=/head/; revision=257503
-rw-r--r--audio/squeezeboxserver/Makefile2
-rw-r--r--audio/squeezeboxserver/files/patch-dbix-class-bug.diff37
2 files changed, 38 insertions, 1 deletions
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index 9f606b0bf50e..20de191cc372 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= squeezeboxserver
PORTVERSION= 7.5.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://downloads.slimdevices.com/SqueezeboxServer_v${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-noCPAN
diff --git a/audio/squeezeboxserver/files/patch-dbix-class-bug.diff b/audio/squeezeboxserver/files/patch-dbix-class-bug.diff
new file mode 100644
index 000000000000..0e0684251df1
--- /dev/null
+++ b/audio/squeezeboxserver/files/patch-dbix-class-bug.diff
@@ -0,0 +1,37 @@
+Index: Slim/Schema.pm
+===================================================================
+--- Slim/Schema.pm (revision 31006)
++++ Slim/Schema.pm (working copy)
+@@ -274,11 +274,15 @@
+ # For custom exceptions
+ $class->storage_type('Slim::Schema::Storage');
+
++ # Don't use autocommit mode for the scanner.
++ # Needs to be set here as setting dbh->{'AutoCommit'} = 0 later
++ # confusing the transaction nesting logic.
++ my $AutoCommit = (main::SCANNER ? 0 : 1);
+ my $on_connect_do = $sqlHelperClass->on_connect_do();
+
+ $class->connection( $dsn || $source, $username, $password, {
+ RaiseError => 1,
+- AutoCommit => 1,
++ AutoCommit => $AutoCommit,
+ PrintError => 0,
+ Taint => 1,
+ on_connect_do => [
+Index: scanner.pl
+===================================================================
+--- scanner.pl (revision 31006)
++++ scanner.pl (working copy)
+@@ -236,9 +236,6 @@
+
+ main::INFOLOG && $log->info("Squeezebox Server Scanner done init...\n");
+
+- # Take the db out of autocommit mode - this makes for a much faster scan.
+- Slim::Schema->storage->dbh->{'AutoCommit'} = 0;
+-
+ my $scanType = 'SETUP_STANDARDRESCAN';
+
+ if ($wipe) {
+
+--------------020502080403070605040408--