aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-02 22:54:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-02 22:54:55 +0000
commitc554fae60b009ddbfea21e2e90c85cd62c058800 (patch)
tree27196bd8d34820d66fd09381b10aef01184a08f2
parent5c171e70d118a24e09c84a1a3e7aa82228f43c86 (diff)
downloadports-c554fae60b009ddbfea21e2e90c85cd62c058800.tar.gz
ports-c554fae60b009ddbfea21e2e90c85cd62c058800.zip
- Update to 2.16.8
- Unbreak PR: ports/78195 Submitted by: TAKATSU Tomonari <tota@rtfm.jp> (maintainer)
Notes
Notes: svn path=/head/; revision=130223
-rw-r--r--japanese/bugzilla/Makefile124
-rw-r--r--japanese/bugzilla/distinfo8
-rw-r--r--japanese/bugzilla/files/patch-checksetup.pl11
-rw-r--r--japanese/bugzilla/files/patch-runtests.sh8
-rw-r--r--japanese/bugzilla/files/patch-t-002goodperl.t11
-rw-r--r--japanese/bugzilla/pkg-descr22
-rw-r--r--japanese/bugzilla/pkg-message23
-rw-r--r--japanese/bugzilla/pkg-plist4
-rw-r--r--japanese/bugzilla3/Makefile124
-rw-r--r--japanese/bugzilla3/distinfo8
-rw-r--r--japanese/bugzilla3/files/patch-checksetup.pl11
-rw-r--r--japanese/bugzilla3/files/patch-runtests.sh8
-rw-r--r--japanese/bugzilla3/files/patch-t-002goodperl.t11
-rw-r--r--japanese/bugzilla3/pkg-descr22
-rw-r--r--japanese/bugzilla3/pkg-message23
-rw-r--r--japanese/bugzilla3/pkg-plist4
16 files changed, 396 insertions, 26 deletions
diff --git a/japanese/bugzilla/Makefile b/japanese/bugzilla/Makefile
index 05560c7a5e0f..5af44ebf4809 100644
--- a/japanese/bugzilla/Makefile
+++ b/japanese/bugzilla/Makefile
@@ -6,23 +6,131 @@
#
PORTNAME= bugzilla
-PORTVERSION= 2.16.6
+PORTVERSION= 2.16.8
CATEGORIES= japanese devel
+MASTER_SITES= ${MASTER_SITE_MOZILLA}
+MASTER_SITE_SUBDIR= webtools webtools/archived
PATCH_SITES= http://hp.vector.co.jp/authors/VA013241/webapp/bugzilla/
-PATCHFILES= ${PORTNAME}-${PORTVERSION}-to-${PORTNAME}-${PORTVERSION}-ja-${PATCHVERSION}.diff.gz
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-to-${PORTVERSION}-ja-${PATCHVERSION}.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= tota@rtfm.jp
COMMENT= Bug-tracking system with Japanese patch
-BROKEN= does not work with bugzilla-2.18 masterport
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql \
+ ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap
+
+.if !defined(WITHOUT_BUG_CHARTING_MODULES)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
+ ${SITE_PERL}/Chart/Base.pm:${PORTSDIR}/graphics/p5-chart
+.endif
+
+.if defined(WITH_BUG_MAILING_MODULES)
+RUN_DEPENDS+= ${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools
+.endif
+
+.if defined(WITH_BUG_EXPORT_AND_IMPORT)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+.endif
CONFLICTS= bugzilla-2.*
-PATCHVERSION= 20040714
+PATCHVERSION= 20050218
+
+.if defined(WITH_CONTRIB)
+PLIST_SUB+= CONTRIB=""
+.else
+PLIST_SUB+= CONTRIB="@comment "
+.endif
+
+USE_REINPLACE= yes
+
+NO_BUILD= yes
+BINMODE= 700
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+BUGZILLADIR?= www/data/bugzilla
+BUGZILLADOCS= html images txt rel_notes.txt
+BONSAIPERLWC= *.cgi *.pl *.pm processmail syncshadowdb contrib/*.pl
+SENDMAILWC= *.pl *.pm processmail contrib/*.pl
+
+PLIST_SUB+= BUGZILLADIR=${BUGZILLADIR}
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_BUG_CHARTING_MODULES do not install perl modules required for bug"
+ @${ECHO_MSG} " charting support"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_BUG_MAILING_MODULES install perl modules required for bug mailing"
+ @${ECHO_MSG} " support (contrib/bug_email.pl) interface"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_BUG_EXPORT_AND_IMPORT install perl modules required for bug"
+ @${ECHO_MSG} " export/import feature to move bugs to or from"
+ @${ECHO_MSG} " other bugzilla installations"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_CONTRIB to install various user-contributed scripts,"
+ @${ECHO_MSG} " e.g. to import bugs from other databases, to"
+ @${ECHO_MSG} " allow follow-ups/submissions by e-mail etc."
+ @${ECHO_MSG} ""
+
+post-patch:
+ @${FIND} -d ${WRKSRC} -name CVS -type d -exec ${RM} -rf {} \;
+ @${FIND} -d ${WRKSRC} -name sgml -type d -exec ${RM} -rf {} \;
+ @${FIND} ${WRKSRC} -name .cvsignore -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
+.for i in ${BONSAIPERLWC}
+ @${REINPLACE_CMD} -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
+ ${WRKSRC}/$i
+.endfor
+.for i in ${SENDMAILWC}
+ @${REINPLACE_CMD} -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
+ ${WRKSRC}/$i
+.endfor
+ @${FIND} ${WRKSRC} -name \*.bak -type f -exec ${RM} -f {} \;
+
+pre-install:
+ @${FIND} ${WRKSRC}/docs -type d -exec ${CHMOD} 755 {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHMOD} ${MANMODE} {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHOWN} root:wheel {} \;
+
+do-install:
+ ${MKDIR} ${PREFIX}/${BUGZILLADIR}
+ ${FIND} ${WRKSRC} \! -type d -maxdepth 1 \! -name UPGRADING* -exec \
+ ${INSTALL_SCRIPT} {} ${PREFIX}/${BUGZILLADIR} \;
+ ${TAR} -C ${WRKSRC} -cf - template css | ${TAR} --unlink -C ${PREFIX}/${BUGZILLADIR} -xf -
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${TAR} -C ${WRKSRC}/docs -cf - . | ${TAR} --unlink -C ${DOCSDIR} -xf -
+.endif
+.if defined(WITH_CONTRIB)
+ ${MKDIR} ${PREFIX}/${BUGZILLADIR}/contrib ${PREFIX}/${BUGZILLADIR}/contrib/cmdline
+ cd ${WRKSRC}/contrib; ${INSTALL_SCRIPT} BugzillaEmail.pm bug_email.pl \
+ bugzilla_email_append.pl cvs-update.sh gnats2bz.pl jb2bz.py \
+ mysqld-watcher.pl yp_nomail.sh ${PREFIX}/${BUGZILLADIR}/contrib
+ cd ${WRKSRC}/contrib/cmdline; ${INSTALL_SCRIPT} buglist bugs \
+ query.conf ${PREFIX}/${BUGZILLADIR}/contrib/cmdline
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/contrib
+ cd ${WRKSRC}/contrib; ${INSTALL_DATA} README README.Mailif \
+ bugmail_help.html bugzilla.procmailrc ${DOCSDIR}/contrib
+.endif
+.endif
-MASTERDIR= ${.CURDIR}/../../devel/bugzilla
-MD5_FILE= ${.CURDIR}/distinfo
-PLIST= ${.CURDIR}/pkg-plist
+post-install:
+ @${SED} -e "s:%%PREFIX%%:${PREFIX}:g" \
+ -e "s:%%BUGZILLADIR%%:${BUGZILLADIR}:g" \
+ -e "s:%%PORTDOCS%%:${PORTDOCS}:g" \
+ -e "s:%%DOCSDIR%%:${DOCSDIR}:g" \
+ ${MASTERDIR}/pkg-message >${PKGMESSAGE}
+.if !defined(BATCH)
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+.endif
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>
diff --git a/japanese/bugzilla/distinfo b/japanese/bugzilla/distinfo
index 57b0ee865c14..a338d08c3bb5 100644
--- a/japanese/bugzilla/distinfo
+++ b/japanese/bugzilla/distinfo
@@ -1,4 +1,4 @@
-MD5 (bugzilla-2.16.6.tar.gz) = 5b694df8739be175f0358507f844b71d
-SIZE (bugzilla-2.16.6.tar.gz) = 1365080
-MD5 (bugzilla-2.16.6-to-bugzilla-2.16.6-ja-20040714.diff.gz) = 7882c3073b89312ced1847a4e265c5fa
-SIZE (bugzilla-2.16.6-to-bugzilla-2.16.6-ja-20040714.diff.gz) = 170046
+MD5 (bugzilla-2.16.8.tar.gz) = 192cf7daa231a9e162a688aeebfc873c
+SIZE (bugzilla-2.16.8.tar.gz) = 1735613
+MD5 (bugzilla-2.16.8-to-2.16.8-ja-20050218.diff.gz) = 5b4610883b8a6bcac11afc0feff98ded
+SIZE (bugzilla-2.16.8-to-2.16.8-ja-20050218.diff.gz) = 170881
diff --git a/japanese/bugzilla/files/patch-checksetup.pl b/japanese/bugzilla/files/patch-checksetup.pl
new file mode 100644
index 000000000000..a038caf18402
--- /dev/null
+++ b/japanese/bugzilla/files/patch-checksetup.pl
@@ -0,0 +1,11 @@
+--- checksetup.pl~ Fri Apr 16 02:48:51 2004
++++ checksetup.pl Thu Jul 15 23:37:09 2004
+@@ -399,7 +399,7 @@
+ # and you cannot set this up any other way. YOU HAVE BEEN WARNED.
+ # If you set this to anything besides "", you will need to run checksetup.pl
+ # as root, or as a user who is a member of the specified group.
+-$webservergroup = "apache";
++$webservergroup = "www";
+ ');
+
+
diff --git a/japanese/bugzilla/files/patch-runtests.sh b/japanese/bugzilla/files/patch-runtests.sh
new file mode 100644
index 000000000000..5ccf3dbeeef0
--- /dev/null
+++ b/japanese/bugzilla/files/patch-runtests.sh
@@ -0,0 +1,8 @@
+--- runtests.sh~ Tue Jan 8 12:58:39 2002
++++ runtests.sh Tue Jan 8 12:58:47 2002
+@@ -9,4 +9,4 @@
+ fi
+ done
+
+-/usr/bonsaitools/bin/perl -e "${PART1}${TEST_VERBOSE}${PART2}" t/*.t
++/usr/bin/perl -e "${PART1}${TEST_VERBOSE}${PART2}" t/*.t
diff --git a/japanese/bugzilla/files/patch-t-002goodperl.t b/japanese/bugzilla/files/patch-t-002goodperl.t
new file mode 100644
index 000000000000..cf9fe9e930ce
--- /dev/null
+++ b/japanese/bugzilla/files/patch-t-002goodperl.t
@@ -0,0 +1,11 @@
+--- t/002goodperl.t~ Mon Feb 3 20:29:23 2003
++++ t/002goodperl.t Mon Feb 3 20:29:37 2003
+@@ -60,7 +60,7 @@
+ $file =~ m/.*\.(.*)/;
+ my $ext = $1;
+
+- if ($file_line1 !~ /\/usr\/bonsaitools\/bin\/perl/) {
++ if ($file_line1 !~ /\/usr\/bin\/perl/) {
+ ok(1,"$file does not have a shebang");
+ } else {
+ my $flags;
diff --git a/japanese/bugzilla/pkg-descr b/japanese/bugzilla/pkg-descr
new file mode 100644
index 000000000000..f4b9cfcf388e
--- /dev/null
+++ b/japanese/bugzilla/pkg-descr
@@ -0,0 +1,22 @@
+Bugzilla is one example of a class of programs called "Defect Tracking
+Systems", or, more commonly, "Bug-Tracking Systems". Defect Tracking
+Systems allow individual or groups of developers to keep track of
+outstanding bugs in their product effectively.
+
+Bugzilla has matured immensely, and now boasts many advanced features.
+These include:
+
+ * integrated, product-based granular security schema
+ * inter-bug dependencies and dependency graphing
+ * advanced reporting capabilities
+ * a robust, stable RDBMS back-end
+ * extensive configurability
+ * a very well-understood and well-thought-out natural bug resolution
+ protocol
+ * email, XML, console, and HTTP APIs
+ * available integration with automated software configuration
+ management systems, including Perforce and CVS (through the
+ Bugzilla email interface and checkin/checkout scripts)
+ * too many more features to list
+
+WWW: http://www.mozilla.org/projects/bugzilla/
diff --git a/japanese/bugzilla/pkg-message b/japanese/bugzilla/pkg-message
new file mode 100644
index 000000000000..0474ba8f11ec
--- /dev/null
+++ b/japanese/bugzilla/pkg-message
@@ -0,0 +1,23 @@
+==========================================================================
+ Bugzilla has now been installed. To quick setup you have to:
+
+ 1. Create database user who has rights on bugs database manipulation
+ by following mysql commands:
+
+ GRANT SELECT,INSERT,UPDATE,DELETE,INDEX,ALTER,CREATE,DROP,REFERENCES,\
+ LOCK TABLES ON <database>.* TO <dbuser>@<host> \
+ IDENTIFIED BY '<password>';
+ FLUSH PRIVILEGES;
+
+ where <database> is a bugs database name; <dbuser> is a bugs database
+ owner; <host> is a host there bugzilla is being setup;
+ <password> is a database owner's password;
+
+ 2. Change working directory to %%PREFIX%%/%%BUGZILLADIR%%
+ 3. Run "./checksetup.pl" script as root user
+ 4. Read output carefully and follow all instructions
+
+ For more complete database setup and post-installation instructions
+ and security tips/notes please read Bugzilla Guide in
+ %%PORTDOCS%%%%DOCSDIR%% (chapter 4: Installation)
+==========================================================================
diff --git a/japanese/bugzilla/pkg-plist b/japanese/bugzilla/pkg-plist
index cf5e3a2ff68b..70512c6bfcfc 100644
--- a/japanese/bugzilla/pkg-plist
+++ b/japanese/bugzilla/pkg-plist
@@ -58,9 +58,11 @@
%%PORTDOCS%%%%DOCSDIR%%/html/whatis.html
%%PORTDOCS%%%%DOCSDIR%%/html/why.html
%%PORTDOCS%%%%DOCSDIR%%/html/win32.html
+%%PORTDOCS%%%%DOCSDIR%%/images/bzLifecycle.png
+%%PORTDOCS%%%%DOCSDIR%%/images/bzLifecycle.xml
%%PORTDOCS%%%%DOCSDIR%%/images/caution.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/dbschema.cdr
%%PORTDOCS%%%%DOCSDIR%%/images/dbschema.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/dbschema.ps
%%PORTDOCS%%%%DOCSDIR%%/images/note.gif
%%PORTDOCS%%%%DOCSDIR%%/images/tip.gif
%%PORTDOCS%%%%DOCSDIR%%/images/warning.gif
diff --git a/japanese/bugzilla3/Makefile b/japanese/bugzilla3/Makefile
index 05560c7a5e0f..5af44ebf4809 100644
--- a/japanese/bugzilla3/Makefile
+++ b/japanese/bugzilla3/Makefile
@@ -6,23 +6,131 @@
#
PORTNAME= bugzilla
-PORTVERSION= 2.16.6
+PORTVERSION= 2.16.8
CATEGORIES= japanese devel
+MASTER_SITES= ${MASTER_SITE_MOZILLA}
+MASTER_SITE_SUBDIR= webtools webtools/archived
PATCH_SITES= http://hp.vector.co.jp/authors/VA013241/webapp/bugzilla/
-PATCHFILES= ${PORTNAME}-${PORTVERSION}-to-${PORTNAME}-${PORTVERSION}-ja-${PATCHVERSION}.diff.gz
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-to-${PORTVERSION}-ja-${PATCHVERSION}.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= tota@rtfm.jp
COMMENT= Bug-tracking system with Japanese patch
-BROKEN= does not work with bugzilla-2.18 masterport
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql \
+ ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap
+
+.if !defined(WITHOUT_BUG_CHARTING_MODULES)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
+ ${SITE_PERL}/Chart/Base.pm:${PORTSDIR}/graphics/p5-chart
+.endif
+
+.if defined(WITH_BUG_MAILING_MODULES)
+RUN_DEPENDS+= ${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools
+.endif
+
+.if defined(WITH_BUG_EXPORT_AND_IMPORT)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+.endif
CONFLICTS= bugzilla-2.*
-PATCHVERSION= 20040714
+PATCHVERSION= 20050218
+
+.if defined(WITH_CONTRIB)
+PLIST_SUB+= CONTRIB=""
+.else
+PLIST_SUB+= CONTRIB="@comment "
+.endif
+
+USE_REINPLACE= yes
+
+NO_BUILD= yes
+BINMODE= 700
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+BUGZILLADIR?= www/data/bugzilla
+BUGZILLADOCS= html images txt rel_notes.txt
+BONSAIPERLWC= *.cgi *.pl *.pm processmail syncshadowdb contrib/*.pl
+SENDMAILWC= *.pl *.pm processmail contrib/*.pl
+
+PLIST_SUB+= BUGZILLADIR=${BUGZILLADIR}
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_BUG_CHARTING_MODULES do not install perl modules required for bug"
+ @${ECHO_MSG} " charting support"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_BUG_MAILING_MODULES install perl modules required for bug mailing"
+ @${ECHO_MSG} " support (contrib/bug_email.pl) interface"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_BUG_EXPORT_AND_IMPORT install perl modules required for bug"
+ @${ECHO_MSG} " export/import feature to move bugs to or from"
+ @${ECHO_MSG} " other bugzilla installations"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_CONTRIB to install various user-contributed scripts,"
+ @${ECHO_MSG} " e.g. to import bugs from other databases, to"
+ @${ECHO_MSG} " allow follow-ups/submissions by e-mail etc."
+ @${ECHO_MSG} ""
+
+post-patch:
+ @${FIND} -d ${WRKSRC} -name CVS -type d -exec ${RM} -rf {} \;
+ @${FIND} -d ${WRKSRC} -name sgml -type d -exec ${RM} -rf {} \;
+ @${FIND} ${WRKSRC} -name .cvsignore -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
+.for i in ${BONSAIPERLWC}
+ @${REINPLACE_CMD} -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
+ ${WRKSRC}/$i
+.endfor
+.for i in ${SENDMAILWC}
+ @${REINPLACE_CMD} -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
+ ${WRKSRC}/$i
+.endfor
+ @${FIND} ${WRKSRC} -name \*.bak -type f -exec ${RM} -f {} \;
+
+pre-install:
+ @${FIND} ${WRKSRC}/docs -type d -exec ${CHMOD} 755 {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHMOD} ${MANMODE} {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHOWN} root:wheel {} \;
+
+do-install:
+ ${MKDIR} ${PREFIX}/${BUGZILLADIR}
+ ${FIND} ${WRKSRC} \! -type d -maxdepth 1 \! -name UPGRADING* -exec \
+ ${INSTALL_SCRIPT} {} ${PREFIX}/${BUGZILLADIR} \;
+ ${TAR} -C ${WRKSRC} -cf - template css | ${TAR} --unlink -C ${PREFIX}/${BUGZILLADIR} -xf -
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${TAR} -C ${WRKSRC}/docs -cf - . | ${TAR} --unlink -C ${DOCSDIR} -xf -
+.endif
+.if defined(WITH_CONTRIB)
+ ${MKDIR} ${PREFIX}/${BUGZILLADIR}/contrib ${PREFIX}/${BUGZILLADIR}/contrib/cmdline
+ cd ${WRKSRC}/contrib; ${INSTALL_SCRIPT} BugzillaEmail.pm bug_email.pl \
+ bugzilla_email_append.pl cvs-update.sh gnats2bz.pl jb2bz.py \
+ mysqld-watcher.pl yp_nomail.sh ${PREFIX}/${BUGZILLADIR}/contrib
+ cd ${WRKSRC}/contrib/cmdline; ${INSTALL_SCRIPT} buglist bugs \
+ query.conf ${PREFIX}/${BUGZILLADIR}/contrib/cmdline
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/contrib
+ cd ${WRKSRC}/contrib; ${INSTALL_DATA} README README.Mailif \
+ bugmail_help.html bugzilla.procmailrc ${DOCSDIR}/contrib
+.endif
+.endif
-MASTERDIR= ${.CURDIR}/../../devel/bugzilla
-MD5_FILE= ${.CURDIR}/distinfo
-PLIST= ${.CURDIR}/pkg-plist
+post-install:
+ @${SED} -e "s:%%PREFIX%%:${PREFIX}:g" \
+ -e "s:%%BUGZILLADIR%%:${BUGZILLADIR}:g" \
+ -e "s:%%PORTDOCS%%:${PORTDOCS}:g" \
+ -e "s:%%DOCSDIR%%:${DOCSDIR}:g" \
+ ${MASTERDIR}/pkg-message >${PKGMESSAGE}
+.if !defined(BATCH)
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+.endif
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>
diff --git a/japanese/bugzilla3/distinfo b/japanese/bugzilla3/distinfo
index 57b0ee865c14..a338d08c3bb5 100644
--- a/japanese/bugzilla3/distinfo
+++ b/japanese/bugzilla3/distinfo
@@ -1,4 +1,4 @@
-MD5 (bugzilla-2.16.6.tar.gz) = 5b694df8739be175f0358507f844b71d
-SIZE (bugzilla-2.16.6.tar.gz) = 1365080
-MD5 (bugzilla-2.16.6-to-bugzilla-2.16.6-ja-20040714.diff.gz) = 7882c3073b89312ced1847a4e265c5fa
-SIZE (bugzilla-2.16.6-to-bugzilla-2.16.6-ja-20040714.diff.gz) = 170046
+MD5 (bugzilla-2.16.8.tar.gz) = 192cf7daa231a9e162a688aeebfc873c
+SIZE (bugzilla-2.16.8.tar.gz) = 1735613
+MD5 (bugzilla-2.16.8-to-2.16.8-ja-20050218.diff.gz) = 5b4610883b8a6bcac11afc0feff98ded
+SIZE (bugzilla-2.16.8-to-2.16.8-ja-20050218.diff.gz) = 170881
diff --git a/japanese/bugzilla3/files/patch-checksetup.pl b/japanese/bugzilla3/files/patch-checksetup.pl
new file mode 100644
index 000000000000..a038caf18402
--- /dev/null
+++ b/japanese/bugzilla3/files/patch-checksetup.pl
@@ -0,0 +1,11 @@
+--- checksetup.pl~ Fri Apr 16 02:48:51 2004
++++ checksetup.pl Thu Jul 15 23:37:09 2004
+@@ -399,7 +399,7 @@
+ # and you cannot set this up any other way. YOU HAVE BEEN WARNED.
+ # If you set this to anything besides "", you will need to run checksetup.pl
+ # as root, or as a user who is a member of the specified group.
+-$webservergroup = "apache";
++$webservergroup = "www";
+ ');
+
+
diff --git a/japanese/bugzilla3/files/patch-runtests.sh b/japanese/bugzilla3/files/patch-runtests.sh
new file mode 100644
index 000000000000..5ccf3dbeeef0
--- /dev/null
+++ b/japanese/bugzilla3/files/patch-runtests.sh
@@ -0,0 +1,8 @@
+--- runtests.sh~ Tue Jan 8 12:58:39 2002
++++ runtests.sh Tue Jan 8 12:58:47 2002
+@@ -9,4 +9,4 @@
+ fi
+ done
+
+-/usr/bonsaitools/bin/perl -e "${PART1}${TEST_VERBOSE}${PART2}" t/*.t
++/usr/bin/perl -e "${PART1}${TEST_VERBOSE}${PART2}" t/*.t
diff --git a/japanese/bugzilla3/files/patch-t-002goodperl.t b/japanese/bugzilla3/files/patch-t-002goodperl.t
new file mode 100644
index 000000000000..cf9fe9e930ce
--- /dev/null
+++ b/japanese/bugzilla3/files/patch-t-002goodperl.t
@@ -0,0 +1,11 @@
+--- t/002goodperl.t~ Mon Feb 3 20:29:23 2003
++++ t/002goodperl.t Mon Feb 3 20:29:37 2003
+@@ -60,7 +60,7 @@
+ $file =~ m/.*\.(.*)/;
+ my $ext = $1;
+
+- if ($file_line1 !~ /\/usr\/bonsaitools\/bin\/perl/) {
++ if ($file_line1 !~ /\/usr\/bin\/perl/) {
+ ok(1,"$file does not have a shebang");
+ } else {
+ my $flags;
diff --git a/japanese/bugzilla3/pkg-descr b/japanese/bugzilla3/pkg-descr
new file mode 100644
index 000000000000..f4b9cfcf388e
--- /dev/null
+++ b/japanese/bugzilla3/pkg-descr
@@ -0,0 +1,22 @@
+Bugzilla is one example of a class of programs called "Defect Tracking
+Systems", or, more commonly, "Bug-Tracking Systems". Defect Tracking
+Systems allow individual or groups of developers to keep track of
+outstanding bugs in their product effectively.
+
+Bugzilla has matured immensely, and now boasts many advanced features.
+These include:
+
+ * integrated, product-based granular security schema
+ * inter-bug dependencies and dependency graphing
+ * advanced reporting capabilities
+ * a robust, stable RDBMS back-end
+ * extensive configurability
+ * a very well-understood and well-thought-out natural bug resolution
+ protocol
+ * email, XML, console, and HTTP APIs
+ * available integration with automated software configuration
+ management systems, including Perforce and CVS (through the
+ Bugzilla email interface and checkin/checkout scripts)
+ * too many more features to list
+
+WWW: http://www.mozilla.org/projects/bugzilla/
diff --git a/japanese/bugzilla3/pkg-message b/japanese/bugzilla3/pkg-message
new file mode 100644
index 000000000000..0474ba8f11ec
--- /dev/null
+++ b/japanese/bugzilla3/pkg-message
@@ -0,0 +1,23 @@
+==========================================================================
+ Bugzilla has now been installed. To quick setup you have to:
+
+ 1. Create database user who has rights on bugs database manipulation
+ by following mysql commands:
+
+ GRANT SELECT,INSERT,UPDATE,DELETE,INDEX,ALTER,CREATE,DROP,REFERENCES,\
+ LOCK TABLES ON <database>.* TO <dbuser>@<host> \
+ IDENTIFIED BY '<password>';
+ FLUSH PRIVILEGES;
+
+ where <database> is a bugs database name; <dbuser> is a bugs database
+ owner; <host> is a host there bugzilla is being setup;
+ <password> is a database owner's password;
+
+ 2. Change working directory to %%PREFIX%%/%%BUGZILLADIR%%
+ 3. Run "./checksetup.pl" script as root user
+ 4. Read output carefully and follow all instructions
+
+ For more complete database setup and post-installation instructions
+ and security tips/notes please read Bugzilla Guide in
+ %%PORTDOCS%%%%DOCSDIR%% (chapter 4: Installation)
+==========================================================================
diff --git a/japanese/bugzilla3/pkg-plist b/japanese/bugzilla3/pkg-plist
index cf5e3a2ff68b..70512c6bfcfc 100644
--- a/japanese/bugzilla3/pkg-plist
+++ b/japanese/bugzilla3/pkg-plist
@@ -58,9 +58,11 @@
%%PORTDOCS%%%%DOCSDIR%%/html/whatis.html
%%PORTDOCS%%%%DOCSDIR%%/html/why.html
%%PORTDOCS%%%%DOCSDIR%%/html/win32.html
+%%PORTDOCS%%%%DOCSDIR%%/images/bzLifecycle.png
+%%PORTDOCS%%%%DOCSDIR%%/images/bzLifecycle.xml
%%PORTDOCS%%%%DOCSDIR%%/images/caution.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/dbschema.cdr
%%PORTDOCS%%%%DOCSDIR%%/images/dbschema.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/dbschema.ps
%%PORTDOCS%%%%DOCSDIR%%/images/note.gif
%%PORTDOCS%%%%DOCSDIR%%/images/tip.gif
%%PORTDOCS%%%%DOCSDIR%%/images/warning.gif