aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2012-11-09 16:35:17 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2012-11-09 16:35:17 +0000
commitd3bdefafbdee2b705f7095833b25c793fe1ae683 (patch)
treee5de205067ca8d5e285477d449f8b6f627254f73
parentfd70e187404fcc5973c912ca53b60a6f4f4a520a (diff)
downloadports-d3bdefafbdee2b705f7095833b25c793fe1ae683.tar.gz
ports-d3bdefafbdee2b705f7095833b25c793fe1ae683.zip
MFH r307206
- fix NLS support, which was wired backwards - actually enable NLS in OPTIONS - change LOCALBASE to PREFIX, as it was attempting to create a directory in one, and then install a file into another - this fixes package building Feature safe: yes Approved by: portmgr
Notes
Notes: svn path=/branches/RELENG_9_1_0/; revision=307242
-rw-r--r--textproc/bsdgrep/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/textproc/bsdgrep/Makefile b/textproc/bsdgrep/Makefile
index 44d019d5b5f4..28d074570109 100644
--- a/textproc/bsdgrep/Makefile
+++ b/textproc/bsdgrep/Makefile
@@ -7,6 +7,7 @@
PORTNAME= grep
PORTVERSION= 20111002
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= gabor
@@ -37,7 +38,7 @@ MAKE_ENV+= BINDIR="${PREFIX}/bin" \
CATDIR="${MANPREFIX}/man/man" \
NLSDIR="${PREFIX}/share/nls"
-OPTIONS_DEFINE= GNU_COMPAT
+OPTIONS_DEFINE= GNU_COMPAT NLS
OPTIONS_DEFAULT= GNU_COMPAT
GNU_COMPAT_DESC= Use GNU regex library (recommended)
@@ -47,16 +48,16 @@ CONFLICTS= gnugrep-*
.if !(${OSVERSION} >= 900012 || (${OSVERSION} < 900000 && ${OSVERSION} >= 800505))
LIB_DEPENDS+= lzma.5:${PORTSDIR}/archivers/xz
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${PREFIX}/include
+LDFLAGS+= -L${PREFIX}/lib
BROKEN= overwrites files installed by dependency
.endif
.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB+= NLS=""
+.else
MAKE_ENV+= WITHOUT_NLS=yes
PLIST_SUB+= NLS="@comment "
-.else
-PLIST_SUB+= NLS=""
.endif
.if !${PORT_OPTIONS:MGNU_COMPAT}
@@ -65,7 +66,7 @@ MAKE_ENV+= WITHOUT_GNU_COMPAT=yes
pre-install:
.if ${PORT_OPTIONS:MNLS}
- ${MKDIR} ${LOCALBASE}/share/nls/gl_ES.ISO8859-1
+ ${MKDIR} ${PREFIX}/share/nls/gl_ES.ISO8859-1
.endif
post-install: