aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-03-29 12:40:44 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-03-31 10:42:06 +0000
commit00125cc731aa270cca04f4afda664c7010bd083f (patch)
treedd596645fe80b8f2725b788c8774a3c79a0047b9
parentf9070c1280f387a33d67a56a77e32237ceb6123c (diff)
downloadports-00125cc731aa270cca04f4afda664c7010bd083f.tar.gz
ports-00125cc731aa270cca04f4afda664c7010bd083f.zip
graphics/pywal: new port
Pywal is a tool that generates a color palette from the dominant colors in an image. It then applies the colors system-wide and on-the-fly in all of your favourite programs. There are currently 5 supported color generation backends, each providing a different palette of colors from each image. You're bound to find an appealing color-scheme. Pywal also supports predefined themes and has over 250 themes built-in. You can also create your own theme files to share with others. The goal of Pywal was to be as out of the way as possible. It doesn't modify any of your existing configuration files. Instead it works around them and provides tools to integrate your system as you see fit. Terminal emulators and TTYs have their color-schemes updated in real-time with no delay. With minimal configuration this functionality can be extended to almost anything running on your system. WWW: https://github.com/dylanaraps/pywal Requested by: reddit user /u/twllnbrck
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pywal/Makefile19
-rw-r--r--graphics/pywal/distinfo3
-rw-r--r--graphics/pywal/files/patch-pywal_util.py11
-rw-r--r--graphics/pywal/pkg-descr18
5 files changed, 52 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b43147fdb622..0fcd0037c0fa 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -963,6 +963,7 @@
SUBDIR += py-willow
SUBDIR += py-yaswfp
SUBDIR += py-zbar-py
+ SUBDIR += pywal
SUBDIR += qcomicbook
SUBDIR += qcustomplot-qt5
SUBDIR += qgis
diff --git a/graphics/pywal/Makefile b/graphics/pywal/Makefile
new file mode 100644
index 000000000000..a66fcb08438a
--- /dev/null
+++ b/graphics/pywal/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= pywal
+DISTVERSION= 3.3.0
+CATEGORIES= graphics
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= fuz@fuz.su
+COMMENT= Generate and change color-schemes on the fly
+WWW= https://github.com/dylanaraps/pywal
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= magick:run python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/pywal/distinfo b/graphics/pywal/distinfo
new file mode 100644
index 000000000000..fe1dd02ba369
--- /dev/null
+++ b/graphics/pywal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1680089939
+SHA256 (pywal-3.3.0.tar.gz) = efeab992c2702c7e07529ac9757425862ea1796a6fc0331148bc45a8675230b7
+SIZE (pywal-3.3.0.tar.gz) = 61269
diff --git a/graphics/pywal/files/patch-pywal_util.py b/graphics/pywal/files/patch-pywal_util.py
new file mode 100644
index 000000000000..348e80a2eacf
--- /dev/null
+++ b/graphics/pywal/files/patch-pywal_util.py
@@ -0,0 +1,11 @@
+--- pywal/util.py.orig 2023-03-29 11:39:40 UTC
++++ pywal/util.py
+@@ -179,7 +179,7 @@ def disown(cmd):
+ def get_pid(name):
+ """Check if process is running by name."""
+ try:
+- subprocess.check_output(["pidof", "-s", name])
++ subprocess.check_output(["pgrep", "-x", name])
+ except subprocess.CalledProcessError:
+ return False
+
diff --git a/graphics/pywal/pkg-descr b/graphics/pywal/pkg-descr
new file mode 100644
index 000000000000..4dd43fb18988
--- /dev/null
+++ b/graphics/pywal/pkg-descr
@@ -0,0 +1,18 @@
+Pywal is a tool that generates a color palette from the dominant colors
+in an image. It then applies the colors system-wide and on-the-fly in
+all of your favourite programs.
+
+There are currently 5 supported color generation backends, each
+providing a different palette of colors from each image. You're bound to
+find an appealing color-scheme.
+
+Pywal also supports predefined themes and has over 250 themes built-in.
+You can also create your own theme files to share with others.
+
+The goal of Pywal was to be as out of the way as possible. It doesn't
+modify any of your existing configuration files. Instead it works around
+them and provides tools to integrate your system as you see fit.
+
+Terminal emulators and TTYs have their color-schemes updated in
+real-time with no delay. With minimal configuration this functionality
+can be extended to almost anything running on your system.