aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:12 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:12 +0000
commit0031b7e8267eab8f7666960b8defa59504a63d78 (patch)
tree37737d842540750989dadf58c41885baba90797e
parentd5a61409299b42aa43542d289a1af15dadd6fd60 (diff)
downloadports-0031b7e8267eab8f7666960b8defa59504a63d78.tar.gz
ports-0031b7e8267eab8f7666960b8defa59504a63d78.zip
devel/py-xstatic-jquery.tablesorter: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--devel/py-xstatic-jquery.tablesorter/Makefile7
-rw-r--r--devel/py-xstatic-jquery.tablesorter/files/patch-setup.py11
2 files changed, 16 insertions, 2 deletions
diff --git a/devel/py-xstatic-jquery.tablesorter/Makefile b/devel/py-xstatic-jquery.tablesorter/Makefile
index d2e0e2c3091c..5b2f9c10face 100644
--- a/devel/py-xstatic-jquery.tablesorter/Makefile
+++ b/devel/py-xstatic-jquery.tablesorter/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xstatic-jquery.tablesorter
PORTVERSION= 2.14.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,8 +14,11 @@ WWW= https://github.com/openstack/xstatic-jquery.tablesorter \
LICENSE= GPLv2 MIT
LICENSE_COMB= dual
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/devel/py-xstatic-jquery.tablesorter/files/patch-setup.py b/devel/py-xstatic-jquery.tablesorter/files/patch-setup.py
new file mode 100644
index 000000000000..593bb2bba729
--- /dev/null
+++ b/devel/py-xstatic-jquery.tablesorter/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2020-04-09 21:08:35 UTC
++++ setup.py
+@@ -7,7 +7,7 @@ setup(
+ from setuptools import setup, find_packages
+
+ setup(
+- name=xs.PACKAGE_NAME,
++ name='xstatic-jquery.tablesorter',
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,