aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-11-29 20:39:34 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-11-29 20:39:34 +0000
commit0065d33851dcecefcb57fe727621cf36cfed751d (patch)
treed2a8210afb734a8a93451736798b388c27b2a54b
parent2aa38a6e2d7a8f290c64471a91931d7f488f7452 (diff)
downloadports-0065d33851dcecefcb57fe727621cf36cfed751d.tar.gz
ports-0065d33851dcecefcb57fe727621cf36cfed751d.zip
devel/mercurial: Fix build with NLS option turned off
-rw-r--r--devel/mercurial/files/extra-patch-setup.py19
1 files changed, 13 insertions, 6 deletions
diff --git a/devel/mercurial/files/extra-patch-setup.py b/devel/mercurial/files/extra-patch-setup.py
index ddb389b7523a..fc8a62f9e36e 100644
--- a/devel/mercurial/files/extra-patch-setup.py
+++ b/devel/mercurial/files/extra-patch-setup.py
@@ -1,20 +1,26 @@
---- setup.py.orig 2020-08-03 17:43:51 UTC
+--- setup.py.orig 2024-11-20 14:38:51 UTC
+++ setup.py
-@@ -477,32 +477,7 @@ class hgbuildmo(build):
- description = "build translations (.mo files)"
+@@ -527,39 +527,7 @@ class hgbuildmo(build):
+ raise DistutilsExecError("failed to build translations")
- def run(self):
+ def _run(self):
+- try:
+- from shutil import which as find_executable
+- except ImportError:
+- # Deprecated in py3.12
+- from distutils.spawn import find_executable
+-
- if not find_executable('msgfmt'):
- self.warn(
- "could not find msgfmt executable, no translations "
- "will be built"
- )
-- return
+- return False
-
- podir = 'i18n'
- if not os.path.isdir(podir):
- self.warn("could not find %s/ directory" % podir)
-- return
+- return False
-
- join = os.path.join
- for po in os.listdir(podir):
@@ -30,6 +36,7 @@
- cmd.append('-c')
- self.mkpath(join('mercurial', modir))
- self.make_file([pofile], mobuildfile, spawn, (cmd,))
+- return True
+ pass