aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2024-08-21 02:58:25 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2024-08-21 03:00:16 +0000
commit00dc54ae758df0dc3922b51e44b90a2777929101 (patch)
tree667ce22eb8c06c2372b2eadd28afea4bcfc21095
parent8a4b6d801f097d2e5b67ddabc1127f794a8bfb2a (diff)
downloadports-00dc54ae758df0dc3922b51e44b90a2777929101.tar.gz
ports-00dc54ae758df0dc3922b51e44b90a2777929101.zip
sysutils/azure-agent: Fix run with python 3.10+
Approved by: maintainer (implicitly) Sponsored by: The FreeBSD Foundation (cherry picked from commit 602d71fcad4232f54aca4bacac6426636a61687c)
-rw-r--r--sysutils/azure-agent/Makefile1
-rw-r--r--sysutils/azure-agent/files/patch-azurelinuxagent_common_utils_textutil.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/azure-agent/Makefile b/sysutils/azure-agent/Makefile
index 787a272579ef..d87378886662 100644
--- a/sysutils/azure-agent/Makefile
+++ b/sysutils/azure-agent/Makefile
@@ -1,5 +1,6 @@
PORTNAME= azure-agent
PORTVERSION= 2.8.0.11
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
diff --git a/sysutils/azure-agent/files/patch-azurelinuxagent_common_utils_textutil.py b/sysutils/azure-agent/files/patch-azurelinuxagent_common_utils_textutil.py
new file mode 100644
index 000000000000..259f5a052c59
--- /dev/null
+++ b/sysutils/azure-agent/files/patch-azurelinuxagent_common_utils_textutil.py
@@ -0,0 +1,11 @@
+--- azurelinuxagent/common/utils/textutil.py.orig 2024-08-20 23:23:16 UTC
++++ azurelinuxagent/common/utils/textutil.py
+@@ -445,7 +445,7 @@ def format_exception(exception):
+ if tb is None or (sys.version_info[0] == 2 and e != exception):
+ msg += "[Traceback not available]"
+ else:
+- msg += ''.join(traceback.format_exception(etype=type(exception), value=exception, tb=tb))
++ msg += ''.join(traceback.format_exception(type(exception), value=exception, tb=tb))
+
+ return msg
+