aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-14 17:32:32 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-14 17:32:32 +0000
commit00f9d9aecd769c1822e3b8d05215ad8f2667b936 (patch)
treeb85f32cf6551c89e83cb36c29986cc1bbbe6a7c9
parent32640edbe9c463d371e829e7506c239da9935be2 (diff)
downloadports-00f9d9aecd769c1822e3b8d05215ad8f2667b936.tar.gz
ports-00f9d9aecd769c1822e3b8d05215ad8f2667b936.zip
devel/py-pint-pandas: Add py-pint-pandas 0.2
Pint-Pandas provides pandas support for pint. WWW: https://github.com/hgrecco/pint-pandas
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pint-pandas/Makefile25
-rw-r--r--devel/py-pint-pandas/distinfo3
-rw-r--r--devel/py-pint-pandas/pkg-descr3
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 25499a324eba..cf06f64ae573 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4811,6 +4811,7 @@
SUBDIR += py-pika-pool
SUBDIR += py-pinocchio
SUBDIR += py-pint
+ SUBDIR += py-pint-pandas
SUBDIR += py-pip
SUBDIR += py-pip-api
SUBDIR += py-pip-licenses
diff --git a/devel/py-pint-pandas/Makefile b/devel/py-pint-pandas/Makefile
new file mode 100644
index 000000000000..a3d5bbc6c402
--- /dev/null
+++ b/devel/py-pint-pandas/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pint-pandas
+PORTVERSION= 0.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Pint-Pandas-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Physical quantities module
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pandas>=1.2,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pint>=0.17:devel/py-pint@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pint-pandas/distinfo b/devel/py-pint-pandas/distinfo
new file mode 100644
index 000000000000..b3a708ad077b
--- /dev/null
+++ b/devel/py-pint-pandas/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1622213964
+SHA256 (Pint-Pandas-0.2.tar.gz) = 6f60d2e80ac102e0f94addb9206e0f6cca5ee42f0b7f8930d8c798002e41fa87
+SIZE (Pint-Pandas-0.2.tar.gz) = 26544
diff --git a/devel/py-pint-pandas/pkg-descr b/devel/py-pint-pandas/pkg-descr
new file mode 100644
index 000000000000..57580c51955c
--- /dev/null
+++ b/devel/py-pint-pandas/pkg-descr
@@ -0,0 +1,3 @@
+Pint-Pandas provides pandas support for pint.
+
+WWW: https://github.com/hgrecco/pint-pandas