aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2023-12-16 13:30:33 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2023-12-16 13:34:41 +0000
commit0195d3d92c72b56528e342106ce7358db29e41a4 (patch)
treedcdbe42513ccf2645a050c10969f01cd98b6744c
parent55a2aec8735fdbbd07e1323b936183e79dcef8d2 (diff)
deskutils/nextcloudclient: Update to 3.11.0
Guido made some additional improvements: - Taking advantage of new cmake option to disable webengine - Added options to control integration with KDE and GNOME file managers - Adjusted dependencies, so they more correctly reflect selected options - Fixed the DOCS option - Reordered some variable to adapt to the suggested order (via portclippy) PR: 275671 Reported by: Guido Falsi
-rw-r--r--deskutils/nextcloudclient/Makefile46
-rw-r--r--deskutils/nextcloudclient/distinfo6
-rw-r--r--deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt4
-rw-r--r--deskutils/nextcloudclient/files/patch-src_CMakeLists.txt41
-rw-r--r--deskutils/nextcloudclient/pkg-plist11
5 files changed, 40 insertions, 68 deletions
diff --git a/deskutils/nextcloudclient/Makefile b/deskutils/nextcloudclient/Makefile
index 998964bd916d..35f27866eaff 100644
--- a/deskutils/nextcloudclient/Makefile
+++ b/deskutils/nextcloudclient/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nextcloudclient
-PORTVERSION= 3.10.1
+PORTVERSION= 3.11.0
DISTVERSIONPREFIX= v
CATEGORIES= deskutils
@@ -17,36 +17,48 @@ USES= cmake:noninja compiler:c++14-lang desktop-file-utils gmake \
gnome iconv kde:5 localbase:ldflags pkgconfig qt:5 shared-mime-info \
sqlite ssl
USE_KDE= archive
+USE_LDCONFIG= yes
USE_QT= buildtools:build concurrent core dbus declarative graphicaleffects \
- gui linguist:build location network printsupport qmake:build \
- quickcontrols quickcontrols2 svg webchannel websockets \
- widgets xml
+ gui linguist:build network qmake:build quickcontrols \
+ quickcontrols2 sql svg websockets widgets xml
+
CMAKE_ARGS= -DBUILD_UPDATER:BOOL=OFF \
-DCMAKE_INSTALL_MANDIR:STRING=man \
-DWITH_STACK_PROTECTOR:BOOL=OFF
-USE_LDCONFIG= yes
+
+PLIST_SUB= VERSION=${PORTVERSION}
USE_GITHUB= yes
GH_ACCOUNT= nextcloud
GH_PROJECT= desktop
-#OPTIONS_DEFINE= DEBUG DOCS
-OPTIONS_DEFINE= DEBUG WEBENGINE # DOCS doesn't build currently
+OPTIONS_DEFINE= DOCS DEBUG GNOME KDE WEBENGINE
+OPTIONS_DEFAULT= GNOME
+OPTIONS_DEFAULT_aarch64= WEBENGINE
OPTIONS_DEFAULT_amd64= WEBENGINE
OPTIONS_DEFAULT_i386= WEBENGINE
-OPTIONS_DEFAULT_aarch64= WEBENGINE
+OPTIONS_SUB= yes
+
+KDE_DESC= KDE desktop environment support
WEBENGINE_DESC= Use Webengine to provide web login flow
-#DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx \
-# doxygen:devel/doxygen
-#DOCS_USES= tex
-#DOCS_USE= TEX=dvipsk:build,latex:build
-#DOCS_CMAKE_ON= -DWITH_DOC:BOOL=ON
+DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx \
+ doxygen:devel/doxygen
+DOCS_USES= tex
+DOCS_USE= TEX=dvipsk:build,latex:build
+DOCS_CMAKE_BOOL= WITH_DOC
+DOCS_VARS= PORTDOCS=*
-WEBENGINE_VARS= USE_QT+=webengine
+GNOME_CMAKE_BOOL= BUILD_SHELL_INTEGRATION_NAUTILUS
-PLIST_SUB= VERSION=${PORTVERSION}
+KDE_USES= xorg
+KDE_USE= KDE=completion,config,coreaddons,ecm,jobwidgets,kio,service,solid,widgetsaddons,windowsystem \
+ XORG=x11
+KDE_CMAKE_BOOL= BUILD_SHELL_INTEGRATION_DOLPHIN
+
+WEBENGINE_USE= QT=webchannel,webengine,printsupport,location
+WEBENGINE_CMAKE_BOOL= BUILD_WITH_WEBENGINE
.include <bsd.port.pre.mk>
@@ -58,10 +70,6 @@ post-patch:
@${REINPLACE_CMD} -e \
's|.lst |.lst.sample |' ${WRKSRC}/CMakeLists.txt
-post-patch-WEBENGINE-off:
- @${REINPLACE_CMD} -e '/add_compile_definitions(WITH_WEBENGINE=1)/d' \
- ${WRKSRC}/src/CMakeLists.txt
-
pre-configure:
@(cd ${WRKSRC} && ${CP} -f sync-exclude.lst sync-exclude.lst.sample)
diff --git a/deskutils/nextcloudclient/distinfo b/deskutils/nextcloudclient/distinfo
index aa16e559f0e4..ed9e48a75a21 100644
--- a/deskutils/nextcloudclient/distinfo
+++ b/deskutils/nextcloudclient/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1698434389
-SHA256 (nextcloud-desktop-v3.10.1_GH0.tar.gz) = 11355941f2b2d83a72868c3dd6101ec1968e6cabb67834a0684ba860faedcee4
-SIZE (nextcloud-desktop-v3.10.1_GH0.tar.gz) = 13519993
+TIMESTAMP = 1702381709
+SHA256 (nextcloud-desktop-v3.11.0_GH0.tar.gz) = 75d53751411a7544ed5b9f23c3e71c19a96f4096313d76dad77314c3773319d9
+SIZE (nextcloud-desktop-v3.11.0_GH0.tar.gz) = 13595770
diff --git a/deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt b/deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt
index 7aa57c6e3cb2..9ae0b5e3c0cd 100644
--- a/deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt
+++ b/deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt
@@ -1,11 +1,11 @@
---- doc/CMakeLists.txt.orig 2017-12-20 15:03:02 UTC
+--- doc/CMakeLists.txt.orig 2023-12-11 17:50:46 UTC
+++ doc/CMakeLists.txt
@@ -11,7 +11,7 @@ if(SPHINX_FOUND)
# assets
set(LATEX_LOGO "${CMAKE_CURRENT_SOURCE_DIR}/logo-blue.pdf")
- set(APPLICATION_DOC_DIR "${CMAKE_INSTALL_DOCDIR}/${PACKAGE}")
-+ set(APPLICATION_DOC_DIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/owncloudclient")
++ set(APPLICATION_DOC_DIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/nextcloudclient")
install(DIRECTORY ${SPHINX_HTML_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
install(DIRECTORY ${SPHINX_PDF_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
install(DIRECTORY ${SPHINX_QCH_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
diff --git a/deskutils/nextcloudclient/files/patch-src_CMakeLists.txt b/deskutils/nextcloudclient/files/patch-src_CMakeLists.txt
deleted file mode 100644
index 047f46c2bb70..000000000000
--- a/deskutils/nextcloudclient/files/patch-src_CMakeLists.txt
+++ /dev/null
@@ -1,41 +0,0 @@
---- src/CMakeLists.txt.orig 2023-02-09 20:54:58 UTC
-+++ src/CMakeLists.txt
-@@ -31,30 +31,16 @@ find_package(Qt5WebEngineWidgets ${REQUIRED_QT_VERSION
- )
-
- find_package(Qt5WebEngineWidgets ${REQUIRED_QT_VERSION} CONFIG QUIET)
--if(APPLE)
-- set_package_properties(Qt5WebEngineWidgets PROPERTIES
-- DESCRIPTION "Qt5 WebEngineWidgets component."
-- TYPE RECOMMENDED
-- )
--else()
-- set_package_properties(Qt5WebEngineWidgets PROPERTIES
-- DESCRIPTION "Qt5 WebEngineWidgets component."
-- TYPE REQUIRED
-- )
--endif()
-+set_package_properties(Qt5WebEngineWidgets PROPERTIES
-+ DESCRIPTION "Qt5 WebEngineWidgets component."
-+ TYPE RECOMMENDED
-+)
-
- find_package(Qt5WebEngine ${REQUIRED_QT_VERSION} CONFIG QUIET)
--if(APPLE)
-- set_package_properties(Qt5WebEngine PROPERTIES
-- DESCRIPTION "Qt5 WebEngine component."
-- TYPE RECOMMENDED
-- )
--else()
-- set_package_properties(Qt5WebEngine PROPERTIES
-- DESCRIPTION "Qt5 WebEngine component."
-- TYPE REQUIRED
-- )
--endif()
-+set_package_properties(Qt5WebEngine PROPERTIES
-+ DESCRIPTION "Qt5 WebEngine component."
-+ TYPE RECOMMENDED
-+)
-
- if(Qt5WebEngine_FOUND AND Qt5WebEngineWidgets_FOUND)
- add_compile_definitions(WITH_WEBENGINE=1)
diff --git a/deskutils/nextcloudclient/pkg-plist b/deskutils/nextcloudclient/pkg-plist
index a2ea9ae1e9f7..24afda8b110a 100644
--- a/deskutils/nextcloudclient/pkg-plist
+++ b/deskutils/nextcloudclient/pkg-plist
@@ -13,12 +13,17 @@ include/nextcloudsync/mirall/syncresult.h
lib/libnextcloud_csync.so
lib/libnextcloud_csync.so.0
lib/libnextcloud_csync.so.%%VERSION%%
+%%KDE%%lib/libnextclouddolphinpluginhelper.so
lib/libnextcloudsync.so
lib/libnextcloudsync.so.0
lib/libnextcloudsync.so.%%VERSION%%
lib/nextcloudsync_vfs_suffix.so
+%%DOCS%%man/man1/nextcloud.1.gz
+%%DOCS%%man/man1/nextcloudcmd.1.gz
+%%KDE%%%%QT_PLUGINDIR%%/kf5/kfileitemaction/nextclouddolphinactionplugin.so
+%%KDE%%%%QT_PLUGINDIR%%/kf5/overlayicon/nextclouddolphinoverlayplugin.so
share/applications/com.nextcloud.desktopclient.nextcloud.desktop
-share/caja-python/extensions/syncstate-Nextcloud.py
+%%GNOME%%share/caja-python/extensions/syncstate-Nextcloud.py
share/icons/hicolor/1024x1024/apps/Nextcloud.png
share/icons/hicolor/128x128/apps/Nextcloud.png
share/icons/hicolor/128x128/apps/Nextcloud_error.png
@@ -85,8 +90,8 @@ share/icons/hicolor/72x72/apps/Nextcloud_sync_shared.png
share/icons/hicolor/72x72/apps/Nextcloud_warn.png
share/icons/hicolor/72x72/apps/Nextcloud_warn_shared.png
share/mime/packages/nextcloud.xml
-share/nautilus-python/extensions/syncstate-Nextcloud.py
-share/nemo-python/extensions/syncstate-Nextcloud.py
+%%GNOME%%share/nautilus-python/extensions/syncstate-Nextcloud.py
+%%GNOME%%share/nemo-python/extensions/syncstate-Nextcloud.py
share/nextcloud/i18n/client_TW.qm
share/nextcloud/i18n/client_af.qm
share/nextcloud/i18n/client_ar.qm