aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2025-01-09 12:18:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2025-01-17 08:58:19 +0000
commit01d3683c441704c1f2ed00c44a41ad94baf72a5b (patch)
tree70205faaad6288a0e8a6d1d4be411d55709bea92
parent2017def45f499560d54a57415713474291d450c2 (diff)
x11/pixman: Make OpenMP optional
OpenMP is not available when the base system has been built with WITHOUT_OPENMP in src.conf(5). PR: 283949 Reviewed by: manu
-rw-r--r--x11/pixman/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/x11/pixman/Makefile b/x11/pixman/Makefile
index 80b8c0f070c0..ce937e01ad47 100644
--- a/x11/pixman/Makefile
+++ b/x11/pixman/Makefile
@@ -15,7 +15,13 @@ MESON_ARGS= -Dloongson-mmi=disabled \
-Dgtk=disabled \
-Ddemos=disabled
-OPTIONS_DEFINE= TEST
+OPTIONS_DEFINE= OPENMP TEST
+OPTIONS_DEFAULT= OPENMP
+OPTIONS_EXCLUDE_armv6= OPENMP
+OPTIONS_EXCLUDE_armv7= OPENMP
+OPTIONS_EXCLUDE_powerpc=OPENMP
+
+OPENMP_MESON_ENABLED= openmp
TEST_LIB_DEPENDS= libpng.so:graphics/png
TEST_MESON_ENABLED= libpng tests
@@ -23,14 +29,12 @@ TEST_MESON_ENABLED= libpng tests
.include <bsd.port.options.mk>
.if ${ARCH} == armv6
-MESON_ARGS+= -Darm-simd=enabled \
- -Dopenmp=disabled
+MESON_ARGS+= -Darm-simd=enabled
.else
MESON_ARGS+= -Darm-simd=disabled
.endif
.if ${ARCH} == armv7
-MESON_ARGS+= -Dneon=enabled \
- -Dopenmp=disabled
+MESON_ARGS+= -Dneon=enabled
.else
MESON_ARGS+= -Dneon=disabled
.endif
@@ -58,9 +62,6 @@ MESON_ARGS+= -Dvmx=enabled
.else
MESON_ARGS+= -Dvmx=disabled
.endif
-.if ${ARCH} == powerpc
-MESON_ARGS+= -Dopenmp=disabled
-.endif
.if ${ARCH} == riscv64
MESON_ARGS+= -Drvv=enabled
.else